Announcement

Collapse
No announcement yet.

connecting 851 router and catalyst 2950

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • connecting 851 router and catalyst 2950

    Hi,

    I need help connecting my 851 cisco router and 2950-24 catalyst switch,
    I tried to setup "router on a stick" by creating a dot1q trunk port but i couldn't.
    i understand that because my 851 router has only one vlan (vlan1)
    i can't create a trunk port to the router...
    i tried creating a sub-interface but the only interface i managed to create it on was fast ethernet 4 (connection to the dsl modem).
    can i solve this issue?
    right now i have only one vlan in my switch and the router is
    connected to one of the ports...is this the only way?
    i must have more then one vlan in my router?
    why is sub-interface used to create the trunk?
    what is the right way to connect the router and the swith in my case?

    Thank you in advance!

  • #2
    Re: connecting 851 router and catalyst 2950

    help somebody?

    Comment


    • #3
      Re: connecting 851 router and catalyst 2950

      Here is an example for router on a stick:

      Code:
      851#conf t
      851(config-if)#
      851(config-if)#int fa0/1.1
      851(config-subif)#encapsulation dot1q 1 native
      851(config-subif)#ip add 172.16.1.1 255.255.0.0
      851(config-subif)#
      851(config-subif)#int fa0/1.2
      851(config-subif)#encapsulation dot1q 2
      851(config-subif)#ip add 172.17.1.1 255.255.0.0
      Now you would connect fa 0/1 from the router to fa 0/1 on the switch

      Code:
      2950#
      2950#conf t
      2950(config)#
      2950(config)#int fa 0/1
      2950(config-if)#
      2950(config-if)#switchport mode trunk
      2950(config-if)#
      2950(config-if)#int fa 0/2
      2950(config-if)#switchport mode access
      2950(config-if)#
      2950(config-if)#int fa 0/3
      2950(config-if)#switchport mode access
      2950(config-if)#switchport access vlan 2
      By default all ports are in vlan 1.
      CCNA, Network+

      Comment


      • #4
        Re: connecting 851 router and catalyst 2950

        Daze, Thank you very much for your help

        The problem is that i can't create sub-interfaces in my router (on interfaces fa0-fa3).

        851#conf t
        851(config-if)#
        851(config-if)#int fa1.1

        ^
        % Invalid input detected at '^' marker.

        I can only create a sub-interface on my fa4, my wan port.
        I can't create the trunk between the router and the switch because of that...

        Comment


        • #5
          Re: connecting 851 router and catalyst 2950

          I think you have to create bridged interfaces and route it that way ... however I too am having issues with the same thing... except I have a C3550 and a 857w ... if I figure it out , Ill try to post here as well... meanwhile If i were you, thats what i would look into .. Bvis...

          im assuming that ur 851 is running c850-advsecurityk9-mz......?

          Comment


          • #6
            Re: connecting 851 router and catalyst 2950

            Thank you very much for you help

            can you please explain how can i create bridged interfaces?

            someone suggested me to change my ios to ip services...i don't know
            if it will work on my 851 and i don't want to change my ios for nothing.


            correct, my 851 is running c850-advsecurityk9-mz.124-9

            Comment


            • #7
              Re: connecting 851 router and catalyst 2950

              The 851 has ONLY ONE image available = Advanced Security Image. NO OTHER software images will run on an 851.

              "Bridged ports on a Cisco 851 & 871 series routers"
              http://itknowledgeexchange.techtarge...eries-routers/

              "Overview of Bridging"
              http://www.cisco.com/en/US/docs/ios/...e_Chapter.html

              ! From my 851W
              !
              bridge irb
              !
              !
              !
              interface Vlan1
              description Internal Network
              no ip address
              bridge-group 1
              bridge-group 1 spanning-disabled
              !
              interface BVI1
              description Bridge to Internal Network
              ip address 192.168.1.1 255.255.255.0
              ip virtual-reassembly
              !
              !
              bridge 1 route ip
              !

              Comment


              • #8
                Re: connecting 851 router and catalyst 2950

                From the Cisco 800 Series Q&A Data Sheet. (bold type added)
                Q. How many 802.1q VLANs can be configured on the built-in 4-port switch (Fast Ethernet
                03)?
                A. A maximum of four VLANs are supported on the Cisco 870 Series with the plus feature set
                (Advanced IP Services/Advanced Enterprise Services). The Cisco 850 Series only supports
                one 802.1q VLAN.
                Q. What does the integrated 10/100 switch provide?
                A. All models have an integrated 10/100 four-port switch. The Cisco 870 Series provide
                a managed switch with up to four 802.1Q VLANs in addition to a default VLAN; each switch
                port could be assigned to a different VLAN as desired. Beside the capability to set
                the speed/duplex capabilities on the switch ports, switch port monitoring (SPAN) and
                IGMP Snooping is also supported.
                The Cisco 850 Series has a partially managed switch providing the ability to set the speed and
                duplex capabilities on switch ports, the ability to shut/unshut switch ports, and SNMP
                management. But VLANs are configurable only on the Cisco 870 Series and not the Cisco
                850 Series.
                Regards,

                References:
                Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
                http://www.cisco.com/en/US/docs/rout...e/857swcg.html

                Cisco 851 Data Sheet
                http://www.cisco.com/en/US/prod/coll...d8028a9a9.html

                Cisco 850 870 Q&A Sheet
                http://www.cisco.com/en/US/prod/coll...d8028a982.html

                Comment


                • #9
                  Re: connecting 851 router and catalyst 2950

                  Thank you for your help.

                  I will try bridging and let you know if it works.

                  Comment


                  • #10
                    Re: connecting 851 router and catalyst 2950

                    i'd also make sure cable type is correct ... that was my issue...

                    Comment


                    • #11
                      Re: connecting 851 router and catalyst 2950

                      thank you all for your help!

                      do i need to change this:

                      Interface Vlan1
                      ip nat inside

                      to that:

                      interface BVI1
                      ip nat inside

                      ??

                      after i put vlan1 into bridge-group 1. how do i continue with
                      connecting the switch to the router and routing between the switch vlans?

                      Comment


                      • #12
                        Re: connecting 851 router and catalyst 2950

                        nat is for mapping ips to external routers.. i dont see why you'd have to enable it, unless your also using it to route to public addresses which in that case Yes.
                        then your WAN port would be the

                        ip nat enable / ip nat outside


                        you would be putting BVI 1 as the internal interface for your dot11 and your fastethernet ports, and associating Vlan1 with it.

                        that should allow you to route.. however Im still unsure about the multiple vlans... I haven't tried yet,... i finally got most of my issues resolved..


                        interface Vlan1
                        no ip address
                        no ip proxy-arp
                        ip virtual-reassembly
                        ip tcp adjust-mss 1452
                        bridge-group 1
                        bridge-group 1 spanning-disabled
                        !
                        interface BVI1
                        ip address 10.10.10.1 255.255.255.0
                        no ip proxy-arp
                        ip nat inside
                        ip nat enable
                        ip virtual-reassembly
                        !


                        ill try to do it later this week and report back if your still here... i would appreciate anything you experince w/ as well

                        thanks,

                        p.s: if your using this to route to internet - my experience:
                        add no ip proxy-arp
                        and also dont do your ip route to the interface, but to the IP of next hop address . (arp over flow otherwise..) .

                        Comment


                        • #13
                          Re: connecting 851 router and catalyst 2950

                          my 851 is connected using a pppoe dialer.
                          vlan1 is configured with nat overload
                          so lan hosts can reach the internet.

                          should i configure ip nat inside in bvi?

                          thanks

                          Comment


                          • #14
                            Re: connecting 851 router and catalyst 2950

                            then the dialer should be ip nat outside.


                            http://www.cisco.com/en/US/docs/rout.../pppoenat.html

                            its for your setup PPPoE / with NAT .

                            im sure you already have, but just make sure you have bridge irb enabeled on the router

                            Comment

                            Working...
                            X