Announcement

Collapse
No announcement yet.

Cannot Ping Router

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot Ping Router

    Hey guys, i have a Cisco router 2600 series, and i have fa0/0 with no ip address defined , it has subnets for each vlan in that interface. The router is configured as well as dhcp server giving address in vlan 10. The laptop is connected to port f0/17 that is connected to vlan 10 in a Cisco Switch 3500-XL that is in trunk mode connected in port f0/1 to f0/0 of cisco router. The laptop get ip adresses with no problem ip add 192.168.100.2 . GW 192.168.0.1 and dns 192.168.0.1. On the cisco router again i have the fa0/1 with the ip addr 192.168.0.2 that connects to my adsl router with ip 192.168.0.1.
    Inside the cisco router i can ping the adsl router but cannot ping an ip address of the internet. In the laptop i can ping 192.168.0.2 that belongs to fa0/1 interface of the cisco router but cannot ping 192.168.0.1 that ip the ip of the adsl router. What is missing here?

    regards
    Kevin

  • #2
    Re: Cannot Ping Router

    Can you show us the router config? Sounds like a routing problem.
    CCNA, Network+

    Comment


    • #3
      Re: Cannot Ping Router

      Thx for the answer Daze, the soon i get home ill copy paste it here. See you then.

      Regards
      Kevin

      EDIT: Here are my Cisco 2600 Config

      KCIROUT1>enable
      Password:
      KCIROUT1#sh run
      Building configuration...

      Current configuration : 1047 bytes
      !
      version 12.4
      service timestamps debug datetime msec
      service timestamps log datetime msec
      no service password-encryption
      !
      hostname KCIROUT1
      !
      boot-start-marker
      boot-end-marker
      !
      enable secret 5 $1$zmCS$/50MD5.2lSQ5FcD65IVDF.
      !
      no aaa new-model
      no network-clock-participate slot 1
      no network-clock-participate wic 0
      ip cef
      !
      !
      no ip dhcp use vrf connected
      ip dhcp excluded-address 192.168.100.1
      !
      ip dhcp pool Servidores
      network 192.168.100.0 255.255.255.0
      default-router 192.168.0.1
      dns-server 192.168.0.1
      !
      !
      !
      !
      !
      !
      !
      !
      !
      interface FastEthernet0/0
      no ip address
      duplex auto
      speed auto
      !
      interface FastEthernet0/0.10
      encapsulation dot1Q 10
      ip address 192.168.100.1 255.255.255.0
      !
      interface FastEthernet0/0.20
      encapsulation dot1Q 20
      ip address 192.168.101.1 255.255.255.0
      !
      interface FastEthernet0/1
      ip address 192.168.0.2 255.255.255.0
      duplex auto
      speed auto
      !
      ip forward-protocol nd
      !
      ip http server
      no ip http secure-server
      !
      !
      control-plane
      !
      !
      line con 0
      logging synchronous
      line aux 0
      line vty 0 4
      login
      !
      !
      end

      KCIROUT1#

      Well I just added this to the router config, dont know if it ok or not:

      ip forward-protocol nd
      ip route 0.0.0.0 0.0.0.0 192.168.0.1
      ip route 192.168.0.0 255.255.255.0 192.168.0.1

      any wrong doing that?
      Last edited by kevinguerreiro; 11th August 2009, 00:28. Reason: Adding INfo

      Comment


      • #4
        Re: Cannot Ping Router

        Can you draw, please, the topology that you are using? The only think that I saw in your config is the static route for 192.168.0.1 network : you don't need that line because router already knows it - it's a directly connected network

        Comment


        • #5
          Re: Cannot Ping Router

          Well i have here a drwaing if it helps.

          Kevin
          Attached Files

          Comment


          • #6
            Re: Cannot Ping Router

            Remove this: ip route 192.168.0.0 255.255.255.0 192.168.0.1
            And it should work fine.
            CCNA, Network+

            Comment


            • #7
              Re: Cannot Ping Router

              Hmmm i did that only after it wasent working, but anyway i got it to work. In the adsl router i added a static route to 192.168.100.0 and 192.168.101.0 networks and it started working and can go to the internet with no problem. I thought that by using fa0/1 with 192.168.0.0 subnet i wouldnt have to make a static route on the adsl router, or i dont have to ?

              Kevin

              Comment


              • #8
                Re: Cannot Ping Router

                Is great to hear you solve the issue. No, you don't need to create a static route for a network that is directly connected to one of its interfaces. When you set an IP address on one interface and use "no shutdown" command, the router populates its routing table with that network automatically.

                Comment


                • #9
                  Re: Cannot Ping Router

                  Sorry for answering so late, but was on vacation. Well i had to add a static route to the adsl router for the 192.168.100.0 and 192.168.101.0 subnets, and that is where things started to work. In the Cisco Router i knew that i didn't need to do the route because the router makes the routing between the ethernet ports when configurated. So i have to add the vlan's subnet to the adsl router to work correctly? or i wasent supose to need to do that?

                  Kevin

                  Comment

                  Working...
                  X