Announcement

Collapse
No announcement yet.

Inter-Vlan Issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Inter-Vlan Issues

    Ok so….I am in the process of creating VLANS on my network. I am currently working with a Cisco 2811 for my router and a HP ProCurve 2824 as my core switch. I need to get 4 vlans configured properly and talking to one another. I will worry about the access-lists after I get things working correctly. Here is an overview of my configurations.
    -Router. I have 4 vlans configured on eth 0/1 (.1, .2, .3, .4). I am using dot1q encapsulation. I have no-ip slit horizon configured on vlan1 interface. I want the vlans to share routing updates. I also want them to be able to talk with one another.
    Physical Interface 0/1: no ip address
    VLAN1: 192.168.1.1 (0/1.1)
    VLAN2: 192.168.2.1 (0/1.2)
    VLAN3: 192.168.3.1 (0/1.3)
    VLAN4: 192.168.4.1 (0/1.4)
    -Switch. 4 VLANS configured. All named VLAN 1 – VLAN 4. IP default-gateway set to 192.168.1.1. IP addresses are as follows.
    VLAN1: 192.168.1.2
    VLAN2: 192.168.2.2
    VLAN3: 192.168.3.2
    VLAN4: 192.168.4.2
    All ports are untagged for VLAN1 and all other ports are tagged for VLANs 2-4. Ports 21 and 22 are teamed as a trunk port with (LACP) and tagged in VLANS 2-4 only
    This is a no brainer, however I’ll say it anyway. I have my patch cable going from eth 0/1 on the router to port 21 on the switch.
    Here is what I can do:
    1. From the router, I can ping all the VLAN interfaces on itself. I can ping all the VLAN interfaces on the switch. I can ping a host connected to port 1 on the switch and configured in VLAN1.
    2. From the switch, I can do what I can with the router.
    3. From Host1 on VLAN1, I can ping all vlan interfaces on the router and only the vlan1 interface on the switch.
    4. From host2 on VLAN2, I cannot ping anything and nothing can ping it.
    Prior to someone trying to help, I had the ports tagged differently on the switch and who knows what else was changed. I have looked, however I may have overlooked something.
    I will provide more info as needed, but im kinda fried right now. Any input is appreciated.

    Thanks,
    Shimmy
    Last edited by Shimmy; 23rd July 2009, 14:11.

  • #2
    Re: Inter-Vlan Issues

    A tagged port would be a trunk port and the untagged port would be an access port.
    CCNA, Network+

    Comment


    • #3
      Re: Inter-Vlan Issues

      Thats what i read. However, I get a message from the switch stating that "Only One VLAN can be untagged" Am I confused?

      Thanks
      Shimmy

      Comment


      • #4
        Re: Inter-Vlan Issues

        I see that quite a few ppl have read this. Your replies are appreciated.

        Shimmy

        Comment


        • #5
          Re: Inter-Vlan Issues

          Has anyone out there configured VLANS on their network using a cisco router and an HP 2824 as the core switch? If you can share configs, it would be appreciated, this is really getting on my nerves.

          What I am simply trying to do at this point is make sure the Vlans are configured correctly. and allow communication, between the vlans.

          At this point, I can ping between the router and swich, each vlan interface routers are (192.168.1.1-4.1) switch interfaces are (192.168.1.2-4.2). But for example from host1 on vlan1, I can ping the vlan2 interface on the router, but cannot get to the vlan2 interface on the switch. I have 2 hosts opn the switch, i cannot ping between them.

          any configs are appreciated, so i can compare. I wish I would have known that they would have given me a HP switch. So much easier with all cisco!!!


          Shimmy
          Last edited by Shimmy; 23rd July 2009, 18:57.

          Comment


          • #6
            Re: Inter-Vlan Issues

            Are you using 802.1Q or ISL encapsulation?

            Comment


            • #7
              Re: Inter-Vlan Issues

              For example; the ports that you need on VLAN2, mark them as untagged.
              CCNA, Network+

              Comment


              • #8
                Re: Inter-Vlan Issues

                Hey Joe, Im using 802.1Q.
                Daze, I get the error. anytime i try to untag the port '"Only One VLAN can be untagged"

                Comment


                • #9
                  Re: Inter-Vlan Issues

                  Ok got them talking, let you know if i have any more issues, however configs are still appreciated. To make sure i have this correct and configured in the most efficient manner.

                  Thanks,
                  Shimmy

                  Comment


                  • #10
                    Re: Inter-Vlan Issues

                    Ok question. First I am a dumba$$, I had my routes incorrect. but here is my question for HP gurus. Since I was having that issue with the error "Only One VLAN can be untagged" I set the ports to that do not belong to the vlan as forbid and untagged the ports that belong to each vlan. see my config below:


                    Running configuration:
                    ; J4903A Configuration Editor; Created on release #I.08.98
                    hostname "VLAN_CORE"
                    interface 21
                    no lacp
                    exit
                    interface 22
                    no lacp
                    exit
                    trunk 21-22 Trk1 LACP
                    timesync sntp
                    sntp broadcast
                    snmp-server community "public" Unrestricted
                    vlan 1
                    name "VLAN 1"
                    forbid 6-20,23-24
                    untagged 1-5,Trk1
                    ip address 192.168.1.2 255.255.255.0
                    no untagged 6-20,23-24
                    exit
                    vlan 2
                    name "VLAN 2"
                    forbid 1-5,11-20,23-24
                    untagged 6-10
                    ip address 192.168.2.2 255.255.255.0
                    tagged Trk1
                    exit
                    vlan 3
                    name "VLAN 3"
                    forbid 1-10
                    untagged 11-20,23-24
                    ip address 192.168.3.2 255.255.255.0
                    tagged Trk1
                    exit
                    ip route 192.168.2.0 255.255.255.0 192.168.1.1
                    ip route 192.168.3.0 255.255.255.0 192.168.1.1
                    ip route 192.168.4.0 255.255.255.0 192.168.1.1
                    management-vlan 1
                    spanning-tree Trk1 priority 4



                    ANY input is Great, Thanks everyone.
                    Last edited by Shimmy; 23rd July 2009, 19:41.

                    Comment

                    Working...
                    X