Announcement

Collapse
No announcement yet.

Fiber link problem between Cisco 2960 and 3750

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fiber link problem between Cisco 2960 and 3750

    Hi,

    Our core switch is a 3750. We just purchased a 2960 with a GLC-SX-MM GBIC transceiver. Our 3750 has 1000BASE-SX GBICS. We are using LC-LC -3M Duplex 9/125 SingleMode fibre.

    I have set 'SPEED NONEGOTIATE' on both ends.

    When I connect the 2960 to the 3750, a link light comes up on the 3750, but not on the 2960. The 2960 shows DOWN/DOWN.

    It appears that the 3750 is receiving, but NOT transmitting.

    I've compared the Interface config with others, and it looks good. Anyone else ever seen this? HELP!?

  • #2
    Re: Fiber link problem between Cisco 2960 and 3750

    The GLC-SX-MM, 1000BASE-SX SFP operates on ordinary multimode fiber optic link spans of up to 550 meters in length.

    That SFP need multimode fiber.
    CCNA, Network+

    Comment


    • #3
      Re: Fiber link problem between Cisco 2960 and 3750

      Make sure that your fiber strands at the light box between the switches are crossover. No mater the physical medium connecting to switches will need a crossover. I had the same issue when I first had fiber installed for our network. Hope that helps.

      Comment


      • #4
        Re: Fiber link problem between Cisco 2960 and 3750

        Hi all,


        Thanks for the replies.

        By mistake I have mentioned GLC-SX-MM Transceiver, but we are using GLC-LH-SM Transceiver. And also the cable is crossover singlemode fiber 3M patch cord.

        still the link is not up.

        Kindly help me.....

        Comment


        • #5
          Re: Fiber link problem between Cisco 2960 and 3750

          Can you show the config of both switches?
          CCNA, Network+

          Comment


          • #6
            Re: Fiber link problem between Cisco 2960 and 3750

            I agree a config would be nice, however it still looks like there is a physical layer issue. It is either the fiber or the transciever being used. If you are using a crossover (and I am assuming there is a light box in between the switches and not a direct connect between the two) try changing the fiber cable to a straight through.

            Comment


            • #7
              Re: Fiber link problem between Cisco 2960 and 3750

              Configuration of 2960


              Current configuration : 881 bytes
              !
              version 12.2
              no service pad
              service timestamps debug uptime
              service timestamps log uptime
              no service password-encryption
              !
              hostname QONECAMP_2960
              !
              enable password hdecman
              !
              username QONECAMP_2960
              no aaa new-model
              system mtu routing 1500
              ip subnet-zero
              !
              !
              !
              !
              no file verify auto
              spanning-tree mode pvst
              spanning-tree extend system-id
              !
              vlan internal allocation policy ascending
              !
              interface FastEthernet0/1
              !
              interface FastEthernet0/2
              !
              interface FastEthernet0/3
              !
              interface FastEthernet0/4
              !
              interface FastEthernet0/5
              !
              interface FastEthernet0/6
              !
              interface FastEthernet0/7
              !
              interface FastEthernet0/8
              !
              interface GigabitEthernet0/1
              description Uplink to 3750
              switchport mode trunk
              media-type sfp
              speed nonegotiate
              !
              interface Vlan1
              no ip address
              no ip route-cache
              shutdown
              !
              ip http server
              !
              control-plane
              !
              !
              line con 0
              line vty 0 4
              login
              line vty 5 15
              login
              !
              end





              Configuration of 3750


              Current configuration : 1307 bytes
              !
              version 12.2
              no service pad
              service timestamps debug uptime
              service timestamps log uptime
              no service password-encryption
              !
              hostname QONECAMP_3750
              !
              enable password hdecman
              !
              no aaa new-model
              switch 1 provision ws-c3750g-12s
              system mtu routing 1500
              ip subnet-zero
              !
              !
              !
              !
              no file verify auto
              spanning-tree mode pvst
              spanning-tree extend system-id
              !
              vlan internal allocation policy ascending
              !
              interface GigabitEthernet1/0/1
              switchport mode access
              !
              interface GigabitEthernet1/0/2
              switchport mode access
              !
              interface GigabitEthernet1/0/3
              switchport mode access
              !
              interface GigabitEthernet1/0/4
              switchport mode access
              !
              interface GigabitEthernet1/0/5
              switchport mode access
              !
              interface GigabitEthernet1/0/6
              switchport mode access
              !
              interface GigabitEthernet1/0/7
              switchport mode access
              !
              interface GigabitEthernet1/0/8
              switchport mode access
              !
              interface GigabitEthernet1/0/9
              switchport mode access
              !
              interface GigabitEthernet1/0/10
              switchport mode access
              !
              interface GigabitEthernet1/0/11
              switchport mode access
              !
              !
              description Uplink to 2960
              switchport trunk encapsulation dot1q
              switchport mode trunk
              speed nonegotiate
              !
              interface Vlan1
              no ip address
              !
              ip classless
              ip http server
              !
              !
              control-plane
              !
              !
              line con 0
              line vty 0 4
              login
              line vty 5 15
              login
              !
              end

              Comment


              • #8
                Re: Fiber link problem between Cisco 2960 and 3750

                There are two things the pop out (at least in my mind)

                1. on the trunk port on the 2960 you don't have the encapsulation manually configured to do1.q

                2. on the 3570 trunk port you aren't manually setting the media type

                That's about the only difference(s).

                Comment


                • #9
                  Re: Fiber link problem between Cisco 2960 and 3750

                  can any one help me........still no connectivity...

                  Comment


                  • #10
                    Re: Fiber link problem between Cisco 2960 and 3750

                    Try taking the "nonegotiate" off of one or both interfaces.
                    CCNA, Network+

                    Comment

                    Working...
                    X