Announcement

Collapse
No announcement yet.

VLAN using Cisco aironet 1131

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • VLAN using Cisco aironet 1131

    I am a newbie to VLAN. I will like to set up a VLAN for my wireless connection using Aironet 1131 and Allied Telesis GS950 switch.

    We will have 3 VLANs: Vlan 1 as default vlan, vlan 30 for staff and vlan 250 for guest (hotspot). on the switch, port 2-14 are assigned to vlan30 untagged. port 15-20 are assigned to vlan 250 untagged, port 22 is tagged for vlan 30,250. all ports are also in vlan1 untagged. the switch, for testing purpose, is uplink to a cisco 2600 router on port 3 and 20. the 2600 has multiple ethernet i/f. dhcp are running on both i/f giving out 192.168.30.0 for vlan 30, 192.168.250.0 for vlan250.

    On the aironet, i also have the same 3 vlans, each with a unique SSID. my laptop can see all 3 SSID and i can connect to all three. the problem is if i connect to vlan30, i cannot receive the dhcp though if i connect the laptop directly to the switch, it works. I can connect to vlan250 thru wireless and can get out to the world.
    I am posting the run-config of the 1130 here:

    !
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname uhls-1131
    !
    no logging console
    enable secret 5 $1$Ju1D$2ev
    !
    ip subnet-zero
    ip domain name uhls.lib.ny.us
    !
    !
    no aaa new-model
    dot11 vlan-name UHLS-staff vlan 30
    dot11 vlan-name hotspot vlan 250
    !
    dot11 ssid test
    vlan 250
    authentication open
    guest-mode
    !
    dot11 ssid uhadmin
    vlan 1
    authentication open
    authentication key-management wpa
    infrastructure-ssid
    wpa-psk ascii 7 073A09607D44
    !
    dot11 ssid uhls-staff
    vlan 30
    authentication open
    authentication key-management wpa
    wpa-psk ascii 7 02332C77384B03
    !
    !
    !
    username uhls privilege 15 password 7 13101F1
    !
    bridge irb
    !
    !
    interface Dot11Radio0
    no ip address
    no ip route-cache
    !
    encryption vlan 1 mode ciphers aes-ccm tkip
    !
    encryption vlan 30 mode ciphers aes-ccm tkip
    !
    ssid test
    !
    ssid uhadmin
    !
    ssid uhls-staff
    !
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    station-role root
    !
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    no ip route-cache
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    !
    interface Dot11Radio0.30
    encapsulation dot1Q 30
    no ip route-cache
    bridge-group 30
    bridge-group 30 subscriber-loop-control
    bridge-group 30 block-unknown-source
    no bridge-group 30 source-learning
    no bridge-group 30 unicast-flooding
    bridge-group 30 spanning-disabled
    !
    interface Dot11Radio0.250
    encapsulation dot1Q 250
    no ip route-cache
    bridge-group 250
    bridge-group 250 subscriber-loop-control
    bridge-group 250 block-unknown-source
    no bridge-group 250 source-learning
    no bridge-group 250 unicast-flooding
    bridge-group 250 spanning-disabled
    !
    interface FastEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    !
    interface FastEthernet0.1
    encapsulation dot1Q 1 native
    no ip route-cache
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    !
    interface FastEthernet0.30
    encapsulation dot1Q 30
    no ip route-cache
    bridge-group 30
    no bridge-group 30 source-learning
    bridge-group 30 spanning-disabled
    !
    interface FastEthernet0.250
    encapsulation dot1Q 250
    no ip route-cache
    bridge-group 250
    no bridge-group 250 source-learning
    bridge-group 250 spanning-disabled
    !
    interface BVI1
    ip address 192.168.30.247 255.255.255.0
    no ip route-cache
    !
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779...onfig/help/eag
    !
    bridge 1 protocol vlan-bridge
    bridge 1 route ip
    bridge 30 protocol vlan-bridge
    bridge 250 protocol vlan-bridge
    !
    !
    !
    line con 0
    line vty 0 4
    login local
    !
    end

    One final note. if i connect a host to the switch directly on either vlan, it works.

    Any idea why it does not work. Also, must i assign a port for vlan1 on the switch. if not, what will happen?
Working...
X