Announcement

Collapse
No announcement yet.

MTU issue on pppoe and 1841

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MTU issue on pppoe and 1841

    Greetings to all.

    I have a Cisco 1841 with 2 ethernet Interfaces.
    1 interface is used for LAN interface and the other is connected to a ADSL2+ router (configured as bridge) and dials a pppoe connection.
    The problem is that i have some connectivity and speed problems to some sites.
    While searching for a solution i read that it might be a MTU problem.
    Knowing that the optimal MTU value for pppoe is 1492 i have configured the router based on this:
    http://www.ciscosystems.com/en/US/te...80093bc7.shtml
    You can see the configuration of the router at the attached "sh run.txt".
    I have seen some improvement but some problems still exist.
    As you can see in the "sh int.txt" although i have configured a MTU value of 1492 for Dialer0 ,i still have a MTU of 1500.
    How can i force it to be 1492?
    Must i configure MTU to all interfaces?

    Best Regards.
    Attached Files

  • #2
    Re: MTU issue on pppoe and 1841

    Hi tech25,

    If you haven't figured this out I would love to take a crack at this. Looking at your running-config you have the mtu set to 1492 which according to the link you provided recommends. However I did notice that you haven't explicitly stated the MSS which is different from the MTU. That document states that the recommended MSS is 1452.

    I would keep the other interface set to there default. Set the Dialer0 interface with a MTU of 1492 and a MSS of 1452. The setting only affect the exit interface which in your case is your Dialer0.

    Ryan

    Comment


    • #3
      Re: MTU issue on pppoe and 1841

      Originally posted by ryansmitty View Post
      Hi tech25,

      If you haven't figured this out I would love to take a crack at this. Looking at your running-config you have the mtu set to 1492 which according to the link you provided recommends. However I did notice that you haven't explicitly stated the MSS which is different from the MTU. That document states that the recommended MSS is 1452.

      I would keep the other interface set to there default. Set the Dialer0 interface with a MTU of 1492 and a MSS of 1452. The setting only affect the exit interface which in your case is your Dialer0.

      Ryan
      Hello there Ryan.

      Thank you for your answer
      Unfortunately it didn't work..

      I have configured the router via SDM and it auto configured the mss value on ethernet 0/0 (my lan interface).As you can see i have configured it accordingly to 1452.
      Never the less i have configured a mss value to dialer 0 as well, but with no luck..

      Comment


      • #4
        Re: MTU issue on pppoe and 1841

        int di0
        ...
        ip inspect SDM_LOW out

        I would change to ip inspect SDM_LOW in.

        Since you should trust traffic going out your network.

        Comment


        • #5
          Re: MTU issue on pppoe and 1841

          The problem was here
          interface Dialer0
          ..
          ..
          ip inspect SDM_LOW out
          ip ips sdm_ips_rule in
          ip ips sdm_ips_rule out

          I have removed "ip ips sdm_ips_rule out" and everything works like a charm

          Comment

          Working...
          X