No announcement yet.

VLAN Config on OLD 2900XL switch

  • Filter
  • Time
  • Show
Clear All
new posts

  • VLAN Config on OLD 2900XL switch

    So, I've been studying for my CCNA, and I just got an old (IOS compiled in July 2000) 2900XL switch.

    I'm having trouble configuring vlans on this switch.
    The switch does not recognize the global config mode 'vlan' command. So, I can't make vlans or change vlans by going in that way. (Note: typing 'v?' at the command prompt shows that vtp and vmps are the only two commands starting with v)

    I was thinking I was out of luck, but then I tried going into one of the fast ethernet interfaces and typing 'switchport access vlan 50' and it worked!

    Going to privilege mode and typing 'show vlan,' sure enough, I had a new VLAN!

    Now, I guess this works, but I was also hoping that I could name my VLANs and delete my VLANs and so forth, but without the 'vlan' command, I'm lost!

    I don't have another switch, so I can't just hook up another switch and have VTP overwrite all the VLAN stuff for me.

    And speaking of VTP, in global config mode, my only option for the 'vtp' command is 'file,' no 'vtp domain <name>,' no 'vtp mode <s/c/t>,' etc...

    Does anybody have any experience with older Cisco switches and know how to work with VLANs (and VTP) on them?

    Last edited by zenmonkey; 17th April 2009, 06:23. Reason: added some more stuff

  • #2
    Re: VLAN Config on OLD 2900XL switch

    If you drop 2900 command reference into the cisco search you should be able to see a list of the commands depending on the software version of the switch.
    "show ver" should give you this info. Might be worth having a look there?

    Please read this before you post:

    Quis custodiet ipsos custodes?