Announcement

Collapse
No announcement yet.

Can't access my server from the internet behind a Cisco Ruter

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't access my server from the internet behind a Cisco Ruter

    I have a 3662 cisco router and I'm trying to access a mail server by hostname from outside the local network. I have ip nat setup properly i believe, yet i can not access my server on port 80. I looked in my router, but the whole NAT thing is still somewhat confusing. I've read lots of documentation on it but things still aren't quite working. I have a local machine on int 0/0 with private ip 192.168.1.11, i want to forward certain ports from the public IP to this server, port 80, 443, plus others. Any help is appreciated. I'll post my running-cnfig file here, maybe someone can tell me where I screwed up. Thanks again.

    resource policy
    !
    !
    !
    ip cef table adjacency-prefix validate
    ip cef
    ip domain name rcserveny.com
    ip name-server 167.206.112.138
    ip name-server 167.206.7.4
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip nat allow-static-host
    ip nat enable
    ip virtual-reassembly
    speed auto
    full-duplex
    !
    interface FastEthernet0/1
    ip address 96.56.78.172 255.255.255.248
    ip nat outside
    ip nat allow-static-host
    ip nat enable
    ip virtual-reassembly
    speed auto
    full-duplex
    !
    router rip
    redistribute connected
    network 96.0.0.0
    network 192.168.1.0
    !
    ip default-gateway 96.56.78.169
    no ip http server
    !
    ip route 0.0.0.0 0.0.0.0 96.56.78.169
    !
    ip nat log translations syslog
    ip nat source static tcp 192.168.1.11 21 interface FastEthernet0/1 21
    ip nat source static tcp 192.168.1.11 80 interface FastEthernet0/1 80
    ip nat inside source list 1 interface FastEthernet0/1 overload
    ip nat inside source static tcp 192.168.1.1 443 interface FastEthernet0/1 443
    ip nat inside source static tcp 192.168.1.11 80 interface FastEthernet0/1 80
    ip nat inside source static tcp 192.168.1.1 636 interface FastEthernet0/1 636
    ip nat inside source static tcp 192.168.1.11 389 interface FastEthernet0/1 389
    ip nat inside source static tcp 192.168.1.11 563 interface FastEthernet0/1 563
    ip nat inside source static tcp 192.168.1.11 119 interface FastEthernet0/1 119
    ip nat inside source static tcp 192.168.1.11 993 interface FastEthernet0/1 993
    ip nat inside source static tcp 192.168.1.11 995 interface FastEthernet0/1 995
    ip nat inside source static tcp 192.168.1.11 465 interface FastEthernet0/1 465
    ip nat inside source static tcp 192.168.1.11 143 interface FastEthernet0/1 143
    ip nat inside source static tcp 192.168.1.11 110 interface FastEthernet0/1 110
    ip nat inside source static tcp 192.168.1.11 25 interface FastEthernet0/1 25
    ip nat inside source static tcp 192.168.1.101 5900 interface FastEthernet0/1 420
    ip nat inside source static tcp 192.168.1.12 22 interface FastEthernet0/1 22
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    dialer-list 1 protocol ip permit
    snmp-server community public RO
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    gateway
    timer receive-rtp 1200
    !
    !
    line con 0
    line aux 0
    line vty 0 4

  • #2
    Re: Can't access my server from the internet behind a Cisco Ruter

    Hi ,

    Please clear mentioned below question

    1) You want to access you office mail box from your home .AM i correct or wrong .
    2) If first point is corect then i suppose you are using public ip .
    3) If second point is correct then have you tried opening with public ip ..If yes then are you able to access your mailbox?
    4)are you able to telnet on port 80 & 443 from your home PC.

    Please let us know the result of mentioned questions


    Cheers
    DT

    Comment

    Working...
    X