Announcement

Collapse
No announcement yet.

cisco 2621 config not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • cisco 2621 config not working

    a new config has been loaded on our cisco 2621 to setup a new internet connection, can anyone help? sanitized ip's but should still make sense.

    From the test pc on 333.333.333.2
    I can ping 333.333.333.1 (my routers internal ip)
    I can also ping 444.444.444.170 (my routers outside ip)
    I cannot ping 444.444.444.169 (my provider, the next hop)
    I cannot ping outside ipís (traceroute indicates it is trying to go out router)
    From router I can ping everywhere

    If I plug in a Linksys wired Ethernet router and configure the same ip addresses I am routed everywhere


    =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2009.03.17 21:13:38 =~=~=~=~=~=~=~=~=~=~=~=
    show run
    Building configuration...
    Current configuration : 1353 bytes
    !
    version 12.2
    no parser cache
    no service single-slot-reload-enable
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    no service alignment logging
    no service dhcp
    !
    hostname aaaaaaaaaa
    !
    logging rate-limit console 10 except errors
    enable secret 5
    enable password
    !
    !
    !
    clock timezone EST -5
    clock summer-time EDT recurring
    ip subnet-zero
    no ip source-route
    ip cef
    !
    !
    ip name-server 4.2.2.1
    !
    no ip dhcp-client network-discovery
    call rsvp-sync
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 444.444.444.170 255.255.255.252
    duplex auto
    speed auto
    !
    interface Serial0/0
    no ip address
    shutdown
    !
    interface FastEthernet0/1
    ip address 333.333.333.1 255.255.255.224
    no ip mroute-cache
    duplex auto
    speed auto
    !
    interface ATM1/0
    no ip address
    shutdown
    no atm ilmi-keepalive
    !
    router eigrp 200
    redistribute static
    network 444.444.444.168 0.0.0.3
    network 333.333.333.0 0.0.0.31
    auto-summary
    no eigrp log-neighbor-changes
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
    no ip http server
    !
    !
    !
    snmp-server community RO
    !
    dial-peer cor custom
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    password
    login
    line vty 5 15
    password
    login
    !
    no scheduler allocate
    ntp clock-period 17180238
    ntp server 63.73.218.130 prefer
    !
    end

  • #2
    Re: cisco 2621 config not working

    This doesn't make sense to me. You're using FE0/0 as an external interface to connect to the ISP? What type of circuit is it?

    Comment


    • #3
      Re: cisco 2621 config not working

      ethernet (that's why i was able to use a wired ethernet router to test the circuit

      Comment


      • #4
        Re: cisco 2621 config not working

        Hey Mike,

        A question for you... Is the LAN IP range perchance one of the private ones (10.x.x.x, 172.16.x.x -172.31.x.x, 192.168.x.x)?

        If so your problem is a lack of NAT. Linksys, because of the intended market, tend to automatically perform NAT, Cisco routers won't until you tell them to.

        Stuart

        Comment


        • #5
          Re: cisco 2621 config not working

          Do this to the FE 0/0:
          ip nat outside

          And this to the FE 0/1
          ip nat inside
          CCNA, Network+

          Comment


          • #6
            Re: cisco 2621 config not working

            both interfaces are public ips

            Comment


            • #7
              Re: cisco 2621 config not working

              I think that spramwell and Daze are right. I didn't catch that yesterday but I believe you need to configure a NAT pool for the internal hosts. I don't think the router will perform automatic NAT. When an internal host sends traffic externally the router needs to NAT the internal host address to an external address and keep that translation in a NAT or PAT table to keep track of that session. If you have no NAT pool then the internal to external traffic will die at the router as the RFC1918 address aren't routable on a public network.

              Comment


              • #8
                Re: cisco 2621 config not working

                Here i am getting confused

                How you can use EIGRP routing protocol with linksys router as EIGRP is Cisco property protocol


                Cheers
                DT

                Comment

                Working...
                X