Announcement

Collapse
No announcement yet.

877W Config Issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 877W Config Issues

    I have a Network Discovery issue with my new 877W router. I recently migrated from a Linksys Wireless router where I was able to access any PC, wired or wireless, on my network from ANY other PC on the network. (If I insert my linksys between the devices on the network and the 877W, Discovery works and I can communicate with everything!)

    LAN IP = 10.10.10.1
    WLAN IP = 10.10.11.1


    With my 877W, I am able to access other PCs that are connected to the 4-port switch but from the wireless devices, I cannot see or communicat with any other device. The exception is my network printer which is connected to the LAN and the port seting was set up manually in the printer prot setup.

    All PCs are able to communicate on the internet without issues os I know this is not a problem with the Wireless Security (per se)!

    Here is my current configuration copied from the router:



    I have been busting my brain (actually the one last remaining "Gray Cell" I have) for a month now. I have recieved a a few suggestions on how to overcome the problem but nothing has worked thus far.

    I suspect that this can be resolved with 3 to 5 lines of code and that it has to do with VLAN setup and bridging.

    Each PC on my network has a specific function from image processing to printing to storage. Because of my location (rental apartment) a wired network is not an option. I must have a fully functional mixed network.

    I would appreciate any help I can get and will be eternally grateful.

    John

  • #2
    Re: 877W Config Issues

    Current configuration : 6018 bytes

    aaa new-model
    !
    !
    aaa authentication login local_auth local
    !
    aaa session-id common
    !
    resource policy

    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.10.1
    ip dhcp excluded-address 10.10.11.1
    !
    ip dhcp pool sdm-pool
    import all
    network 10.10.10.0 255.255.255.0
    default-router 10.10.10.1
    dns-server 66.82.4.8 205.171.2.65 4.2.2.2 4.2.2.4
    lease 0 2
    !
    ip dhcp pool Wireless
    import all
    network 10.10.11.0 255.255.255.0
    default-router 10.10.11.1
    dns-server 66.82.4.8 205.171.2.65 4.2.2.2 4.2.2.4
    lease 0 2
    !
    crypto pki certificate chain TP-self-signed-3677562

    certificate self-signed 01
    quit

    !
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    no atm ilmi-keepalive
    bundle-enable
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    description $ES_WAN$
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    pvc 0/32
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet0
    switchport mode trunk
    !
    interface FastEthernet1
    switchport mode trunk
    !
    interface FastEthernet2
    switchport mode trunk
    !
    interface FastEthernet3
    switchport mode trunk
    !
    interface Dot11Radio0
    ip address 10.10.11.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    ip virtual-reassembly
    !
    encryption mode ciphers tkip
    !
    ssid Hermesz_Home
    max-associations 25
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 7 097C1A1D1123461C0F5F16022E36
    !
    speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 asic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
    channel 2427
    station-role root
    !
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
    ip address 10.10.10.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    !
    interface Dialer0
    description $FW_OUTSIDE$
    ip address negotiated
    ip verify unicast source reachable-via rx allow-default 100
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname [THIS IS ME]
    ppp chap password 7 0252340C3E341E0A66
    ppp pap sent-username [My UserName] password 7 [My Password]
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    !
    no ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat inside source list 1 interface Dialer0 overload
    !
    !
    logging trap debugging
    logging facility local2
    access-list 1 permit 10.10.10.0 0.0.0.255
    access-list 1 permit 10.10.11.0 0.0.0.255
    access-list 100 permit udp any any eq bootpc
    dialer-list 1 protocol ip permit
    no cdp run
    !
    !
    control-plane
    !
    banner login ^CAuthorized access only!
    Disconnect IMMEDIATELY if you are not an authorized user!^C
    banner motd ^CIf you are UNAUTHORIZED, Get OFF!^C
    !
    line con 0
    exec-timeout 5 0
    login authentication local_auth
    no modem enable
    transport output telnet
    line aux 0
    login authentication local_auth
    transport output telnet
    line vty 0 4
    privilege level 15
    password 7 06071D20481B501B
    login authentication local_auth
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    end

    Comment


    • #3
      Re: 877W Config Issues

      Hi John,

      At a guess I would imagine that the Linksys places all devices, whether they are wired or wireless on the same subnet therefore allowing network discovery.

      The 877W has wired devices on the 10.10.10.0 subnet and the wireless on the 10.10.11.0 subnet and routes between them. The difference is that broadcasts (used to perform network discovery) are not passed between subnets.

      Stuart

      Comment


      • #4
        Re: 877W Config Issues

        This IS the crux of the problem. However, being able to print go an network printer located at 10.10.10.250 from a wireless PC located at 10.10.11.100 tells me that it is possible to see and communicate with devices on a different subnet. The reading I have done also bears this out!

        Thus far, I have not been able to implement this.

        John

        Comment


        • #5
          Re: 877W Config Issues

          John,

          Printing cross subnet does not require network discovery, as long as the device which wishes to print is aware of the correct address for the printer it would still work.

          I suspect from what you say that the printer was configured with this address prior to connection to the 877W and has maintained the same address. As the Wireless clients use DHCP to acquire an IP address they would simply forward traffic destined for the printer to the default gateway as they would already know that the printer was on a different subnet. Network discovery would have played no part in your ability to print.

          Stuart

          Comment


          • #6
            Re: 877W Config Issues

            Stuart

            According to all the information I have read, Cisco routers are able to route traffic (enable discovery) in a community in such a way that devices on different submasks are discoverable by one another. My understanding is that this is implemented via VLANs.

            My question was, and still is, How do I implement this? What changes to my configuration do I need to make and how do I do this?

            John

            Comment


            • #7
              Re: 877W Config Issues

              John,

              OK... This is possible using VLAN bridging but isn't something I have ever personally set up. Give me an hour or two to look into it and I'll come back with a solution for you....

              Stuart

              Comment


              • #8
                Re: 877W Config Issues

                John,

                OK, first things first. Before making these changes please make sure that you save your current running-config so that if this doesn't work you can reboot the router and return to your existing config. Do not save the running-config until you are happy that this solution works. Better still if you have some TFTP software make a back up of the startup-config file.

                The way that this works is to configure settings relating to VLAN1 on the wireless interface, create a bridging group for VLAN1 and assign a sub interface on the Wireless interface to the bridging group. From what I understand this will then force your wireless clients to use the same subnet as the wired LAN and so make the 10.10.11.0 DHCP pool redundant.

                The commands are as follows:

                conf t
                ip dhcp excluded-address 10.10.10.1 10.10.10.2
                int dot11radio 0
                no ip address 10.10.11.1 255.255.255.0
                encryption vlan 1 mode ciphers tkip
                ssid Hermesz_Home
                vlan 1
                exit
                exit
                bridge irb
                interface vlan 1
                bridge-group 1
                interface bvi 1
                bridge 1 route ip
                ip address 10.10.10.2 255.255.255.0
                interface dot11radio 0.1
                encapsulation dot1q 1 native
                no cdp enable
                bridge-group 1
                exit
                exit


                No guarantees this will work as I have never configured a router this way, I've tended to use stand alone WAPs so, as I said, don't save the config until you've tested it and are happy with it.

                Please let me know if this works for my own future reference.

                Stuart

                Comment


                • #9
                  Re: 877W Config Issues

                  Did this work?

                  Comment


                  • #10
                    Re: 877W Config Issues

                    Sorry for the delay in getting back here. was called out of state on a contract and just got back.

                    I tried your suggestion but still could not get things to work. I finally restored the router to factory defaults and did a clean config. Still the same issues.

                    Attached it the new config. Still looking for help on this.

                    Comment

                    Working...
                    X