Announcement

Collapse
No announcement yet.

Cisco ip-helper

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco ip-helper

    Hi all,

    I have the following problem.

    We have a cisco router configured with a ip-helper address

    Now when the packet is received by the DHCP server than it sees a broadcast addres of 0.0.0.0 it should receive an adres of the subnet of the router (172.22.20).

    This way it doesn't send a ip-adres.

    see config below:

    Code:
    !
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime localtime
    service timestamps log datetime localtime
    service password-encryption
    service sequence-numbers
    no service dhcp
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 51200 debugging
    logging console critical
    enable secret ****************
    !
    no aaa new-model
    !
    resource policy
    !
    clock timezone CET 1
    ip subnet-zero
    ip cef
    !
    !
    ip tcp synwait-time 10
    ip domain lookup
    !
    !
    username **************** privilege 15 secret ****************
    !
    !
    controller DSL 0
     mode atm
     line-term cpe
     line-mode 2-wire line-zero
     dsl-mode shdsl symmetric annex B
     line-rate auto
    !
    !
    !
    interface ATM0
     no ip address
     ip route-cache flow
     no atm ilmi-keepalive
     dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
     pvc 0/35
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
       !
    !
    interface FastEthernet0
     duplex full
     speed 100
    !
    interface FastEthernet1
     duplex full
     speed 100
    !
    interface FastEthernet2
     duplex full
     speed 100
    !
    interface FastEthernet3
     duplex full
     speed 100
    !
    interface Vlan1
     ip address 172.22.2.251 255.255.255.0
     ip helper-address 130.45.5.66
     ip directed-broadcast
     ip virtual-reassembly
     ip route-cache flow
      ip tcp adjust-mss 1452
    !
    interface Dialer0
     ip address negotiated
     no ip redirects
     no ip unreachables
     ip virtual-reassembly
     encapsulation ppp
     ip route-cache flow
     dialer pool 1
     no cdp enable
     ppp authentication pap callin
     ppp pap sent-username **************** password ****************
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    !
    logging trap debugging
    !
    !
    dialer-list 1 protocol ip permit
    no cdp run
    !
    control-plane
    !
    banner login ^Cbanner login Authorized access only!
     Disconnect IMMEDIATELY if you are not an authorized user!^C
    !
    line con 0
     login local
     no modem enable
    line aux 0
    line vty 0 4
     privilege level 15
     login local
     transport input telnet ssh
    !
    scheduler max-task-time 5000
    scheduler allocate 4000 1000
    scheduler interval 500
    end
    Last edited by danny230681; 16th February 2009, 16:29.

  • #2
    Re: Cisco ip-helper

    I believe the ip-helper-address command needs to be on a physical interface (the interface that is connected to the LAN where the broadcasts originate) and not on the VLAN interface. You should put the ip-helper-address on all FE interfaces if you have DHCP clients connected to all these interfaces.

    Comment


    • #3
      Re: Cisco ip-helper

      Ok, tried that but i cannot enter the ip helper on an physical interface..

      Comment


      • #4
        Re: Cisco ip-helper

        I think you can configure a Vlan interface with the Ip helper-address.
        If its only DHCP traffic you are concerned about you could try the following instead of the Ip helper-address:-
        ip forward-protocol udp bootpc
        ip forward-protocol udp bootps

        or alternatively add the following with the Ip helper-address
        no ip forward-protocol udp netbios-ns
        no ip forward-protocol udp netbios-dgm
        no ip forward-protocol udp domain
        no ip forward-protocol udp time
        no ip forward-protocol udp tacacs
        no ip forward-protocol udp tftp

        if you already have provisions on the Lan or don't need any of them.

        Ta
        Caesar's cipher - 3

        ZKHQ BRX HYHQWXDOOB GHFLSKHU WKLV BRX ZLOO UHDOLVH LW ZDV D ZDVWH RI WLPH!

        SFX JNRS FC U6 MNGR

        Comment

        Working...
        X