Announcement

Collapse
No announcement yet.

Trouble Configuring EIGRP with 2503

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble Configuring EIGRP with 2503

    Hi, just joined, first post, please be kind i'm still learning

    I'm studying for a Network degree in Glasgow, and to help me along i bought 3 2503's quite cheaply to practice at home. I had no idea the 2500's were now discontinued (i think), and ive been having a few problems with configuring them as we use 2600's at uni and some of the commands dont work on the 2500's, but ive found fixes for most of the problems.

    However, whenever i try to configure EIGRP using the strange subnet mask thing (sorry, i dont know what you call it, dont even know if they told us), i get an error like this.

    R3(config)#router eigrp 100
    R3(config-router)#network 10.0.0.0
    R3(config-router)#network 172.16.0.0
    R3(config-router)#network 192.168.0.0 0.0.31.255
    ^
    % Invalid input detected at '^' marker.

    *the up arrow is below the first 0 in the second lot (the strat of the subnet mask thing), no idea why its showing as being at the start of the line when i paste it in.

    Just wondering if anybody knew of a way round this, or if it is even possible with 2500's.

    Cheers,

    Gary.

  • #2
    Re: Trouble Configuring EIGRP with 2503

    Instead of the wildcard mask you also can use subnet mask eg
    Network 192.168.0.0 255.255.255.0

    It should be clever enough to change it for you
    Marcel
    Technical Consultant
    Netherlands
    http://www.phetios.com
    http://blog.nessus.nl

    MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
    "No matter how secure, there is always the human factor."

    "Enjoy life today, tomorrow may never come."
    "If you're going through hell, keep going. ~Winston Churchill"

    Comment


    • #3
      Re: Trouble Configuring EIGRP with 2503

      Wildcard mask!!! Thats it. God i'd forget my head if it wasnt screwed on.

      Thanks Dumber, i'll give it a bash.

      It would still like to use the widcard mask though if anybody knows why it i'm getting the error, as i'm trying to go through all the lab books we had so i dont forget anything, as the routing class is over now but we never got to do every book.

      Cheers again

      Comment


      • #4
        Re: Trouble Configuring EIGRP with 2503

        I've the same problem with my head

        Well try it with the subnet mask.
        Then do a show run and see what the output is for it.

        However, I tried your command "network 192.168.0.0 0.0.31.255" and it simply worked over here.
        I don't see that quickly where it's going wrong
        Marcel
        Technical Consultant
        Netherlands
        http://www.phetios.com
        http://blog.nessus.nl

        MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
        "No matter how secure, there is always the human factor."

        "Enjoy life today, tomorrow may never come."
        "If you're going through hell, keep going. ~Winston Churchill"

        Comment


        • #5
          Re: Trouble Configuring EIGRP with 2503

          Hi again Dumber. Glad i'm not the only one with the head problem, lol.

          Tried the subnet mask, but it doesn't like that either. I'm assuming its these 2500 series routers.

          Here's what ive put since booting up there, and the ^ errors are at the start of the wildcard mask and the subnet mask.


          R1>en
          R1#telnet 10.1.1.3
          Trying 10.1.1.3 ... Open

          R3>en
          Password:
          R3#conf t
          Enter configuration commands, one per line. End with CNTL/Z.
          R3(config)#router eigrp 100
          R3(config-router)#network 192.168.0.0 0.0.31.255
          ^
          % Invalid input detected at '^' marker.

          R3(config-router)#network 192.168.0.0 255.255.255.0
          ^
          % Invalid input detected at '^' marker.

          R3(config-router)#


          Here's a show run as well


          R3(config-router)#^Z
          R3#sh run
          Building configuration...

          Current configuration:
          !
          version 11.2
          no service password-encryption
          no service udp-small-servers
          no service tcp-small-servers
          !
          hostname R3
          !
          enable password
          !
          ip subnet-zero
          !
          interface Loopback1
          ip address 192.168.1.1 255.255.254.0
          !
          interface Loopback5
          ip address 192.168.5.5 255.255.254.0
          !
          interface Loopback9
          ip address 192.168.9.9 255.255.254.0
          !
          interface Loopback13
          ip address 192.168.13.13 255.255.254.0
          !
          interface Loopback17
          ip address 192.168.17.17 255.255.254.0
          !
          interface Loopback21
          ip address 192.168.21.21 255.255.254.0
          !
          interface Loopback25
          ip address 192.168.25.25 255.255.254.0
          !
          interface Loopback100
          ip address 10.1.3.1 255.255.255.252
          !
          interface Loopback172
          ip address 172.16.1.1 255.255.255.252
          !
          interface Ethernet0
          no ip address
          shutdown
          !
          interface Serial0
          no ip address
          shutdown
          no fair-queue
          !
          interface Serial1
          ip address 10.1.1.3 255.255.255.248
          bandwidth 64
          !
          interface BRI0
          no ip address
          shutdown
          !
          router eigrp 100
          network 10.0.0.0
          network 172.16.0.0
          no auto-summary
          !
          no ip classless
          !
          line con 0
          exec-timeout 0 0
          line aux 0
          line vty 0 4
          no login
          !
          end

          R3#
          Last edited by Dumber; 4th February 2009, 11:12.

          Comment


          • #6
            Re: Trouble Configuring EIGRP with 2503

            I'm curious, what if you leave out the subnet mask?
            So just network 192.168.0.0
            Marcel
            Technical Consultant
            Netherlands
            http://www.phetios.com
            http://blog.nessus.nl

            MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
            "No matter how secure, there is always the human factor."

            "Enjoy life today, tomorrow may never come."
            "If you're going through hell, keep going. ~Winston Churchill"

            Comment


            • #7
              Re: Trouble Configuring EIGRP with 2503

              If i do that it works fine, but i'm not sure if it defeats the purpose of the excercise, as it's about 'Summarization and Default Network Advertisement'. So i'm trying to do it exactly as it says in the lab book.

              I had problems with bad mask using a /29 subnet mask, but i discovered putting ip subnet-zero solved that, and there were a few other things that didnt work because i was using 2500's but ive found ways round it, so i'm asssuming it must be the same for this one, but i cant see anybody else with the same problem through googling.

              Baffling, lol.

              Comment

              Working...
              X