Announcement

Collapse
No announcement yet.

2620xm SLOW ADSL when using the WIC-1ADSL

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2620xm SLOW ADSL when using the WIC-1ADSL

    Hello..
    I have a 2620xm router with AT&T DSL 6000/768 service....

    When I setup pppoe using the WIC-1ADSL my speed is 2369Kbps... (DSL>>Router>>Lan)

    When I setup pppoe with a DSL modem infront of the router my speed is 5460Kbps.... (DSL Modem>>Router>>Lan)

    The 2620xm info:
    IOS c2600-adventerprisek9-mz.124-19
    48mb Flash/256mb Ram
    2 FastEthernet interfaces
    1 Serial interface
    1 ATM interface

    Current Config:

    !
    ! Last configuration change at 15:27:30 CDT Tue Jan 6 2009
    ! NVRAM config last updated at 14:15:59 CDT Tue Jan 6 2009
    !
    version 12.4
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    !
    hostname xxxxxxx
    !
    boot-start-marker
    boot-end-marker
    !
    logging count
    logging buffered 16000 debugging
    logging console informational
    enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxx
    enable password 7 xxxxxxxxxxxxxxxxxxxx
    !
    no aaa new-model
    clock timezone CDT -6
    clock summer-time CDT recurring
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    ip domain name xxxxxxxxxxxx
    ip name-server xxxxxxxxxxxx
    ip name-server xxxxxxxxxxxx
    ip name-server xxxxxxxxxxxx
    ip name-server xxxxxxxxxxxx
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    ip ddns update method sdm_ddns1
    DDNS both
    !
    ip ddns update method sdm_ddns2
    HTTP
    add xxxxxxxxxxx-members.dyndns.org/nic/update?system=dyndns&hostname/nic/update?system=dyndns&hostname=<h>&myip=
    !
    remove xxxxxxxxxxx-members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=
    interval maximum 28 0 0 0
    interval minimum 28 0 0 0
    !
    !
    username xxxxxx privilege 15 view root secret 5 xxxxxxxxxxxxxxxxxxxxx
    !
    !
    !
    !
    buffers tune automatic
    !
    !
    !
    interface FastEthernet0/0
    description (LAN) xxxxxxxxx-ISA 2006 Server$ETH-LAN$
    ip address xxxxxxxxxxxx xxxxxxxxxxxxxxx
    ip access-group 100 in
    ip helper-address xxxxxxxxxxxxx
    ip mask-reply
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1460
    speed 100
    full-duplex
    no mop enabled
    !
    interface Serial0/0
    no ip address
    shutdown
    no fair-queue
    !
    interface ATM0/1
    description (WAN) AT&T ADSL
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    dsl enable-training-log
    hold-queue 224 in
    !
    interface ATM0/1.1 point-to-point
    pvc 0/35
    pppoe-client dial-pool-number 1
    !
    !
    interface FastEthernet1/0
    description (DMZ)
    ip address xxxxxxxxxxxx xxxxxxxxxxx
    ip helper-address xxxxxxxxxxx
    ip nat inside
    ip virtual-reassembly
    speed 100
    full-duplex
    !
    interface Dialer0
    description Virtual Dial Interface
    ip ddns update hostname xxxxxxxxxxxxxxx
    ip ddns update sdm_ddns2
    ip address negotiated
    ip mtu 1492
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication pap callin
    ppp pap sent-username [email protected] password 7 xxxxxxxxxxxxxxxxx
    ppp ipcp dns request
    ppp ipcp route default
    !
    ip forward-protocol nd
    !
    !
    ip http server
    ip http access-class 1
    no ip http secure-server
    ip nat inside source list 2 interface Dialer0 overload


    *** NAT INFO REMOVED BECAUSE OF SIZE ***


    !
    logging trap debugging
    logging xxxxxxxxxxxx
    logging xxxxxxxxxxxx


    ***ACL LIST REMOVED BECAUSE OF SIZE ***


    dialer-list 1 protocol ip permit
    snmp-server community public RW
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    transport preferred none
    speed 115200
    line aux 0
    line vty 0 4
    access-class 101 in
    password 7 xxxxxxxxxxxxxx
    login
    transport preferred none
    !
    ntp logging
    ntp clock-period 17180358
    ntp server xxxxxxxxxxx source FastEthernet0/0 prefer
    !
    end

    I have attached some of the SHOW INTERFACE commands......


    I know this is a huge post but I am posting all information possible......


    Thanks.......I am just not sure if I missed a command somewhere....

    I would be thankful for ANY help or information.....

    Dave
    Attached Files

  • #2
    Re: 2620xm SLOW ADSL when using the WIC-1ADSL

    I was persistent in solving the issue......so I dug deep into every bit of Cisco documentation I could find...

    The speed issue is resolved...

    - Using the WIC-1ADSL

    - No DSL modem in front of the router...

    - Both Upload/Download speed and latency is actually BETTER than it was before....


    Thanks once again.......
    Last edited by Scorpion69; 9th January 2009, 06:07.

    Comment


    • #3
      Re: 2620xm SLOW ADSL when using the WIC-1ADSL

      I'm glad you sorted it but would you mind explaining what you did for the benefit of others?
      cheers
      Andy

      Please read this before you post:


      Quis custodiet ipsos custodes?

      Comment


      • #4
        Re: 2620xm SLOW ADSL when using the WIC-1ADSL

        We have been experiencing the same issue as you describe, and we even have the same exact IOS version, please do describe what it was that you were able to do to resolve the speed issues with the wic card. I have searched documentation and almost given up, with the cisco it goes half the speed of without it. We have the need for the device so we are still using it at the slow speeds.

        We have the same 2621XM with the same IOS, hoping that you can help solve this issue once and for all!!!


        WAREHOUSE#show ver
        Cisco IOS Software, C2600 Software (C2600-ADVENTERPRISEK9-M), Version 12.4(19), RELEASE SOFTWARE (fc1)
        Technical Support: http://www.cisco.com/techsupport
        Copyright (c) 1986-2008 by Cisco Systems, Inc.
        Compiled Fri 29-Feb-08 19:23 by prod_rel_team
        ROM: System Bootstrap, Version 12.2(7r) [cmong 7r], RELEASE SOFTWARE (fc1)
        WAREHOUSE uptime is 2 days, 42 minutes
        System returned to ROM by reload
        System image file is "flash:c2600-adventerprisek9-mz.124-19.bin"

        Comment


        • #5
          Re: 2620xm SLOW ADSL when using the WIC-1ADSL

          Hello....

          The information or the "FIX" came after hours of reading thru tons of Cisco documents.....but this is the document where I found the setting needed....http://ciscosystems.com/en/US/docs/r...L.html#wp38589

          Now go to the section :

          Configuring the SCC Clock Rate

          Communciation between a DSL WIC and the host in a router takes place through a device called a serial communications controller (SCC). Whenever the host wants to transmit data or send any control traffic to the DSL WIC, it uses an SCC. Similarly, when a DSL WIC wants to forward incoming data from the line to the host, it also uses an SCC. Each DSL WIC installed in a router uses two SCCs. One SCC, SCC-A, is used for ATM adaptation layer 5 (AAL5) data traffic, while the other, SCC-B, is used for ATM adaptation layer 2 (AAL2) data traffic and for control traffic. The speed at which an SCC transfers data between the host and the WIC depends on the clock rate with which the SCC has been configured. This clock rate is configured by the user, and it is always synchronous. The SCC clock rate is the same whether the WIC is sending or receiving data through the SCC. For an asynchronous DSL (ADSL) WIC, the SCC clock rate should be set slightly higher than the larger of the DSL line rates (upstream or downstream). It is recommended that the SCC clock rate always be set higher than the DSL line rate to accommodate any SCC overhead.
          SCC Clock Rate Configuration

          The following example is a configuration of SCC clock rates on an ATM interface. Clock rates are set with the clock rate aal5 command and the clock rate aal2 command. On Cisco 1700 series routers, valid clock rates are in the range from 4 Mbps to 8 Mbps. The clock rate values are entered as bits per second, as shown in the example.
          interface ATM0/0

          no ip address

          clock rate aal5 5300000

          clock rate aal2 4000000

          no atm ilmi-keepalive

          bundle-enable

          bundle ama-bundle12

          !

          dsl operating-mode auto

          end


          Note It is strongly recommended that on Cisco 1700 series routers, the SCC clock rate be set to the default value of 8 Mbps (8000000 bps).

          Note When an SCC clock rate is deconfigured on a Cisco 1700 series router by using the no form of the command, it is reset to the default value of 8 Mbps.
          SCC Clock Rate Verification

          To verify the configuration of the SCC clock rate, use the show controller command. SCC-A represents the clock rate for AAL5, while SCC-B represents the clock rate for AAL2.
          Router#show controller atm0/0



          To answer your question I added the following command for my 6016/768 service:

          clock rate aal5 7000000
          clock rate aal2 1000000



          Here is my SHOW Interface:

          Stinger#SHOW CONTROLLERS ATM0/1
          Interface: ATM0/1, Hardware: DSLSAR (with Alcatel ADSL Module), State: up
          IDB: 84F27908 Instance: 84F28A1C reg_dslsar:67000400 wic_regs: 67000480
          PHY Inst:84F4F1CC Ser0Inst: 84F15D14 Ser1Inst: 84F1EB08 us_bwidth:768
          Slot: 0 Unit: 1 Subunit: 1 pkt Size: 4528
          VCperVP: 256 max_vp: 256 max_vc: 65536 total vc: 1
          rct_size:65536 vpivcibit:16 connTblVCI:8 vpi_bits: 8
          vpvc_sel:3 enabled: 0 throttled: 0 cell drops: 0
          Last Peridic Timer 09:02:45.032(32565032)
          Parallel reads to TCQ:0 tx count reset = 0, periodic safe start = 0
          Attempts to overwrite SCC txring: 0
          Host Controller lockup recovery Info:
          recovery count1= 0, recovery count2= 0
          Saved Host Controller Info to check any lockup:
          scc = 0, output_qcount = 0, head:10,
          buf addr = 0x00000000, serial outputs = 41336
          scc = 1, output_qcount = 0, head:8,
          buf addr = 0x00000000, serial outputs = 56
          Serial idb(AAL5) output_qcount:0 max:40
          Serial idb(RAW) output_qcount:0, max:40
          Sar ctrl queue: max depth = 10, current queue depth = 0, drops = 0, urun cnt = 0, total cnt = 56
          Serial idb tx count: AAL5: 41336, RAW: 56, Drop count:AAL5: 0, RAW: 0
          Host Controller Clock rate Info:
          SCC Clockrates:
          SCC0 = 0
          SCC1 = 7000000 (ATM0/1)
          SCC2 = 1000000 (ATM0/1)
          SCC3 = 0




          I sure hope it works for you because I posted in the cisco forums and got no answers.....and I have seen ALOT of posts where people had the same issue.......give up.........and just installed the DSL modem infront of the router...

          Well with the money I spent on a 2620xm router .....and maxing out the flash and ram.....I was determined to find the fix.


          There are a few other TWEAKS I did...but lets see if that works for you first......


          BTW.....I am running IOS c2600-adventerprisek9-mz.124-21.bin now....


          Please let me know if this works for you.....

          Later...good luck...

          Dave
          Last edited by Scorpion69; 11th January 2009, 01:12.

          Comment


          • #6
            Re: 2620xm SLOW ADSL when using the WIC-1ADSL

            A good read, many thanks for taking the time to get back and explain how your sorted it. Much appreciated.
            cheers
            Andy

            Please read this before you post:


            Quis custodiet ipsos custodes?

            Comment


            • #7
              Re: 2620xm SLOW ADSL when using the WIC-1ADSL

              Yes, immediate change, once i put the clock rate for the aal5 on the ATM0/0 interface, we lost connectivity while the interface reset itself. Once it came back the speed was increased 2 fold, from under 2.5 meg to well over 5.5 meg now. This is the fix, thank you for taking the time to post it back here so that it also has resolved a major issue for me.

              Comment


              • #8
                Re: 2620xm SLOW ADSL when using the WIC-1ADSL

                Excellent....glad it's working for you now........

                Comment


                • #9
                  Re: 2620xm SLOW ADSL when using the WIC-1ADSL

                  Community in action
                  cheers
                  Andy

                  Please read this before you post:


                  Quis custodiet ipsos custodes?

                  Comment


                  • #10
                    Re: 2620xm SLOW ADSL when using the WIC-1ADSL

                    Let me know if I can be of further assistance..........

                    Dave

                    Comment


                    • #11
                      Re: 2620xm SLOW ADSL when using the WIC-1ADSL

                      Sure stay around and try to reply to others
                      Marcel
                      Technical Consultant
                      Netherlands
                      http://www.phetios.com
                      http://blog.nessus.nl

                      MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
                      "No matter how secure, there is always the human factor."

                      "Enjoy life today, tomorrow may never come."
                      "If you're going through hell, keep going. ~Winston Churchill"

                      Comment

                      Working...
                      X