Announcement

Collapse
No announcement yet.

Opening Ports Here and There

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Opening Ports Here and There

    Well to Start off, here is my running config.

    Code:
    McLeodNetworks#sh ru 
    Building configuration... 
    
    Current configuration : 1103 bytes 
    ! 
    version 12.3 
    service timestamps debug uptime 
    service timestamps log uptime 
    no service password-encryption 
    ! 
    hostname McLeodNetworks 
    ! 
    boot-start-marker 
    boot-end-marker 
    ! 
    enable secret xxxxxxxxxxxxxxxxxxxx 
    enable password xxxxxxxxxxxxxxxxx 
    ! 
    no aaa new-model 
    ip subnet-zero 
    ip cef 
    ! 
    ! 
    ip dhcp excluded-address 1.0.0.1 1.0.0.99 
    ! 
    ip dhcp pool McLeodNetworks 
       network 1.0.0.0 255.0.0.0 
       default-router 1.0.0.1 
       dns-server 68.87.77.130 68.87.72.130 
       lease 0 5 
    ! 
    ! 
    ! 
    ! 
    ! 
    ! 
    interface Ethernet0/0 
     description Comcast Cable Modem 
     ip address dhcp 
     ip nat outside 
     half-duplex 
    !          
    interface Serial0/0 
     no ip address 
     shutdown 
    ! 
    interface Ethernet0/1 
     description Cisco 2924-XL Switch 
     ip address 1.0.0.1 255.0.0.0 
     ip nat inside 
     half-duplex 
    ! 
    ip nat inside source list 100 interface Ethernet0/0 overload 
    ip nat inside source static 1.0.0.74 interface Ethernet0/0 
    ip http server 
    ip classless 
    ! 
    ! 
    access-list 100 permit ip any any 
    banner motd ^C 
    McLeod Networks Main Router (Cisco 2611) Authorized Staff Only! 
    ^C 
    ! 
    line con 0 
    line aux 0 
    line vty 0 1 
     password <some password>
     login 
    line vty 2 4 
     login 
    ! 
    ! 
    end
    Using the config above, i have my router setup so that 1.0.0.74 goes to the outside world. Lets say i want to have socket 1.0.0.75:80 go to the outside world instead of 1.0.0.74:80. But i want to leave all the other ports open on 1.0.0.74.

    Is this possible?

    Kinda complicated but basically, you have the asterisk server that uses random ports and then i have a web server that is on port 80 (web) and 21 (ftp).

    Thanks


    <edit dumber: removed password in the vty config>
    Last edited by Dumber; 18th January 2009, 12:08.

  • #2
    Re: Opening Ports Here and There

    I think your wording is a little confusing. What you currently have is all internet traffic being forwarded to 1.0.0.74.

    You want tcp port 80 traffic to go to x.x.x.75 while all other traffic goes to x.x.x.74?

    Or you want to be able to access both servers on port 80 (not possible with only one global IP). You'd have to use an alternate port. I'd just change asterisk web interface to use 8080 or something. But I'd need a better description to fully understand and make good suggestions.
    -Tim

    Comment


    • #3
      Re: Opening Ports Here and There

      Well, i want all internet traffic but port 80, 21, and 1723 to go to x.x.x.74.

      For all internet traffic on port 80, 21, and 1723 i want it to go to x.x.x.75.

      I dont need to manage the asterisk server remotely, so that isnt an issue.

      Is that clear enough? sorry to not provide enough

      Comment


      • #4
        Re: Opening Ports Here and There

        i tried doing this but it didnt work

        Code:
        ip nat inside source static tcp 1.0.0.75 80 interface Ethernet0/0 80
        ip nat inside source static 1.0.0.74 interface Ethernet0/0
        any suggestions?

        Comment

        Working...
        X