Announcement

Collapse
No announcement yet.

Cisco 877W & PS3

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco 877W & PS3

    Hello, this is my first post and I want to say hello to all the community.
    I'm writing from Italy...sorry for my bad english

    I have a great problem with Playstation 3 connected via WIFI to my Cisco 877W.

    When I start the connection Test on PS3 it return the following message:

    "your router does not support IP Fragmentation"

    I have just tried to change the MTU value on the BVI interface (and on PS3, obviously), but nothing change.

    When I start the test, these are the logs on the router:

    10.2.88 is the IP reserved via DHCP to PS3.

    Dec 23 20:59:15.044: %IP_VFR-3-OVERLAP_FRAGMENTS: BVI2: from the host 10.2.88.100 destined to 198.107.159.129

    Dec 23 20:59:16.644: %IP_VFR-3-SYSTEM_ERROR: BVI2: IP VFR System failure - Unable to create fragment chain
    Dec 23 20:59:16.644: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=83D06F10, count=0, -Traceb
    ack= 0x808DA290 0x8030919C 0x8141424C 0x814150A4 0x81415C6C 0x8141750C 0x80C3A2C4 0x807BE2D4 0x807BE
    434 0x80390D98 0x803B3740 0x803B6F78 0x8039EB6C 0x80484B10 0x80369148 0x8008590C

    Dec 23 20:59:16.644: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=83D15A78, count=0, -Traceback= 0x808DA290 0x8030919C 0x80385E08 0x807BE29C 0x807BE434 0x80390D98 0x803B3740 0x803B6F78 0x8039E
    B6C 0x80484B10 0x80369148 0x8008590C 0x8008590C 0x80369208 0x81107910 0x811079A8
    The BVI interface is configured as follow:

    interface BVI2
    ip address 10.2.88.1 255.255.255.0
    ip access-group DMZ in
    ip mtu 1492
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    and this is part of the running conf:

    ...
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 8/35
    pppoe-client dial-pool-number 1
    !
    bundle-enable
    dsl operating-mode auto
    !
    ...

    interface Dot11Radio0.2
    encapsulation dot1Q 2
    no cdp enable
    bridge-group 2
    bridge-group 2 subscriber-loop-control
    bridge-group 2 spanning-disabled
    bridge-group 2 block-unknown-source
    no bridge-group 2 source-learning
    no bridge-group 2 unicast-flooding
    !

    ...

    interface Vlan2
    no ip address
    ip tcp adjust-mss 1452
    no autostate
    bridge-group 2
    !

    ...

    interface Dialer0
    ip address negotiated
    ip access-group 101 in
    ip mtu 1492
    ip nat outside
    ip inspect Firewall out
    ip virtual-reassembly
    encapsulation ppp
    ip tcp header-compression
    ip tcp adjust-mss 1452
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap pap callin
    ppp chap hostname xxxx
    ppp chap password 0 xxx
    ppp pap sent-username xxxx password 0 xxxx
    !

    ...

    interface BVI2
    ip address 10.2.88.1 255.255.255.0
    ip access-group DMZ in
    ip mtu 1492
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    !

    ...

    ip nat inside source list 1 interface Dialer0 overload
    !
    ip access-list extended DMZ
    deny ip 10.2.88.0 0.0.0.255 10.1.88.0 0.0.0.255 log
    deny ip 10.2.88.0 0.0.0.255 192.168.1.0 0.0.0.255 log
    permit ip any any
    !
    access-list 1 remark *** ACL PER PAT E NAT ***
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 1 permit 10.1.88.0 0.0.0.255
    access-list 1 permit 10.2.88.0 0.0.0.255
    access-list 101 remark ################################################## ###########
    access-list 101 remark ### ACL PER TRAFFICO DA INTERNET AL ROUTER ##################
    access-list 101 remark *** VARI ************************************************** **
    access-list 101 permit tcp any any established
    access-list 101 permit tcp host 192.168.1.3 any eq telnet
    access-list 101 remark *** RISOLUZIONE NOMI DNS ************************************
    access-list 101 permit udp host 208.67.222.222 eq domain any
    access-list 101 permit udp host 208.67.220.220 eq domain any
    access-list 101 remark *** ICMP ************************************************** **
    access-list 101 permit icmp host 192.168.1.3 any
    access-list 101 permit icmp any any echo-reply
    access-list 101 permit icmp any any ttl-exceeded
    access-list 101 remark *** EMULE ************************************************** *
    access-list 101 permit tcp any any eq 4662
    access-list 101 permit udp any any eq 4672
    access-list 101 remark *** TORRENT *************************************************
    access-list 101 permit tcp any any eq 1755
    access-list 101 permit udp any any eq 1755
    access-list 101 remark *** NTP ************************************
    access-list 101 permit udp host 207.46.232.42 eq ntp any
    access-list 101 permit udp host 192.43.244.18 eq ntp any
    access-list 700 permit xxxx.daaf.xxxx 0000.0000.0000
    access-list 700 permit xxxx.6f3d.xxxx 0000.0000.0000
    access-list 700 permit xxxx.f607.xxxx 0000.0000.0000
    access-list 700 permit xxxx.d939.xxxx 0000.0000.0000
    access-list 700 deny 0000.0000.0000 ffff.ffff.ffff
    dialer-list 1 protocol ip permit
    Please help me!

  • #2
    Re: Cisco 877W & PS3

    under the dot11radio interface try this command: fragment-threshold value x

    Use different values for x and see what happens.
    -Tim

    Comment


    • #3
      Re: Cisco 877W & PS3

      Originally posted by kornface13 View Post
      under the dot11radio interface try this command: fragment-threshold value x

      Use different values for x and see what happens.

      Nothing
      I have used these values 256 512 768 1024 1280 ... 2346 (max possible), but the result is the same: The router does not support ip fragment.

      Comment


      • #4
        Re: Cisco 877W & PS3

        Wow...well this sucks. Your device most definately supports fragmentation, so I wonder why it's doing this. The only thing I can think of is......buy a 360? haha, just kidding.
        -Tim

        Comment


        • #5
          Re: Cisco 877W & PS3

          I don't know which version you have, but for the 2800 series i found:
          http://www.cisco.com/en/US/docs/ios/.../124TCAVS.html
          Symptoms: Cisco 2800 router crashes after displaying the following error messages:

          %IP_VFR-3-SYSTEM_ERROR: BVIxx:: IP VFR System failure - Unable to create fragment
          chain Sep 11 09:27:57.493: %SYS-2-BADSHARE: Bad refcount in datagram_done,
          ptr=4AEF7C74, count=0 +Traceback Sep 11 09:27:57.497: %SYS-2-BADSHARE: Bad refcount in
          datagram_done, ptr=4AADBB9C, count=0 + Traceback

          Conditions: Occurs on a Cisco 2800 running Cisco IOS Release 12.4(22)T. The router is configured for IRB and has NAT and "ip virtual-reassembly" enabled on the BVI-interface.

          Workaround: There is no workaround.
          Marcel
          Technical Consultant
          Netherlands
          http://www.phetios.com
          http://blog.nessus.nl

          MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
          "No matter how secure, there is always the human factor."

          "Enjoy life today, tomorrow may never come."
          "If you're going through hell, keep going. ~Winston Churchill"

          Comment


          • #6
            Re: Cisco 877W & PS3

            I have just read this article....

            Workaround: There is no workaround.
            What mean this???
            Die with Cisco's benediction???

            My IOS is 12.4(22)T (the last released), but I don't think the problem is on the IOS...

            Comment


            • #7
              Re: Cisco 877W & PS3

              Well this is the problem I guess...
              The router is configured for IRB and has NAT and "ip virtual-reassembly" enabled on the BVI-interface.
              Marcel
              Technical Consultant
              Netherlands
              http://www.phetios.com
              http://blog.nessus.nl

              MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
              "No matter how secure, there is always the human factor."

              "Enjoy life today, tomorrow may never come."
              "If you're going through hell, keep going. ~Winston Churchill"

              Comment


              • #8
                Re: Cisco 877W & PS3

                Ok.
                What kind of action you suggest me?

                I have just disabled the virtual reassembly on the bvi interface (no ip virtual-reassembly)...what can I do? Disabling the NAT???
                Last edited by alfnetx; 31st December 2008, 17:19.

                Comment


                • #9
                  Re: Cisco 877W & PS3

                  Did you ever get your Fragmentation problem solved? I had the same issues with my 1721 router connecting wireless over a 1200 AP. I then statically nated my PS3 with all ports open. Then lowered the MTU from 1492 (typical for ADSL over PPPoE) to 1452 and adujsted the MSS to 1412. Then I manually entered the MTU on my PS3 and the problem was solved! BUT!!!! After a recent update on my PS3 I'm getting the same fragmentation issues with NAT type 2 errors. Come to think of it I also removed the static NAT entry.

                  I tried lowering the MTU and MSS values to even less, but same problems persist. I can howerver still play online although I don't get proper ping response times (Warhawk will show all servers except the first one with ping of ???? and audio seems gargled).

                  I'm wondering if this has something to do with the wireless part or if the PS3 has to be statically NATed. Tonight I will try to do a static NAT and connect over ethernet to see if this makes any difference.

                  Any other tips would be of great help!

                  Comment

                  Working...
                  X