Announcement

Collapse
No announcement yet.

Cisco 1760 with DNS not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco 1760 with DNS not working

    Hi Everyone,

    I have a Cisco 1760 running a configuration i thought was working however i now discoverd that all dns queries are being served from my secondary dns provider and the secondary dns provider has not been able to sync with my primary one thus serving old data.

    I have allowed Port 53 both TCP and UDP am i missing something? my configuration is below (Any comments or suggestions on improving the config is also most welcome):

    Thanks.

    R001#show config
    Using 1768 out of 29688 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname R001
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $4$zGGa$/feJj.6AhD/Loie7BesTB0
    !
    no aaa new-model
    clock timezone UTC 10
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    !
    !
    !
    !
    ip cef
    no ip domain lookup
    vpdn enable
    !
    !
    !
    !
    !
    !
    interface ATM0/0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 8/35
    pppoe-client dial-pool-number 1
    !
    !
    interface FastEthernet0/0
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    speed auto
    !
    interface Dialer1
    mtu 1492
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    ppp chap hostname [email protected]
    ppp chap password 7
    ppp pap sent-username [email protected] password 7
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer1
    no ip http server
    !
    ip nat inside source list 1 interface Dialer1 overload
    ip nat inside source static tcp 192.168.0.15 21 interface Dialer1 21
    ip nat inside source static tcp 192.168.0.15 25 interface Dialer1 25
    ip nat inside source static tcp 192.168.0.15 53 interface Dialer1 53
    ip nat inside source static udp 192.168.0.15 53 interface Dialer1 53
    ip nat inside source static tcp 192.168.0.15 80 interface Dialer1 80
    ip nat inside source static tcp 192.168.0.15 110 interface Dialer1 110
    !
    !
    access-list 1 permit any
    !
    !
    !
    control-plane
    !
    !
    line con 0
    speed 115200
    line aux 0
    line vty 0 4
    login
    !
    ntp source FastEthernet0/0
    ntp server 192.168.0.10
    ntp server 192.168.0.10 source FastEthernet0/0 prefer
    end

  • #2
    Re: Cisco 1760 with DNS not working

    This sounds more like server problem than a router config problem. You are forwarding ports to your DNS server I guess, correct? Primary or secondary dns server is on the 192.168.0.x network?
    -Tim

    Comment

    Working...
    X