Announcement

Collapse
No announcement yet.

QoS on Cisco 3560

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • QoS on Cisco 3560

    Hi All,
    I am having issues setting up and achieving the desired thoroughput after applying QoS. I would like to prioritze citrix application, but when our office uses FTP to transfer big files to another office, citrix users experience very slow network, even sometimes they can't use it while FTP is on. Below is a trunkated running config and couple of show output detail. Please advise if there's anything to make it better? Thank you.

    mls qos map cos-dscp 0 8 10 26 34 46 48 56
    mls qos
    class-map match-any BULK
    match access-group name QOS_bulk_data
    class-map match-any VOICE_TRAFFIC
    match access-group name QOS_voice
    class-map match-any CRITICAL_DATA
    match access-group name QOS_critical_data
    class-map match-any VIDEO
    match access-group name QOS_video
    !
    !
    policy-map VOICE
    class VOICE_TRAFFIC
    set dscp ef
    class VIDEO
    set dscp af41
    class BULK
    set dscp af11
    class CRITICAL_DATA
    set dscp af31
    !

    interface FastEthernet0/21
    switchport access vlan 443
    switchport mode access
    mls qos vlan-based
    !
    interface FastEthernet0/22
    switchport access vlan 443
    switchport mode access
    mls qos vlan-based
    no mdix auto
    !
    interface FastEthernet0/23
    switchport access vlan 443
    switchport mode access
    mls qos vlan-based
    no mdix auto
    !
    interface FastEthernet0/24
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 57,199
    switchport mode trunk
    priority-queue out
    mls qos trust dscp
    interface Vlan443
    ip address 172.24.7.1 255.255.255.0
    service-policy input VOICE
    !
    ip access-list extended QOS_bulk_data
    remark QOS Classification for bulk data
    permit tcp any any eq ftp
    permit tcp any any eq ftp-data
    permit tcp any any eq smtp
    permit tcp any eq ftp any
    permit tcp any eq ftp-data any
    permit tcp any eq smtp any
    permit tcp any eq www any
    permit tcp any any eq www
    permit tcp any eq 443 any
    permit tcp any any eq 443
    ip access-list extended QOS_critical_data
    remark QOS Classification for critical data
    permit tcp any any eq 1494
    permit tcp any eq 1494 any
    permit tcp any eq 2598 any
    permit tcp any any eq 2598
    ip access-list extended QOS_video
    remark QOS Classification for video
    ip access-list extended QOS_voice

    abx-rsw-001.abx.nsw#show policy-map interface input
    Vlan443
    Service-policy input: VOICE
    Class-map: VOICE_TRAFFIC (match-any)
    0 packets, 0 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: access-group name QOS_voice
    0 packets, 0 bytes
    5 minute rate 0 bps
    Class-map: VIDEO (match-any)
    0 packets, 0 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: access-group name QOS_video
    0 packets, 0 bytes
    5 minute rate 0 bps
    Class-map: BULK (match-any)
    64 packets, 72667 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: access-group name QOS_bulk_data
    64 packets, 72667 bytes
    5 minute rate 0 bps
    Class-map: CRITICAL_DATA (match-any)
    215 packets, 19722 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: access-group name QOS_critical_data
    215 packets, 19722 bytes
    5 minute rate 0 bps
    Class-map: class-default (match-any)
    9006 packets, 2758073 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: any
    9006 packets, 2758073 bytes
    5 minute rate 0 bps
    abx-rsw-001.abx.nsw#show access-lists
    Extended IP access list QOS_bulk_data
    10 permit tcp any any eq ftp
    20 permit tcp any any eq ftp-data
    30 permit tcp any any eq smtp (46 matches)
    40 permit tcp any eq ftp any
    50 permit tcp any eq ftp-data any
    60 permit tcp any eq smtp any (6 matches)
    70 permit tcp any eq www any (1 match)
    80 permit tcp any any eq www (11 matches)
    90 permit tcp any eq 443 any
    100 permit tcp any any eq 443
    Extended IP access list QOS_critical_data
    10 permit tcp any any eq 1494
    20 permit tcp any eq 1494 any
    30 permit tcp any eq 2598 any
    40 permit tcp any any eq 2598 (215 matches)
    Extended IP access list QOS_video
    Extended IP access list QOS_voice
Working...
X