Announcement

Collapse
No announcement yet.

Cannot ping through Cisco 1841

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot ping through Cisco 1841


    Hi to all. I am new to Cisco routers and just managed to find this forum. I have a Cisco 1841 with two Ethernet interfaces that I am trying to setup.

    Setup
    I have one PC (PC #1) connected to FA0/0 with an IP Address of 172.31.3.60 /24 and a gateway of 172.31.3.1. I have a second PC (PC#2) connected to FA0/1 with an IP Address of 172.18.5.8 and a gateway of 172.18.5.9

    Issue
    From the Router, I have verified that both interfaces are in an UP / UP State. Both router interfaces and both PCís show up in the ARP table on the router. I can ping both router interfaces both PC,s from the router. From PC #1, I canít ping PC #2 and the reverse is also true. When I attempt this ping, I can only reach the FastEthernet interface that I am connected to.


    This is the running config of the router:

    !version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    no logging buffered
    !
    no aaa new-model
    !
    resource policy
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip subnet-zero
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    !
    !
    !
    !
    interface FastEthernet0/0
    description LAN A
    ip mask-reply
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    description LAN B
    ip address 172.18.5.9 255.255.255.0
    ip mask-reply
    duplex auto
    speed auto
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 permanent
    !
    ip http server
    !
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    end


    Can someone please give me an idea of what I am missing and actions I should take to correct the issue.

    Thanks in advance

  • #2
    Re: Cannot ping through Cisco 1841

    HI, obwalker

    Looking at your config your FA0/0 doesn't have an ip address for starters. Second just out of curiosity why are you using the ip mask reply command? From a security standpoint that command is a no no. Anyways let me know if I can be of any more help.

    Ryan

    Comment


    • #3
      Re: Cannot ping through Cisco 1841

      Those lines were left out as I copied and pasted the config into the post. I verified that this was the case. Re-tested my issue with no changes in my issue.

      Here is the complete config with FA0/0 correct information:

      !version 12.4
      service timestamps debug datetime msec
      service timestamps log datetime msec
      no service password-encryption
      !
      hostname Router
      !
      boot-start-marker
      boot-end-marker
      !
      no logging buffered
      !
      no aaa new-model
      !
      resource policy
      !
      mmi polling-interval 60
      no mmi auto-configure
      no mmi pvc
      mmi snmp-timeout 180
      ip subnet-zero
      ip cef
      !
      !
      !
      !
      no ip domain lookup
      !
      !
      !
      !
      interface FastEthernet0/0
      description LAN A
      ip address 172.31.3.1 255.255.255.0
      ip mask-reply
      ip mask-reply
      duplex auto
      speed auto
      !
      interface FastEthernet0/1
      description LAN B
      ip address 172.18.5.9 255.255.255.0
      ip mask-reply
      duplex auto
      speed auto
      !
      ip classless
      ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 permanent
      !
      ip http server
      !
      !
      control-plane
      !
      !
      line con 0
      line aux 0
      line vty 0 4
      login
      !
      end

      Comment


      • #4
        Re: Cannot ping through Cisco 1841

        have you verified that you have the correct subnet masks and default gateways configured on the pc's? Also are you connecting the PC's directly to the router interfaces? If so, you need a to use crossover cables.

        Ryan

        Comment

        Working...
        X