Announcement

Collapse
No announcement yet.

Cisco 877 and 857 ADSL routers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco 877 and 857 ADSL routers

    Hi im new on this forum and quite new on Cisco hw too...

    I bought a brand new Cisco 877 router with a ADSLoPOTS interface. I moved on through the SDM wizard to set the router up and all went well until I connected the ADSL line to the router. It shows on the SDM that the interface is up in the configure GUI but on the Overview it shows the interface DOWN.

    This i've tried to get fixed for about three weeks and when I couldnt get it working I did another stupid move... I went on thinking it might be something wrong with the 877 so I bought another Cisco router, a 857...

    But guess what, I have EXACTLY the same problem with that one so now I got two expensive routers lying around doing nothing and have to use my old Linksys RVS4000 using PPPoE connected to a bridged Speedtouch 546i modem. And I really need a Cisco router working cuz I need a VPN connection to our 5550 ASA at work

    Any ideas? (any help would be appretiated)


    BTW (here is the config of the 877):

    This is the running config of the router: XX.XX.XX.XX
    ----------------------------------------------------------------------------
    !version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !
    hostname XXXX
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 51200
    logging console critical
    enable secret 5 $1$hGaD$r3SYXegK3B2naoes4xzqr.
    !
    no aaa new-model
    clock timezone PCTime 1
    clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
    !
    crypto pki trustpoint TP-self-signed-888454089
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-888454089
    revocation-check none
    rsakeypair TP-self-signed-888454089
    !
    !
    crypto pki certificate chain TP-self-signed-888454089
    certificate self-signed 01
    30820249 308201B2 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
    30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
    69666963 6174652D 38383834 35343038 39301E17 0D303230 33303130 30313130
    315A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
    532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3838 38343534
    30383930 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
    C1A17F25 46FD0744 43306CB9 BFA94A54 174B841A 1B7F04E6 6092A4A8 8174CB7F
    CE977D2B 760C9346 E31D7E3C 9164DDA4 88977201 D22E3B40 01FCC437 34CFE042
    467F03D7 A24E1692 24EBD6D2 8C28151F E67E4F6F F6A954DD BF306924 0C991F98
    0ED87FF1 373B4ADF B2EA8CA2 96705FF3 FA907450 F11270C4 C19BAFC8 464AF56B
    02030100 01A37330 71300F06 03551D13 0101FF04 05300301 01FF301E 0603551D
    11041730 1582134F 72656967 2E6F7265 69672E6D 696E652E 6E75301F 0603551D
    23041830 1680142C 8321112E A871E3A7 857DD730 E68BCCE1 4D24D530 1D060355
    1D0E0416 04142C83 21112EA8 71E3A785 7DD730E6 8BCCE14D 24D5300D 06092A86
    4886F70D 01010405 00038181 005D7E16 2729AD79 6EC58161 07D24F98 01992149
    7B579788 1F2E4642 4A1E2C4C 6C5212AA 28FA1A01 73C4FAA3 3C18ADC6 704C3F48
    00231678 49F7F383 8479BD8C 06AED0FA 3F34F6BD D976966B 63ECD35C 50F525C4
    F89DA153 6299786B F3AED5D3 1C9C37F4 0C8CF764 C0116BE4 666EDC82 FC1D55BB
    FDE4AD75 6AF00142 65AA154E 7B
    quit
    dot11 syslog
    no ip source-route
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address XX.XX.XX.XX
    !
    ip dhcp pool sdm-pool1
    import all
    network XX.XX.XX.XX XX.XX.XX.XX
    default-router XX.XX.XX.XX
    !
    !
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    no ip bootp server
    no ip domain lookup
    ip domain name my.dyndns.org
    !
    !
    !
    username XXXXX privilege 15 secret 5 XXXXXXXXXXXXXX
    !
    !
    archive
    log config
    hidekeys
    !
    !
    ip tcp synwait-time 10
    ip ssh time-out 60
    ip ssh authentication-retries 2
    !
    !
    !
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    description $ES_WAN$$FW_OUTSIDE$
    ip nat outside
    ip virtual-reassembly
    pvc 8/35
    pppoe-client dial-pool-number 1
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
    ip address XX.XX.XX.XX XXX.XXX.XXX.X
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    ip virtual-reassembly
    ip route-cache flow
    ip tcp adjust-mss 1412
    !
    interface Dialer0
    ip address dhcp
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1452
    encapsulation ppp
    ip route-cache flow
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username XXXXXXXXX password 7 XXXXXXXXXX
    !
    ip forward-protocol nd
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat inside source list 1 interface ATM0.1 overload
    !
    logging trap debugging
    access-list 1 remark INSIDE_IF=Vlan1
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit XX.XX.XX.XX X.X.X.XXX
    dialer-list 1 protocol ip permit
    no cdp run
    !
    !
    !
    control-plane
    !
    banner exec ^C
    % Password expiration warning.
    -----------------------------------------------------------------------

    Cisco Router and Security Device Manager (SDM) is installed on this device and
    it provides the default username "cisco" for one-time use. If you have already
    used the username "cisco" to login to the router and your IOS image supports the
    "one-time" user option, then this username has already expired. You will not be
    able to login to the router with this username after you exit this session.

    It is strongly suggested that you create a new username with a privilege level
    of 15 using the following command.

    username <myuser> privilege 15 secret 0 <mypassword>

    Replace <myuser> and <mypassword> with the username and password you want to
    use.

    -----------------------------------------------------------------------
    ^C
    banner login ^CAuthorized access only!
    Disconnect IMMEDIATELY if you are not an authorized user!^C
    !
    line con 0
    login local
    no modem enable
    transport output telnet
    line aux 0
    login local
    transport output telnet
    line vty 0 4
    privilege level 15
    login local
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    scheduler allocate 4000 1000
    scheduler interval 500
    end
    Last edited by AcesHigh; 6th October 2008, 19:50.

  • #2
    Re: Cisco 877 and 857 ADSL routers

    Wrong forum or what???

    Comment


    • #3
      Re: Cisco 877 and 857 ADSL routers

      Don't forget that people has normal lives and jobs.
      Also it isn't really clear what problem you have.
      Marcel
      Technical Consultant
      Netherlands
      http://www.phetios.com
      http://blog.nessus.nl

      MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
      "No matter how secure, there is always the human factor."

      "Enjoy life today, tomorrow may never come."
      "If you're going through hell, keep going. ~Winston Churchill"

      Comment


      • #4
        Re: Cisco 877 and 857 ADSL routers

        Sry for the unpatience, but im on the edge of selling the Cisco routers...

        The problem is that I cant get the ADSLoPOTS interface to connect to my ISP. I've gone through all the settings that i know of, done the SDM wizard but I cannot get the PPPoE up and running.

        Comment


        • #5
          Re: Cisco 877 and 857 ADSL routers

          Please post a sh int stat

          And if you have a nice bargain let me know
          Marcel
          Technical Consultant
          Netherlands
          http://www.phetios.com
          http://blog.nessus.nl

          MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
          "No matter how secure, there is always the human factor."

          "Enjoy life today, tomorrow may never come."
          "If you're going through hell, keep going. ~Winston Churchill"

          Comment


          • #6
            Re: Cisco 877 and 857 ADSL routers

            Im currently using it as a plain switch only using the LAN ports, with firewall enabled, have configured the Linksys RVS4000 router and set the IP of the Cisco Router in a DMZ...


            Cisco877#sh int stat
            FastEthernet0
            Switching path Pkts In Chars In Pkts Out Chars Out
            Processor 1368622 830371101 2143248 1642945056
            Route cache 0 0 0 0
            Total 1368622 830371101 2143248 1642945056
            FastEthernet1
            Switching path Pkts In Chars In Pkts Out Chars Out
            Processor 28400153 936372740 18718960 3646719945
            Route cache 0 0 0 0
            Total 28400153 936372740 18718960 3646719945
            FastEthernet2
            Switching path Pkts In Chars In Pkts Out Chars Out
            Processor 17057694 2823447175 26913405 3650590769
            Route cache 0 0 299127 17947620
            Total 17057694 2823447175 27212532 3668538389
            FastEthernet3
            Switching path Pkts In Chars In Pkts Out Chars Out
            Processor 0 0 0 0
            Route cache 0 0 0 0
            Total 0 0 0 0
            ATM0
            Switching path Pkts In Chars In Pkts Out Chars Out
            Processor 0 0 0 0
            Route cache 0 0 0 0
            Total 0 0 0 0
            Vlan1
            Switching path Pkts In Chars In Pkts Out Chars Out
            Processor 232801 17446767 6451 2863246
            Route cache 20 2200 0 0
            Total 232821 17448967 6451 2863246
            NVI0
            Switching path Pkts In Chars In Pkts Out Chars Out
            Processor 0 0 0 0
            Route cache 0 0 0 0
            Total 0 0 0 0
            Dialer0
            Switching path Pkts In Chars In Pkts Out Chars Out
            Processor 0 0 0 0
            Route cache 0 0 0 0
            Total 0 0 0 0
            Dialer1
            Switching path Pkts In Chars In Pkts Out Chars Out
            Processor 0 0 0 0
            Route cache 0 0 0 0
            Total 0 0 0 0




            BTW. Nice website u got there (http://www.phetios.com)
            Last edited by AcesHigh; 7th October 2008, 13:22.

            Comment


            • #7
              Re: Cisco 877 and 857 ADSL routers

              try the below config. I'm not a GUI typa person....so hope you can work the CLI...

              just a copy and paste should do it

              change everything in red..


              ==============================================

              service nagle
              no service pad
              service tcp-keepalives-in
              service tcp-keepalives-out
              service timestamps debug datetime msec localtime show-timezone
              service timestamps log datetime msec localtime show-timezone
              service password-encryption
              service linenumber
              service compress-config
              service sequence-numbers
              no service dhcp
              !
              hostname {your_router_name_here}
              !
              boot-start-marker
              boot system flash
              boot-end-marker
              !
              logging snmp-authfail
              logging buffered 65535 debugging
              enable secret {your_enable_pass_here}

              !
              aaa new-model
              !
              !
              !
              aaa session-id common
              !
              resource policy
              !
              clock timezone SAST 2
              no ip source-route
              no ip gratuitous-arps
              ip cef
              !
              !
              !
              !
              ip telnet source-interface Vlan1
              no ip bootp server
              no ip domain lookup
              ip name-server {dns_server_here}
              ip ssh time-out 60
              ip ssh version 2
              ip sla 1
              icmp-echo {your/any_isp_ip_here} source-interface Vlan1
              frequency 15
              ip sla schedule 1 life forever start-time now
              !

              !
              !
              username {your_username_here} password {your_password_here}
              !
              !
              track 1 rtr 1 reachability
              !
              no crypto isakmp enable
              !
              !
              !
              !
              interface ATM0
              no ip address
              load-interval 30
              no atm ilmi-keepalive
              dsl operating-mode auto
              no shut
              !
              interface ATM0.1 point-to-point
              no snmp trap link-status
              pvc 8/35 {this line might change depending on your telco - check with your current dsl router to confirm}
              pppoe-client dial-pool-number 1
              !
              !
              interface FastEthernet0
              !
              no shut

              interface FastEthernet1

              no shut
              !
              interface FastEthernet2

              no shut
              !
              interface FastEthernet3

              no shut
              !
              interface Vlan1
              ip address {your_internal_range_here} {your_subnet_here}
              ip virtual-reassembly
              ip tcp adjust-mss 1400
              hold-queue 100 out
              ip nat inside
              no shut
              !

              interface Dialer0
              ip address negotiated
              no ip redirects
              encapsulation ppp
              ip route-cache flow
              load-interval 30
              dialer pool 1
              dialer-group 1
              ppp authentication pap callin
              ppp pap sent-username {your_DSL_username_here} password {your_DSL_password_here}
              ip nat outside
              no shut
              !

              ip route 0.0.0.0 0.0.0.0 Dialer0

              !
              !
              no ip http server
              no ip http secure-server
              !
              logging facility local6
              access-list 1 permit {your_int_ip_range_here} {your_subnet_here}
              access-list 1 deny any log

              dialer-list 1 protocol ip permit
              snmp-server community snmp_string_here
              snmp-server ifindex persist
              snmp-server queue-length 1
              snmp-server enable traps tty
              no cdp run
              !
              !
              !
              !
              control-plane
              !
              !
              line con 0
              session-timeout 5 output
              exec-timeout 120 0
              password password_here
              no modem enable
              transport preferred ssh
              stopbits 1
              line aux 0
              transport preferred ssh
              line vty 0 4
              session-timeout 10 output
              access-class 1 in
              exec-timeout 120 0
              password password_here
              transport preferred ssh
              !
              scheduler max-task-time 5000
              ntp clock-period 17175031
              ntp source Vlan1
              ntp server x.x.x.x source Vlan1
              sntp server x.x.x.x
              !
              webvpn context Default_context
              ssl authenticate verify all
              !
              no inservice
              !
              end

              ==============================================

              Hope it helps...
              Last edited by TheGuardian; 9th October 2008, 06:24.

              Comment


              • #8
                Re: Cisco 877 and 857 ADSL routers

                Thank you, TheGuardian for your try, but i did the CONF TERM and pasted your edited config into my router but it was still the same...

                Now I only have one more option, does anyone know if there's a way of programming one of the LAN ports to act as a WAN port with PPPoE so I can connect it directly to the bridged Speedtouch 546i modem? If this works I can still use the Cisco Router and all the functions of it, including the VPN server.
                Last edited by AcesHigh; 9th October 2008, 10:09.

                Comment


                • #9
                  Re: Cisco 877 and 857 ADSL routers

                  Or maybe if someone could help me make a complete config for my router, cuz i really dont understand the CLI commands just yet. Is it nessecary that a user of the Cisco routers should have to study CCNA or CCNP to be able to set up a working connection?

                  Well if someone could help me setting this up it would be appretiated, I can be contacted on MSN "afterglow [AT] theones [dot] dk" or at the same adress in email.


                  Edit Dumber:
                  I've modified your email address to protect your privacy against spammers.
                  Last edited by Dumber; 10th October 2008, 10:28.

                  Comment


                  • #10
                    Re: Cisco 877 and 857 ADSL routers

                    Do you have any cisco knowledge at all?

                    If you use an ATM interface you are doing PPPoA.
                    If your service provider requires PPPoE you need a cisco 861,871, or 881.

                    These routers have one wan port Fastethernet4 which connects you to your provider.

                    Than your configurations is done under the dialer interface and mapped to Fastethernet4

                    I could be wrong here, but I never seen PPPoe over an ATM interface
                    Last edited by rgmartins; 21st October 2008, 11:18.

                    Comment


                    • #11
                      Re: Cisco 877 and 857 ADSL routers

                      Originally posted by rgmartins View Post
                      Do you have any cisco knowledge at all?

                      If you use an ATM interface you are doing PPPoA.
                      If your service provider requires PPPoE you need a cisco 861,871, or 881.

                      These routers have one wan port Fastethernet4 which connects you to your provider.

                      Than your configurations is done under the dialer interface and mapped to Fastethernet4

                      I could be wrong here, but I never seen PPPoe over an ATM interface
                      Thats because you wont PPPoE is over Ethernet. PPPoA your more common ADSL connection is over an ATM. There 2 entirely diffrent mediums.

                      Comment

                      Working...
                      X