Announcement

Collapse
No announcement yet.

Frame Relay Switch

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Frame Relay Switch

    Hello,

    I need help setting up a Frame Relay Switch. I have a cisco 2521 - 4 serial interfaces, that I need to use in an IS-IS lab.

    Here is a shot of the lab.

    http://img385.imageshack.us/img385/3328/isisfrsbm0.jpg

    Also I will be using 3 other cisco 2514's instead of 2600 series routers. My 2514's have the latest IOS and should be fine. All I need is for my 2521 to act as the "FRS" switch. Any help would be greatly appreciated.

    here is the lab configuration.

    HQ# show run
    !
    hostname HQ
    !
    no ip domain-lookup
    !
    interface Loopback0
    ip address 192.168.10.1 255.255.255.0
    ip router isis
    !
    interface Serial0/0/1
    no ip address
    encapsulation frame-relay
    no shutdown
    !
    interface Serial0/0/1.102 point-to-point
    ip address 192.168.128.1 255.255.255.0
    ip router isis
    frame-relay interface-dlci 102
    !
    interface Serial0/0/1.103 point-to-point
    ip address 192.168.192.1 255.255.255.0
    ip router isis
    frame-relay interface-dlci 103
    !
    router isis
    net 49.0001.1111.1111.1111.00
    !
    end



    EAST# show run
    !
    hostname EAST
    !
    no ip domain-lookup
    !
    interface Loopback0
    ip address 192.168.20.1 255.255.255.0
    ip router isis
    !
    interface Serial0/0/1
    no ip address
    encapsulation frame-relay
    clock rate 64000
    no shutdown
    !
    interface Serial0/0/1.201 point-to-point
    !
    interface Serial0/0/1.2001 multipoint
    ip address 192.168.128.2 255.255.255.0
    ip router isis
    frame-relay interface-dlci 201
    !
    router isis
    net 49.0001.2222.2222.2222.00
    !
    end


    WEST# show run
    Building configuration...
    !
    hostname WEST
    !
    no ip domain-lookup
    !
    interface Loopback0
    ip address 192.168.30.1 255.255.255.0
    ip router isis
    !
    interface Serial0/0/0
    no ip address
    encapsulation frame-relay
    clock rate 2000000
    no shutdown
    !
    interface Serial0/0/0.301 point-to-point
    ip address 192.168.192.2 255.255.255.0
    ip router isis
    frame-relay interface-dlci 301
    !
    router isis
    net 49.0001.3333.3333.3333.00
    !
    end

  • #2
    Re: Frame Relay Switch

    What specifically do you need help with?

    Comment


    • #3
      Re: Frame Relay Switch

      I need my 2521 to act as a Frame Relay switch.

      Comment


      • #4
        Re: Frame Relay Switch

        You have to configure the 2521 as a clock source for the other routers and you need to disable LMI. Here's the configs from my 2 routers connected in a FR back-to-back:

        Router 1
        no service single-slot-reload-enable
        service timestamps debug uptime
        service timestamps log uptime
        no service password-encryption
        !
        hostname CiscoRouter1
        !
        enable password xxxxxxxx
        !
        ip subnet-zero
        ip cef
        !
        interface Ethernet0
        ip address 192.168.1.9 255.255.255.0
        ip route-cache flow
        !
        interface Serial0
        no ip address
        encapsulation frame-relay
        ip route-cache flow
        no keepalive
        no fair-queue
        service-module 56k clock source internal
        no service-module 56k remote-loopback
        !
        interface Serial0.1 point-to-point
        ip address 10.0.0.1 255.0.0.0
        ip route-cache flow
        frame-relay interface-dlci 100
        !
        interface Serial1
        no ip address
        ip route-cache flow
        shutdown
        !
        interface BRI0
        ip route-cache flow
        no ip address
        shutdown
        !
        router rip
        network 10.0.0.0
        network 192.168.1.0
        !
        router igrp 100
        network 10.0.0.0
        network 192.168.1.0
        !
        ip flow-export source Null0
        ip flow-export version 5
        ip flow-export destination 192.168.1.7 9996
        ip classless
        ip http server
        !
        snmp-server community public RO
        snmp-server community private RW
        !
        line con 0
        exec-timeout 0 0
        password xxxxxxxx
        login
        line aux 0
        password xxxxxxxx
        login
        line vty 0 4
        password xxxxxxxx
        login
        !
        end

        Router 2
        no service single-slot-reload-enable
        service timestamps debug uptime
        service timestamps log uptime
        no service password-encryption
        !
        hostname CiscoRouter2
        !
        enable password xxxxxxxx
        !
        ip subnet-zero
        ip cef
        !
        interface Ethernet0
        ip address 192.168.2.9 255.255.255.0
        ip route-cache flow
        !
        interface Serial0
        no ip address
        ip route-cache flow
        encapsulation frame-relay
        no keepalive
        no fair-queue
        no service-module 56k remote-loopback
        !
        interface Serial0.1 point-to-point
        ip address 10.0.0.2 255.0.0.0
        ip route-cache flow
        frame-relay interface-dlci 100
        !
        interface Serial1
        no ip address
        ip route-cache flow
        shutdown
        !
        interface BRI0
        no ip address
        ip route-cache flow
        shutdown
        !
        router rip
        network 10.0.0.0
        network 192.168.2.0
        !
        router igrp 100
        network 10.0.0.0
        network 192.168.2.0
        !
        ip flow-export source Null0
        ip flow-export version 5
        ip flow-export destination 192.168.1.7 9996
        ip classless
        ip http server
        !
        snmp-server community public RO
        snmp-server community private RW
        !
        line con 0
        exec-timeout 0 0
        password xxxxxxxx
        login
        line aux 0
        password xxxxxxxx
        login
        line vty 0 4
        password xxxxxxxx
        login
        !
        end

        I've also uploaded a few Cisco documents on the subject. Hope it helps.
        Attached Files

        Comment


        • #5
          Re: Frame Relay Switch

          Joe,

          Thank you very much for your response. I appreciate that you are tying to help.

          Could you take a look at the configuration I have for "HQ" , "East" and "West" router and give me an example configuration to use for my 2521 serial router - to act as a frame relay switch? I would deeply appreciate if you could. Thanks again.

          Comment


          • #6
            Re: Frame Relay Switch

            There are a couple of methods I can think of to enable frame-switching. Each method requires a slightly different configuration when dealing with DLCI's

            * add "frame-relay route" in interface mode
            * add "connect" in global config mode

            NOTE: In my example below, I am posting from memory , so hopefully I am close. Also, I am using the "frame-relay route" method

            First, get the back-to-back serial configuration working between HQ, EAST, WEST and FRS. Use the links JoeQwerty posted as a starting point. That should resolve any clocking and/or DCE/DTE issues on the serial interfaces between the routers.

            1) On router FRS... Enable "frame-relay switching" in global config mode

            2) On each interface of router FRS... add a "frame-relay route" statement to route/switch DLCIs between interfaces. Something like (again from memory but using the posted drawing as reference)
            Code:
            interface s0/0/0
             description Connection to HQ
             encapsulation frame-relay
             frame-relay intf-type dce
             frame-relay route 102 interface Serial0/0/1 201
             frame-relay route 103 interface Serial0/1/0 301
             
            interface s0/0/1
             description Connection to EAST
             encapsulation frame-relay
             frame-relay intf-type dce
             frame-relay route 201 interface Serial0/0/0 102
             
            interface s0/1/0
             description Connection to WEST
             encapsulation frame-relay
             frame-relay intf-type dce
             frame-relay route 301 interface Serial0/0/0 103
            3) On router HQ, the serial interface config should look something like
            Code:
            interface s0/0/1
             description Connection to router FRS s0/0/0
             encapsulation frame-relay IETF
             
            interface s0/0/1.102
             ip address 192.168.128.1 255.255.255.0
             frame-relay interface-dlci 102
             
            interface s0/0/1.103
             ip address 192.168.192.1 255.255.255.0
             frame-relay interface-dlci 103
            4) On router EAST, the serial interface config should look something like
            Code:
            interface s0/0/1
             description Connection to router FRS s0/0/1
             ip address 192.168.128.2 255.255.255.0
             encapsulation frame-relay
             frame-relay interface-dlci 201
            5) On router WEST, the serial interface config should look something like
            Code:
            interface s0/0/0
             description Connection to router FRS s0/1/0
             ip address 192.168.192.2 255.255.255.0
             encapsulation frame-relay
             frame-relay interface-dlci 301
            At this point, if you have resolved all layer 1 and 2 issues, you should be able to ping each serial ip address from HQ->EAST, etc... via FRS. Continue your quest by enabling routing protocols for your loopbacks. I assume you are using loopbacks to simulate a network behind the serial interfaces of each router.

            Some commands to use for debugging

            On FRS
            show frame-relay route
            show frame-relay pvc - pvcs should show "active/switched"

            On HQ, EAST and WEST
            show frame-relay pvc - pvcs should show "active/local"

            Now for some homework

            What commands would you add to allow router EAST and WEST to communicate directly via FRS instead of via HQ?

            Comment


            • #7
              Re: Frame Relay Switch

              I consulted a friend of mine in my company's network dept. He gave me this and it works.



              hostname FRS

              no ip domain-lookup

              frame-relay switching

              interface Serial0
              no ip address
              encapsulation frame-relay
              clockrate 64000
              frame-relay intf-type dce
              frame-relay route 102 interface Serial1 201
              frame-relay route 103 interface Serial2 301
              no shutdown

              interface Serial1
              no ip address
              encapsulation frame-relay
              clockrate 64000
              frame-relay intf-type dce
              frame-relay route 201 interface Serial0 102
              no shutdown

              interface Serial2
              no ip address
              encapsulation frame-relay
              clockrate 64000
              frame-relay intf-type dce
              frame-relay route 301 interface Serial0 103
              no shutdown


              I have set the loopbacks and can ping any ip address from any router.

              I used 3x2514's and 1x2521 - 2514's running 12.2.29b (service provider) image and the 2521 is running 12.3.26 (Ip Plus) image. Ths latest Cisco image wont run ISIS, so I had to go fishing.
              I spent 2 days on this, but now I have a good understanding now.


              Thanks again for your help.

              Comment


              • #8
                Re: Frame Relay Switch

                Glad to hear you got router FRS configured

                Comment

                Working...
                X