Announcement

Collapse
No announcement yet.

Home Lab Network Serial Link INOP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Home Lab Network Serial Link INOP

    Ive just added equipment to my home network for CCNA test. I have almost
    everything up and running with the exception of the serial links.
    I think its a layer 1 problem since the show interface command on the
    serials are displaying Down Down.
    Im using DCE/DTE DB 60 crossover cables. It can possibly ca not be the
    cables because I tried all three cables which a new out of the bag.
    Im not sure if the Synchronous, or Asynchronous modes have anything to
    with it It seems that the 2500 routers serial interface is using HDLC on
    BOTH ends as its encapsulation which I think is synchronous.
    I have the Frame-Relay router set as the DCE (with the cable mark DCE
    attach to the router) Maybe I need to change the Router on the other end
    serial interface to DTE. I tried, but I can not seem to find the correct
    command. I thought the Routers come with DTE as its default.
    Can someone assist me to resolve the problem?
    Below are various outputs of the Frame-Relay (DCE), and the Core 2500
    router along with a attachment of my network:



    Frame-Relay Output:
    Frame-Relay#sh controller serial 1/0
    CD2430 Slot 1, Port 0, Controller 0, Channel 0, Revision 19
    Channel mode is synchronous serial
    idb 0x81D3E468, buffer size 1524, V.35 DCE cable, clockrate 128000


    Frame-Relay#
    ------------------------------------------------------------------
    !
    !
    Frame-Relay#sh ip int brief
    Interface IP-Address OK? Method Status
    Protocol
    Ethernet0/0 192.168.4.117 YES NVRAM up
    up
    Serial0/0 unassigned YES NVRAM administratively
    down down
    Ethernet0/1 10.1.1.2 YES NVRAM up
    up
    Serial1/0 192.168.1.18 YES NVRAM down
    down
    Serial1/1 unassigned YES NVRAM administratively
    down down
    Serial1/2 unassigned YES NVRAM administratively
    down down
    Serial1/3 unassigned YES NVRAM administratively
    down down
    Frame-Relay#

    ---------------------------------------------------------------
    !
    !
    Frame-Relay#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) C2600 Software (C2600-IS-M), Version 12.2(40a), RELEASE SOFTWARE
    (fc1)
    Copyright (c) 1986-2007 by cisco Systems, Inc.
    Compiled Sun 11-Mar-07 01:33 by pwade
    Image text-base: 0x8000808C, data-base: 0x8111D344
    ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)
    Frame-Relay uptime is 10 hours, 44 minutes
    System returned to ROM by power-on
    System restarted at 00:00:02 MST Mon Mar 1 1993
    System image file is "flash:c2600-is-mz.122-40a.bin"
    cisco 2611 (MPC860) processor (revision 0x203) with 61440K/4096K bytes of
    memory.
    Processor board ID JAD0434089R (4095170074)
    M860 processor: part number 0, mask 49
    Bridging software.
    X.25 software, Version 3.0.0.
    2 Ethernet/IEEE 802.3 interface(s)
    1 Serial network interface(s)
    4 Low-speed serial(sync/async) network interface(s)
    32K bytes of non-volatile configuration memory.
    16384K bytes of processor board System flash (Read/Write)
    Configuration register is 0x2102
    !
    !
    Frame-Relay#
    ---------------------------------------------------------------
    !
    !
    Frame-Relay#sh run
    Building configuration...
    Current configuration : 1383 bytes
    !
    ! Last configuration change at 10:40:38 MST Mon Mar 1 1993 by tsignal32
    ! NVRAM config last updated at 10:35:45 MST Mon Mar 1 1993 by tsignal32
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname Frame-Relay
    !
    logging buffered 4096 debugging
    enable secret 5 $1$AS6E$8ROsj/chEcjKjIW87YLfT/
    !
    username tsignal32 privilege 15 password 7 04580A040324484F1E1E
    username tsignal33 privilege 3 password 7 134F5D310A011406242A2F6261
    clock timezone MST 0
    ip subnet-zero
    !
    !
    !
    call rsvp-sync
    !
    !
    interface Ethernet0/0
    description Uplink Linksys
    ip address 192.168.4.117 255.255.255.0
    half-duplex
    !
    interface Serial0/0
    no ip address
    shutdown
    !
    interface Ethernet0/1
    description Downlink to Core 2500
    ip address 10.1.1.2 255.0.0.0
    half-duplex
    !
    interface Serial1/0
    ip address 192.168.1.18 255.255.255.240
    clock rate 128000
    !
    interface Serial1/1
    no ip address
    shutdown
    !
    interface Serial1/2
    no ip address
    shutdown
    !
    interface Serial1/3
    no ip address
    shutdown
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.4.222
    ip route 172.17.0.0 255.255.0.0 Ethernet0/1
    ip http server
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    line con 0
    password 7 130616100709002B3C23
    logging synchronous
    line aux 0
    line vty 0 4
    exec-timeout 30 0
    password 7 110A18071B170F0D132D
    login local
    !
    ntp clock-period 17208194
    ntp master
    end
    Frame-Relay#
    !
    !
    --------------------------------------------------------------------------
    Frame-Relay#sh int serial 1/0
    Serial1/0 is down, line protocol is down
    Hardware is CD2430 in sync mode
    Internet address is 192.168.1.18/28
    MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation HDLC, loopback not set

    Frame-Relay#
    !
    !
    ------------------------------------------

    Frame-Relay#sh ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
    level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static
    route
    o - ODR, P - periodic downloaded static route
    Gateway of last resort is 192.168.4.222 to network 0.0.0.0
    S 172.17.0.0/16 is directly connected, Ethernet0/1
    C 192.168.4.0/24 is directly connected, Ethernet0/0
    C 10.0.0.0/8 is directly connected, Ethernet0/1
    S* 0.0.0.0/0 [1/0] via 192.168.4.222
    Frame-Relay#


    2500 Output:

    Router#sh runn
    Building configuration...
    Current configuration:
    !
    version 10.3
    service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname Router
    !
    enable secret 5 $1$6erp$niYFu/HmnqlsyzbwiOgPc.
    !

    !
    interface Ethernet0
    description Upling to Core C2500
    ip address 172.17.1.2 255.255.0.0
    !
    interface Ethernet1
    no ip address
    shutdown
    !
    interface Serial0
    description UpLink to Frame-Relay
    ip address 192.168.1.22 255.255.255.240
    !
    interface Serial1
    no ip address
    shutdown
    !
    ip route 0.0.0.0 0.0.0.0 Ethernet0
    !
    line con 0
    line aux 0
    transport input all
    line vty 0
    exec-timeout 600 0
    password 7 0205055907030B205B49
    login
    line vty 1
    exec-timeout 600 0
    password 7 110A18071B170F0D132D
    login
    line vty 2
    exec-timeout 600 0
    password 7 0508070D2D494A080E02
    login
    line vty 3
    exec-timeout 600 0
    password 7 15110A0E082F2F253F34
    login
    line vty 4
    exec-timeout 600 0
    password 7 094F4F0B150013131C0B
    login
    !
    end
    Router#
    -----------------------------------------------
    Router#sh controller serial 0
    HD unit 0, idb = 0x7F9C0, driver structure at 0x81480
    buffer size 1524 HD unit 0, V.35 DTE cable

    Router#
    -------------------------------------------------------------
    Router#sh int serial 0
    Serial0 is down, line protocol is down
    Hardware is HD64570
    Description: UpLink to Frame-Relay
    Internet address is 192.168.1.22 255.255.255.240
    MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
    Encapsulation HDLC, loopback not set, keepalive set (10 sec)
    Router#
    --------------------------------------------------------------------
    Router#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) 3000 Software (IGS-I-L), Version 10.3(11), RELEASE SOFTWARE (fc1)
    Copyright (c) 1986-1996 by cisco Systems, Inc.
    Compiled Wed 24-Apr-96 15:19 by dschwart
    Image text-base: 0x0301B5C8, data-base: 0x00001000
    ROM: System Bootstrap, Version 5.2(5), RELEASE SOFTWARE
    ROM: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(5), RELEASE
    SOFTWARE (fc1)
    Router uptime is 10 hours, 59 minutes
    System restarted by power-on
    System image file is "flash:igs-i-l.103-11.bin", booted via flash
    cisco 2500 (68030) processor (revision C) with 4096K/2048K bytes of
    memory.
    Processor board serial number 01511701
    Bridging software.
    X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.
    Primary Rate ISDN software, Version 1.0.
    2 Ethernet/IEEE 802.3 interfaces.
    2 Serial network interfaces.
    32K bytes of non-volatile configuration memory.
    4096K bytes of processor board System flash (Read ONLY)
    Configuration register is 0x2102
    Router#
    Attached Files

  • #2
    Re: Home Lab Network Serial Link INOP

    You have to set the clock rate on the DCE interface.
    Also you might have a look at sh frame pvc.

    Ps,
    check this out:
    http://www.cisco.com/en/US/tech/tk71...80094a3b.shtml
    Marcel
    Technical Consultant
    Netherlands
    http://www.phetios.com
    http://blog.nessus.nl

    MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
    "No matter how secure, there is always the human factor."

    "Enjoy life today, tomorrow may never come."
    "If you're going through hell, keep going. ~Winston Churchill"

    Comment


    • #3
      Re: Home Lab Network Serial Link INOP

      Dumber,

      Thanks - For the information on Frame-Relay. Unfortunately, the serial ports still did not come up after configuring it. It still displaying both serial interfaces in down - down status.

      I cant have all three DCE/DTE crossover cable bad.

      I will upgrade the IOS on the 2500 routers since they have 10.5 version when I get home. I will keep you updated on the results.

      tsignal32

      Comment


      • #4
        Re: Home Lab Network Serial Link INOP

        Have you already tried to restart the routers with the cables connected.
        Marcel
        Technical Consultant
        Netherlands
        http://www.phetios.com
        http://blog.nessus.nl

        MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
        "No matter how secure, there is always the human factor."

        "Enjoy life today, tomorrow may never come."
        "If you're going through hell, keep going. ~Winston Churchill"

        Comment


        • #5
          Re: Home Lab Network Serial Link INOP

          You need to set one interface as the clock source and you have to disable LMI (I'm pretty sure I have this right). Here's the config for my back-to-back router setup:

          ROUTER 1:

          interface Serial0
          no ip address
          encapsulation frame-relay
          ip route-cache flow
          no keepalive
          no fair-queue
          service-module 56k clock source internal
          no service-module 56k remote-loopback
          !
          interface Serial0.1 point-to-point
          ip address 10.0.0.1 255.0.0.0
          frame-relay interface-dlci 100

          ROUTER 2:

          interface Serial0
          no ip address
          encapsulation frame-relay
          ip route-cache flow
          no keepalive
          no fair-queue
          no service-module 56k remote-loopback
          !
          interface Serial0.1 point-to-point
          ip address 10.0.0.2 255.0.0.0
          frame-relay interface-dlci 100

          Comment


          • #6
            Re: Home Lab Network Serial Link INOP

            Everyone,

            Thanks - For the information. I manage to get the serial ethernet, and line protocol ports in the Up - Up status. It was a layer 1 problem. I didn't have the DCE/DTE tight on the routers. Once I tighte them up the pors came up.
            Thanks

            Tsignal 32

            Comment

            Working...
            X