Announcement

Collapse
No announcement yet.

DHCP request times out

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • DHCP request times out

    My client can't obtain an IP address from the DHCP server located in different VLAN.
    Stacked catalyst 3750 provides routing and it is in Server mode. Trunk links are configured & VLAN database is propagated without any problems.
    edited 3750 config posted at the end
    If I assign to node (win xp SP2) static IP address everything works. every VLAN sufffers from this problem.
    I thought the dhcp snooping was the issue but after configuring it I have same problem. disabled dhcp snooping doesn't make diference. DHCP server is an windows 2003 server.
    Access switches are 29xx,35xx and 37xx

    Any suggestion would be greatly appreciated.

    Trbonja

    3750 config

    ===========================



    Core#show run
    Building configuration...

    Current configuration : 6121 bytes
    !
    ! Last configuration change at 12:53:31 EDT Tue Jul 29 2008
    ! NVRAM config last updated at 12:53:32 EDT Tue Jul 29 2008
    !
    version 12.2
    no service pad
    service tcp-keepalives-in
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !
    hostname Core
    !
    logging buffered 16384 debugging
    enable secret 5 $1$5tSm$fG$ixvfw0y9l3R9fbkJ$V1
    !
    no aaa new-model
    clock timezone EST -5
    clock summer-time EDT recurring
    switch 1 provision ws-c3750g-12s
    switch 2 provision ws-c3750g-12s
    ip subnet-zero
    no ip source-route
    ip routing
    ip cef load-sharing algorithm universal C05B8979
    ip tcp synwait-time 10
    ip domain-name domain.com
    ip name-server 10.0.1.1
    ip name-server 192.168.1.2
    !
    no file verify auto
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    interface Port-channel1
    description Server Farm
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface Port-channel2
    description Main Office
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface Port-channel3
    description Engineering
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface GigabitEthernet1/0/1
    description Part of Server Farm Channel
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 1 mode on
    !
    interface GigabitEthernet1/0/2
    description Part of Engineering Channel
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 3 mode on
    !
    interface GigabitEthernet1/0/3
    description HR #3
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface GigabitEthernet1/0/4
    description 3548 HR 2nd floor
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface GigabitEthernet1/0/5
    !
    interface GigabitEthernet1/0/6
    description Temporary 3508
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface GigabitEthernet1/0/7
    description Steel-Prep
    switchport trunk encapsulation dot1q
    switchport mode trunk
    duplex full
    !
    interface GigabitEthernet1/0/8
    description Paint Kitchen-100 Meg
    duplex full
    !
    interface GigabitEthernet1/0/9
    description F1-F2 100 Meg
    duplex full
    !
    interface GigabitEthernet1/0/10
    description Equipment Shop
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface GigabitEthernet1/0/11
    !
    interface GigabitEthernet1/0/12
    description Part of Main Office Channel
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface GigabitEthernet2/0/1
    description Part of Server Farm Channel
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 1 mode on
    !
    interface GigabitEthernet2/0/2
    description Part of Engineering Channel
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 3 mode on
    !
    interface GigabitEthernet2/0/3
    description HR #2
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface GigabitEthernet2/0/4
    !
    interface GigabitEthernet2/0/5
    description Time Bunker
    !
    interface GigabitEthernet2/0/6
    description Warehouse-100 Meg
    switchport trunk encapsulation dot1q
    switchport mode trunk
    duplex full
    !
    interface GigabitEthernet2/0/7
    description F3-100 Meg
    duplex half
    !
    interface GigabitEthernet2/0/8
    description CAPEX
    duplex full
    !
    interface GigabitEthernet2/0/9
    description Power House
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface GigabitEthernet2/0/10
    description QA 3560
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface GigabitEthernet2/0/11

    !
    interface GigabitEthernet2/0/12
    description Main office 3750
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 2 mode on
    !
    interface Vlan1
    description Management Interface
    ip address 10.0.0.30 255.0.0.0
    !
    interface Vlan3
    description Steelprep
    ip address 192.168.3.1 255.255.255.0
    ip helper-address 10.0.1.1
    ip helper-address 192.168.1.2
    ip dhcp relay information trusted

    interface Vlan12
    ip address 192.168.4.1 255.255.255.0
    ip helper-address 10.0.1.1
    ip helper-address 192.168.1.2
    !
    interface Vlan20
    description Wireless VLAN
    ip address 192.168.20.1 255.255.255.0
    ip helper-address 10.0.1.1
    ip helper-address 192.168.1.2
    !
    ip default-gateway 10.0.0.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.0.0.1
    no ip http server
    !
    snmp-server engineID local 000000090200000425A55C00
    snmp-server community private RW
    snmp-server community public RO
    snmp-server contact Mike-3308
    !
    control-plane
    !
    banner motd ^C
    +-----------------------------------------------------------------------+
    | WARNING |
    | |

    | |
    | !!!If you are not an authorized user, DO NOT ATTEMPT TO LOG IN!!! |
    | |
    +-----------------------------------------------------------------------+^C
    !
    line con 0
    line vty 0 4
    password 7 182214421D43A34E
    login
    line vty 5 15
    no login
    !
    ntp clock-period 36029373
    !
    end

    Core#

  • #2
    Re: DHCP request times out

    It was actually a dhcp issue. Restored it from backup and all is good.

    Regards,
    Trbonja

    Comment

    Working...
    X