Announcement

Collapse
No announcement yet.

Can Ping From Console, Not From PC

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can Ping From Console, Not From PC

    I am setting up two Cisco 1841 routers back to back. I attached an RJ 48C cable to emulate a T1. I can ping from routerA FE to the other routerB FE using the console without a problem. When I hook up a PC to routerA FE, I cannot run a windows ping to the routerB FE.

    Here is the config:

    RouterA
    FE 0/0
    IP address 172.16.1.10 255.255.255.0
    no shutdown

    S0/0
    IP address 172.16.250.1 255.255.255.252
    encapsulation HDLC
    no shutdown



    RouterB
    FE 0/0
    IP address 172.16.12.1 255.255.255.0
    no shutdown

    S0/0
    IP address 172.16.250.2 255.255.255.252
    encapsulation HDLC
    no shutdown

    PC
    IP Address: 172.16.1.4 255.255.255.0
    default gateway 172.16.1.10

    Any suggestions?

    Thanks

  • #2
    Re: Can Ping From Console, Not From PC

    In which port do you plug the computer? If you try to ping the remote router interface which is in the same IP Address range you will not receive an response because the PC thinks that the machine you try to find is in the same LAN therefore the PC will try to solve the problem alone, not using the default gateway.

    Comment


    • #3
      Re: Can Ping From Console, Not From PC

      I am plugging the PC in RouterA FE 0/0. I am trying to get to RouterB FE 0/0 and beyond. The remote router (RouterB) has an IP of 172.16.12.1 while I'm on 172.16.1.X (subnet is /24). Thanks

      Comment


      • #4
        Re: Can Ping From Console, Not From PC

        A few things, but I'm not a Cisco expert:

        1. You need to set a clock source on one of the routers for the serial interfaces
        2. You need to disable LMI (keepalives) on the serial interfaces
        3. You need to set up routing on each router to route for the FE networks

        As it is right now, Router A knows nothing about the 172.16.12.0 network on Router B and Router B knows nothing about the 172.16.1.0 network on Router A. Therefore when you ping Router B FE from the PC, Router A doesn't know where to send the packets.

        Comment


        • #5
          Re: Can Ping From Console, Not From PC

          Originally posted by mginsburg View Post
          I am plugging the PC in RouterA FE 0/0. I am trying to get to RouterB FE 0/0 and beyond. The remote router (RouterB) has an IP of 172.16.12.1 while I'm on 172.16.1.X (subnet is /24). Thanks
          I'm still confused about your topology. Can you draw it and attach it to your next replay?

          Comment


          • #6
            Re: Can Ping From Console, Not From PC

            Run a tracert. It will tell you exactly where the packets are getting dropped.

            Also, you may want to post the complete configs for both routers.

            Personally it sounds like a routing issue.
            MCITP:SA, MCSA 2003, MCP, CCNA, A+, Net+, Security+

            Comment


            • #7
              Re: Can Ping From Console, Not From PC

              Thanks for your feedback. I think it is the clock source command. Do you know if this is done only on one router? When I can, I'll send the configs from the router. I think when I set up the T1, it should work OK. Now, I'm just setting the config in a lab setting to see if the configs are working. Thanks again

              Comment


              • #8
                Re: Can Ping From Console, Not From PC

                Yes, the clock source should be set only on one router. Here are the relevant configs from my routers which are connected in a back-to-back setup:

                Router 1
                interface Serial0
                no ip address
                encapsulation frame-relay
                ip route-cache flow
                no keepalive
                no fair-queue
                service-module 56k clock source internal
                no service-module 56k remote-loopback
                !
                interface Serial0.1 point-to-point
                ip address 10.0.0.1 255.0.0.0
                frame-relay interface-dlci 100

                Router 2
                interface Serial0
                no ip address
                encapsulation frame-relay
                ip route-cache flow
                no keepalive
                no fair-queue
                no service-module 56k remote-loopback
                !
                interface Serial0.1 point-to-point
                ip address 10.0.0.2 255.0.0.0
                frame-relay interface-dlci 100

                Comment

                Working...
                X