Announcement

Collapse
No announcement yet.

Problem configuring Cisco 857 in bridge mode

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem configuring Cisco 857 in bridge mode

    Sorry guys, I bet this has been answered dozens of times, but I am having trouble getting this router up and running.

    Question 1. Do I need to set up access lists in Bridge mode? Is that my problem
    Q 2. What is wrong with my config?

    All help will be appreciated

    The router connects to my ISP through the ATM0 interface.
    It uses DHCP to obtain the ISP provided IP address
    The Router connects to my firewall through one of the FastEthernet ports (FE0)
    I do not intend to do NAT, as the Firewall has a Public IP address (203.53.68.178/7)
    Basically this is an external router, the Firewall is doing all NAT and other firewall functions.

    I have followed a cisco procedure to set up bridging, with some variation for my specific config.

    I can connect to my ISP and obtain the correct DHCP address.

    show interface dialer0
    Dialer0 is up, line protocol is up (spoofing)
    Hardware is Unknown
    Description: ADSL link FNN xxxxxxx
    Internet address is 165.228.226.9/32
    MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, loopback not set
    Keepalive set (10 sec)
    DTR is pulsed for 1 seconds on reset
    Interface is bound to Vi2
    Last input never, output never, output hang never
    Last clearing of "show interface" counters 00:16:40
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: weighted fair
    Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations 0/0/16 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    Available Bandwidth 42 kilobits/sec
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    325 packets input, 24564 bytes
    184 packets output, 2576 bytes
    Bound to:
    Virtual-Access2 is up, line protocol is up
    Hardware is Virtual Access interface
    MTU 1500 bytes, BW 1020 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, LCP Open
    Listen: BCP
    Open: IPCP
    PPPoATM vaccess, cloned from Dialer0
    Vaccess status 0x44
    Bound to ATM0 VCD: 1, VPI: 8, VCI: 35, loopback not set
    Keepalive set (10 sec)
    DTR is pulsed for 5 seconds on reset
    Interface is bound to Di0 (Encapsulation PPP)
    Last input 00:04:20, output never, output hang never
    Last clearing of "show interface" counters 00:16:06
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    339 packets input, 24779 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    198 packets output, 2800 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions

    A laptop connected to the FE1 port will ping my Firewall address.
    The laptop will not pick up a DHCP address (do I need the access list to allow DHCP?)
    I cannot get tftp working at themoment to upload configs. You can see that I tried to enable port 69 for tftp

    Here is my current config (with security info removed)

    sh run
    Building configuration...
    Current configuration : 2320 bytes
    !
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    service sequence-numbers
    !
    hostname (removed)!
    boot-start-marker
    boot-end-marker
    !
    logging buffered 16000
    no logging console
    enable secret 5 (removed)!
    enable password 7 (removed)!
    !
    no aaa new-model
    no ip source-route
    no ip dhcp use vrf connected
    ip dhcp excluded-address 203.53.68.177 203.53.68.178
    !
    ip dhcp pool CUSTOMER_LAN_POOL
    network 203.53.68.176 255.255.255.248
    default-router 203.53.68.177
    dns-server 203.50.2.71 139.130.4.4
    !
    !
    ip cef
    no ip bootp server
    ip domain name direct.telstra.net
    ip name-server 203.50.2.71
    ip name-server 139.130.4.4
    ip ssh version 2
    !
    !
    !
    !
    !
    !
    !
    bridge irb
    !
    !
    !
    interface ATM0
    description ADSL link FNN xxxxxxx
    no ip address
    no ip route-cache cef
    no ip route-cache
    load-interval 30
    no atm ilmi-keepalive
    pvc 8/35
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    bridge-group 1
    !
    interface FastEthernet0
    spanning-tree portfast
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Dot11Radio0
    no ip address
    shutdown
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    station-role root
    !
    interface Vlan1
    description CUSTOMER_LAN
    ip address 203.53.68.177 255.255.255.248
    ip access-group 100 in
    ip virtual-reassembly
    no ip route-cache cef
    bridge-group 1
    !
    interface Dialer0
    description ADSL link FNN xxxxxxx
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip virtual-reassembly
    encapsulation ppp
    ip route-cache flow
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname (removed)!
    ppp chap password 7 (removed)!
    bridge-group 1
    !
    interface BVI1
    mac-address 0000.0cb5.a42c
    ip address dhcp client-id Vlan1
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    no ip http server
    no ip http secure-server
    !
    access-list 100 permit tcp any any eq 69
    !
    control-plane
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    password 7 03360B1E080B234D1F58
    login
    !
    scheduler max-task-time 5000
    end
Working...
X