No announcement yet.

multiple DHCP on cisco 2611

  • Filter
  • Time
  • Show
Clear All
new posts

  • multiple DHCP on cisco 2611

    Hi everyone, I need some help again. Is it possible to have a DHCP server setup so that int e0/1 is getting a certain set of IPs ( and eth 1/0 is getting another set of IP's ( Then I would like to send the internet from eth 0/0 to both those interfaces.

    Current Config:

    Building configuration...

    Current configuration : 992 bytes
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    hostname IntechRouter
    enable secret 5 $1$MgYM$VeHt5guWqEhl45NMF9Xz80
    enable password mcleod
    ip subnet-zero
    ip dhcp excluded-address
    ip dhcp pool NetworkDHCP
    import all
    lease 0 5
    interface Ethernet0/0
    description Comcast Cable Modem
    ip address dhcp
    ip nat outside
    interface Ethernet1/0
    no ip address
    interface Ethernet0/1
    description Cisco 2924-XL Switch
    ip address
    ip nat inside
    ip nat inside source list 100 interface Ethernet0/0 overload
    ip classless
    ip http server
    access-list 100 permit ip any any
    banner motd ^C

    Intech Networks Main Router (Cisco 2611) Authorized Staff Only!
    line con 0
    line aux 0
    line vty 0 1
    password mcleod
    line vty 2 4

    If possible I would like some help. Thank-You!

    PS: I did a search for this, but nothing came up, I didnt really know what to search for.

  • #2
    Re: multiple DHCP on cisco 2611

    If I understand your post correctly

    You can create multiple dhcp pools in your router configuration. Just create another dhcp pool using the network/mask and gateway that you plan on assigning to hosts connected to interface e1/0. Use your current dhcp pool as reference, just change the pool name. Don't forget to add the appropriate dhcp exclude for the new dhcp pool. The router will be able to determine which dhcp pool to use based on which interface the client dhcp discover packet was recevied on.

    Then I would like to send the internet from eth 0/0 to both those interfaces.
    The wording of your post is confusing. If you are wanting to "permit" hosts connected to both interface 0/1 and interface e1/0 access to the internet (via NAT overload), then just add "ip nat inside" to the e1/0 configuration. The ACL you are referencing (100) for the NAT overload statement is already permitting everything. So any interface that has "ip nat inside" will get NAT'd to internet.
    Last edited by scowles; 7th July 2008, 12:02.


    • #3
      Re: multiple DHCP on cisco 2611


      Would it be possible for you to post your final Config,
      because i want to setup the same, but don't know how to configure it.

      Maybe my setup is a big different, let me try to explain.
      I have 3 locations on a 3560G switch, and i want to give them different ip's, but in the same subnet (
      Is that possible in your setup or do i need to do something else?

      Best Regards

      Frederik Larsen
      Last edited by Frederik_Larsen; 7th July 2008, 12:39.


      • #4
        Re: multiple DHCP on cisco 2611

        yep, i am going to work on it eventually, then i will post the final config...also that solution makes a lot of sense, it just takes time to think out. Thank-you!