Announcement

Collapse
No announcement yet.

Multiple T1's into a 2811

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Multiple T1's into a 2811

    Hi all,

    I have a 2811 (ios version 12.4) with 2 2-port WIC's. We currently have 1 T1 on this router. We are in the process of provisioning another T1 to up the bandwidth on this circuit from 1500k to 3000k.

    Since I've never "combined" multiple T's into one serial interface before, I'm a little fuzzy on the details of how to do it. Whenever I try to do Google searches, I get all kinds of info, but nothing that applies to what I'm trying to do.

    So, the version of WIC in this router requires a separate "controller" definition as such (as opposed to defining the timeslots in the serial interface):
    controller T1 0/0/0
    framing esf
    linecode b8zs
    channel-group 0 timeslots 1-24


    Then, we have the serial interface defined as such:
    interface Serial0/0/0:0
    ip address 192.168.xxx.xxx 255.255.255.252
    ip nbar protocol-discovery
    encapsulation ppp
    service-policy output SDM-Pol-Serial0/0/0:0


    My first question is how is the serial interface tied to a particular controller interface?

    I assume that when I add the second T, I'll define the next controller interface similar to the first:
    controller T1 0/0/1
    framing esf
    linecode b8zs
    channel-group 0 timeslots 1-24


    So, my second question is how then will the existing serial 0/0/0:0 map to the new controller interface (0/0/1) in addition to the existing one (0/0/0)?

    Does it have to do with the channel-group 0 in the controller def. matching up to the 0/0/0:0 in the serial interface def.?

    Thanks,
    JasonL

  • #2
    Re: Multiple T1's into a 2811

    At my company, we initially started out with a single T1 for Internet access. That gave us 1.5Mb up and 1.5Mb down. Over time, we outgrew the 1.5Mb down as we added more users. We had to add more bandwidth; however, it was not cost effective to bring in a DS3 or fractional DS3 for Internet access, just to add one or two more T1 circuits. Also, we wanted the circuits to act as a single circuit, not two or three independent circuits. We ended up ordering two additional T1 circuits in a multilink PPP bundle. Later, we added one more T1 circuit. With a total of four T1 circuits for Internet access, this gives us a total of 6Mb of Internet bandwidth (6Mb upstream and 6Mb downstream). But how do you configure four T1 circuits to act as one? Find out how Multilink PPP can help.

    What is Multilink PPP?

    PPP is a standards-based protocol based on a RFC (Request for Comments document); Multilink PPP is also a standard based on an RFC. Specifically, Multilink PPP is based on RFC2686 - The Multi-Class Extension to Multi-Link PPP and RFC 1990 - The PPP Multilink Protocol (MP).

    The point of Multilink PPP is to take multiple PPP links and “bond” them together to act as a single PPP link. These PPP links that are being bonded could be an ISDN BRI circuit, T1 circuits, or other types of PPP circuits. You should know that Multilink PPP must be configured on each side of the link. Thus, you cannot get multiple PPP T1 circuits from multiple carriers and expect to run Multilink PPP across them. All Multilink PPP circuits must come from the same carrier.

    Multilink PPP is not something new; it has been around for a long time. However, in the past it was primarily used to bond together multiple, slower dial-up circuits (like ISDN circuits). While I am sure there are plenty of companies out there still using Multilink PPP with dial-up connections, it is now more common that Multilink PPP is being used to combine multiple circuits of T1 or higher bandwidth into a single circuit.

    How do you configure Multilink PPP?

    Given that the two sites that are connecting via Multilink PPP communicate with each other and coordinate the configuration, configuring Multilink PPP is easy. Here is a sample configuration of four T1 circuits being bonded to form a single 6Mb Internet circuit:

    controller T1 0/0/0
    framing esf
    linecode b8zs
    channel-group 0 timeslots 1-24
    !
    controller T1 0/0/1
    framing esf
    linecode b8zs
    channel-group 0 timeslots 1-24
    !
    controller T1 0/1/0
    framing esf
    linecode b8zs
    channel-group 0 timeslots 1-24
    !
    controller T1 0/1/1
    framing esf
    linecode b8zs
    channel-group 0 timeslots 1-24
    !
    interface Multilink1
    ip address 1.1.1.1 255.255.255.252
    no cdp enable
    ppp multilink
    ppp multilink group 1
    !
    interface Serial0/0/0:0
    no ip address
    encapsulation ppp
    no fair-queue
    ppp multilink
    ppp multilink group 1
    !
    interface Serial0/0/1:0
    no ip address
    encapsulation ppp
    no fair-queue
    ppp multilink
    ppp multilink group 1
    !
    interface Serial0/1/0:0
    no ip address
    encapsulation ppp
    no fair-queue
    ppp multilink
    ppp multilink group 1
    !
    interface Serial0/1/1:0
    no ip address
    encapsulation ppp
    no fair-queue
    ppp multilink
    ppp multilink group 1
    This configuration is from a Cisco 3845 router that has Qty 2 VWIC-2MFT-T1 interfaces. These T1 controllers create the Serial0/0/0, 0/0/1, 0/1/0, and 0/1/1 interface that are bound to the multilink group #1.

    It is the multilink1 interface that is actually the single combined interface that really has the “6Mb” of bandwidth, and that is where you would apply all of your “normal interface configuration” for this 6Mb connection that connects to the Internet. You can see how the multilink 1 interface has an interface number that matches the ppp multilink group. On that multilink 1 interface, you have the IP address for this link, an ACL on the interface, firewall, NAT, or other Internet public router interface commands.

    By using the multilink interface, you are able to bond all four of these T1 interfaces into a single router interface — very cool!

    To verify that your multilink interfaces are up and running, you can use the show ppp multilink command, like this:

    Router# show ppp multilink

    Multilink1, bundle name is MY-ISP
    Endpoint discriminator is MY-ISP
    Bundle up for 10w0d, total bandwidth 6144, load 25/255
    Receive buffer limit 48000 bytes, frag timeout 1000 ms
    2/3020 fragments/bytes in reassembly list
    204716 lost fragments, 310561297 reordered
    474999/517174257 discarded fragments/bytes, 474999 lost received
    0x256CD0 received sequence, 0x2071C9 sent sequence
    Member links: 4 active, 0 inactive (max not set, min not set)
    Se0/1/1:0, since 10w0d
    Se0/1/0:0, since 10w0d
    Se0/0/0:0, since 10w0d
    Se0/0/1:0, since 10w0d
    No inactive multilink interfaces

    Router#


    The key to configuring Multilink PPP is the multilink interface, the ppp multilink protocol on each router, and the ppp multilink group x command on each interface. Multilink PPP isn’t a difficult router configuration to set up, and it is extremely valuable when you need multiple circuits bonded into a single circuit from a single provider.

    Comment


    • #3
      Re: Multiple T1's into a 2811

      Sweet! Thanks Scott.

      I'm sure PPP multilink is what my provider will be using. They specified that the additional T1 had to be from the same carrier as the first one.

      Now I know how to set it up on my end.

      Thanks again!

      Jason

      Comment


      • #4
        Re: Multiple T1's into a 2811

        You may need to specify to your carrier or ISP that you want to run MLPPP as the new port in the PE device needs to be collocated with the existing port. Also you will likely experience a brief outage when you turn this up as the mulilink will typically use a different IP address. You will need to modify your current config to be MLPPP. If you are running a routing protocol like EBGP with the provider remember the neighbor IP address may also need to change, if static routes then your next hop can be either the PE IP Address or the interface. Just some gotcha's that can crop up. I work for an carrier in Managed Services and the fact they tell you it needs to be the same carrier does not necessarily mean they are planning on doing MLPPP for you. There are instances where a customer wants a second T1 but not for bandwidth aggregation.

        If the carrier does not want to run MLPPP for some reason their are other methods for getting some semblance of load sharing or load balancing with a carrier using EBGP with multihop and multipath.

        Comment

        Working...
        X