Announcement

Collapse
No announcement yet.

Inter VLAN routing problem with sisco 1800 series router (fixed) configuration

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Inter VLAN routing problem with sisco 1800 series router (fixed) configuration

    Hi every body

    I have recently been experiencing a wierd situation while configuring my 1812 series router to router between VLAN's.

    The sisco 1812 series router has two fast enthernet WAN links and 8 fast ethernet ports on its integrated switch module.

    I am newbie in the cisco world and not very good in using the CLI but have used SDM a couple of moments to make various configurations which worked with no problems.

    Problem description

    I have three VLAN's, 1,2 3 on my router
    the following are VLAN configurations

    config t
    int vlan1
    ip address 192.168.1.1 255.255.255.0
    no shutdown

    int vlan2
    ip address 192.168.2.1 255.255.255.0
    no shutdown

    int vlan3
    ip address 192.168.3.1 255.255.255.0
    no shutdown

    I have computers connected to their respective LAN's and I can ping them right from my router's CLI

    I tried to configure static routing so that computers could communicate accross these VLAN's

    the following is the configuration

    config t
    ip routing
    ip route 192.168.1.0 255.255.255.0 vlan1
    ip route 192.168.2.0 255.255.255.0 vlan2
    ip route 192.168.3.0 255.255.255.0 vlan3

    However, when I try to list the static routes via the 'show ip route static' command I get nothing listed.

    Trying to ping a machine from a different subnet doesn't work either.

    I have gone through many sites and read dosen of articles. According to what I know is that you should be able to list the static routes via the 'show ip route static' command after adding static routes, which for some reasons doesn't work for me.

    I am not sure what I am actually missing, but things don't really behave nicely to me!

    Any help would greatly be appreciated.

  • #2
    Re: Inter VLAN routing problem with sisco 1800 series router (fixed) configuration

    Can you list a sh run and a sh ver ?

    Comment


    • #3
      Re: Inter VLAN routing problem with sisco 1800 series router (fixed) configuration

      try the following

      config t

      ip routing

      ip router rip
      network 192.168.1.0
      network 192.168.2.0
      network 192.168.3.0

      Comment


      • #4
        Re: Inter VLAN routing problem with sisco 1800 series router (fixed) configuration

        Without seeing your entire running configuration, its hard to tell where your problem is.

        But based on your problem description, it sounds like you may not have created the layer 2 vlan definitions for vlans 2 and 3. To verify, Type:

        Code:
        show ip int brief
        -or-
        Code:
        show vlans 1
        show vlans 2
        show vlans 3
        if the output from "show ip int brief" shows interface vlans 2 and 3 as up/down (status/protocol), then you would need to create the layer 2 vlan definitions so the protocol for the vlan interfaces 2 and 3 will come up. To create the layer 2 vlan definitions, type:
        Code:
        config t
        vlan 2
         name network_2
        vlan 3
         name network_3
        As for the static routes... you are trying to add static routes for already "connected" networks. In this case, interface vlans 1-3. Cisco IOS will accept the static routes from the command line, but it will not add them to the route tables because they are considered connected via the vlan interface definitions. Type: "show ip route" and notice the connected status to see what I am referring to.

        Comment

        Working...
        X