Announcement

Collapse
No announcement yet.

new to VLANs, need some help please :-D

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • new to VLANs, need some help please :-D

    Hi everyone, my first task was getting the router running. Now I want to set up a few VLANs. I don't know anything about VLANs or for the matter switches. But a simple switch seemed easy to set up. Now I can get each VLAN to work. I have 4 VLANs setup right now.
    VLAN1>8 Ports
    VLAN2>8 Ports
    VLAN3>6 Ports
    VLAN4>2 Ports
    Now, I would like to use port 1 as my uplink from my router. But I want that port to go to each VLAN. My Cisco 2611 router provides the internet and it only has two ethernet ports (internet and network in my setup).

    So my question: How would I go about setting up each VLAN so that the VLANs can share the same internet but not be able to talk to each other?

    Thanks!

    Running Config:
    Building configuration...

    Current configuration:
    !
    version 11.2
    no service pad
    no service udp-small-servers
    no service tcp-small-servers
    !
    hostname IntechSwitch
    !
    enable secret 5 $1$cqoH$E1By4/.zY9xatcLc4iF7k0
    enable password mcleod
    !
    !
    !
    !
    interface VLAN1
    description Main Computers/12 Port Hub
    ip address 19.0.0.2 255.0.0.0
    no ip route-cache
    !
    interface VLAN2
    description Intech Networks
    ip address 19.0.0.3 255.0.0.0
    no ip route-cache
    shutdown
    !
    interface VLAN3
    description Wall Ports
    no ip route-cache
    shutdown
    !
    interface VLAN4
    description Wireless Internet
    no ip route-cache
    shutdown
    !
    interface FastEthernet0/1
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    switchport access vlan 2
    !
    interface FastEthernet0/10
    switchport access vlan 2
    !
    interface FastEthernet0/11
    switchport access vlan 2
    !
    interface FastEthernet0/12
    switchport access vlan 2
    !
    interface FastEthernet0/13
    switchport access vlan 2
    !
    interface FastEthernet0/14
    switchport access vlan 2
    !
    interface FastEthernet0/15
    switchport access vlan 2
    !
    interface FastEthernet0/16
    switchport access vlan 2
    !
    interface FastEthernet0/17
    switchport access vlan 3
    !
    interface FastEthernet0/18
    switchport access vlan 3
    !
    interface FastEthernet0/19
    switchport access vlan 3
    !
    interface FastEthernet0/20
    switchport access vlan 3
    !
    interface FastEthernet0/21
    switchport access vlan 3
    !
    interface FastEthernet0/22
    switchport access vlan 3
    !
    interface FastEthernet0/23
    switchport access vlan 4
    !
    interface FastEthernet0/24
    switchport access vlan 4
    !
    ip default-gateway 192.168.2.1
    banner motd ^C
    Intech Networks Main Switch- Authorized Staff Only!

    ^C
    !
    line con 0
    stopbits 1
    line vty 0 1
    password mcleod
    login
    line vty 2 4
    login
    line vty 5 9
    login
    !
    end

  • #2
    Re: new to VLANs, need some help please

    You can create four subinterface on one phisical link.
    Assume that You have four VLAN for example:
    192.168.10.32/27
    192.168.10.64/27
    192.168.10.96/27
    192.168.10.128/27

    On the Routers you have to define four subinterfaces:
    In the subnetworks above It will be:


    F0.1 192.168.10.33/27
    F0.2 92.168.10.65/27
    F0.3 192.168.10.97/27
    F0.4 192.168.10.129/27

    If you don't want to talk between Vlans you can use access list to deny access between Vlans.
    Last edited by Rafaello; 29th June 2008, 10:34.

    Comment


    • #3
      Re: new to VLANs, need some help please

      I don't think subinterfaces can work on 2611, in my opinion, subinterfaces only can work on a 100M interface, but 2611 has 2 10M interface, you need a 2621.

      Comment

      Working...
      X