Announcement

Collapse
No announcement yet.

cisco 2611 and comcast

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • cisco 2611 and comcast

    Hello everyone! I just bought a Cisco 2611 off of ebay ($50) so that I can play around with it and figure out how it works away from school (im learning to be a CCNA right now).

    I went to go set it up this morning.

    This is what ive done so far:

    Building configuration...

    Current configuration : 877 bytes
    !
    version 12.2
    service config
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname IntechRouter
    !
    enable secret 5 $1$vzO/$xLPtWbxxpg3gWXD45it/8/
    enable password mcleod
    !
    ip subnet-zero
    !
    !
    ip dhcp excluded-address 19.0.0.1 19.0.0.99
    !
    ip dhcp pool InsideNetwork
    network 19.0.0.0 255.0.0.0
    dns-server 68.87.77.130 68.87.72.130
    default-router 19.0.0.1
    !
    !
    !
    !
    interface Ethernet0/0
    description Comcast Cable Modem
    ip address dhcp
    half-duplex
    !
    interface Ethernet0/1
    description Connection to Cisco 2924-XL Switch
    ip address 19.0.0.1 255.0.0.0
    ip nat inside
    half-duplex
    !
    router eigrp 100
    network 19.0.0.0
    auto-summary
    !
    ip classless
    ip http server
    !
    banner motd ^C
    Intech Networks Main Router- Authorized Staff Only!

    ^C
    !
    line con 0
    line aux 0
    line vty 0 1
    password mcleod
    login
    line vty 2 4
    login
    !
    end


    command: sh ip int brief


    Interface IP-Address OK? Method Status Protocol
    Ethernet0/0 71.87.243.19 YES DHCP up down
    Ethernet0/1 19.0.0.1 YES NVRAM up up


    any ideas why i'm not able to get on the internet? I can get to my servers homepage (using the private static IP i assigned it) just fine and i can ping the router's e0/1 interface and i can also ping to other computers. The problem comes when I try to get online to like google.com or something.

    also i should note:

    the router is getting an IP from the comcast DHCP server, the line protocols are up on both interfaces, however i still cannot connect to the internet.


    Thanks!
    Mike McLeod

  • #2
    Re: cisco 2611 and comcast

    A) You didn't configure NAT correctly.
    B) your Eth1 is not up (should be up up like eth0)
    C) I don't see an Access-list to allow traffic.
    Marcel
    Technical Consultant
    Netherlands
    http://www.phetios.com
    http://blog.nessus.nl

    MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
    "No matter how secure, there is always the human factor."

    "Enjoy life today, tomorrow may never come."
    "If you're going through hell, keep going. ~Winston Churchill"

    Comment


    • #3
      Re: cisco 2611 and comcast

      so how can i fix it?

      Comment


      • #4
        Re: cisco 2611 and comcast

        does anyone know how to fix it?

        Comment


        • #5
          Re: cisco 2611 and comcast

          Didn't you already tried for searching it yourself?

          Ok, a few articles to read:

          A)
          How to configure NAT on Cisco.
          http://www.cisco.com/en/US/tech/tk64...80094e77.shtml
          http://www.cisco.com/en/US/docs/secu...de/cfgnat.html


          B) I don't know. Please post a show int status of the interface which is down.

          C)
          How to configure Access-lists on Cisco
          http://www.cisco.com/en/US/products/...800a5b9a.shtml
          Marcel
          Technical Consultant
          Netherlands
          http://www.phetios.com
          http://blog.nessus.nl

          MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
          "No matter how secure, there is always the human factor."

          "Enjoy life today, tomorrow may never come."
          "If you're going through hell, keep going. ~Winston Churchill"

          Comment


          • #6
            Re: cisco 2611 and comcast

            ethernet 0/1 is not down. It works because computers inside the network are getting IP's from it and I can ping

            Comment


            • #7
              Re: cisco 2611 and comcast

              sorry I meant eth 0/0
              Marcel
              Technical Consultant
              Netherlands
              http://www.phetios.com
              http://blog.nessus.nl

              MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
              "No matter how secure, there is always the human factor."

              "Enjoy life today, tomorrow may never come."
              "If you're going through hell, keep going. ~Winston Churchill"

              Comment


              • #8
                Re: cisco 2611 and comcast

                its not down either, but thanks for those guides, those fixed the problem!

                Comment


                • #9
                  Re: cisco 2611 and comcast

                  Glad you solved it
                  In my opinion it's always better to solve it yourself using guides then I rewrite completely your config.
                  Otherwise you wouldn't learn it

                  Although I think it's strange Eth0 is up because of this:

                  Interface IP-Address OK? Method Status Protocol
                  Ethernet0/0 71.87.243.19 YES DHCP up down

                  In my opinion it's telling that the protocol is down...

                  Oh ps,
                  Maybe you can tell what you have changed for others
                  Marcel
                  Technical Consultant
                  Netherlands
                  http://www.phetios.com
                  http://blog.nessus.nl

                  MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
                  "No matter how secure, there is always the human factor."

                  "Enjoy life today, tomorrow may never come."
                  "If you're going through hell, keep going. ~Winston Churchill"

                  Comment


                  • #10
                    Re: cisco 2611 and comcast

                    Running Config:
                    Building configuration...

                    Current configuration : 945 bytes
                    !
                    version 12.2
                    service timestamps debug uptime
                    service timestamps log uptime
                    no service password-encryption
                    !
                    hostname IntechRouter
                    !
                    enable secret 5 $1$MgYM$VeHt5guWqEhl45NMF9Xz80
                    enable password mcleod
                    !
                    ip subnet-zero
                    !
                    !
                    ip dhcp excluded-address 19.0.0.1 19.0.0.99
                    !
                    ip dhcp pool NetworkDHCP
                    import all
                    network 19.0.0.0 255.0.0.0
                    default-router 19.0.0.1
                    dns-server 68.87.77.130 68.87.72.130
                    lease 0 5
                    !
                    !
                    !
                    !
                    interface Ethernet0/0
                    description Comcast Cable Modem
                    ip address dhcp
                    ip nat outside
                    half-duplex
                    !
                    interface Ethernet0/1
                    description Cisco 2924-XL Switch
                    ip address 19.0.0.1 255.0.0.0
                    ip nat inside
                    half-duplex
                    !
                    ip nat inside source list 100 interface Ethernet0/0 overload
                    ip classless
                    ip http server
                    !
                    access-list 100 permit ip any any
                    banner motd ^C

                    Intech Networks Main Router (Cisco 2611) Authorized Staff Only!
                    ^C
                    !
                    line con 0
                    line aux 0
                    line vty 0 1
                    password mcleod
                    login
                    line vty 2 4
                    login
                    !
                    end

                    Comment


                    • #11
                      Re: cisco 2611 and comcast

                      now my next task is to upgrade to the cisco 2621 so i can get 10/100 ports

                      Comment

                      Working...
                      X