No announcement yet.

Kron copy tftp issues

  • Filter
  • Time
  • Show
Clear All
new posts

  • Kron copy tftp issues

    Hi Guys,

    I have a requirement to change MoH files regularly at about 40 sites and I'm looking at tftp'ing via Kron on a monthly schedule.

    I've been using the following code on a 2821 with ADVIPSERVICESK9-M Version 12.4(11)

    file prompt quiet
    kron policy-list MoH-Download
    cli copy tftp://
    kron occurrence MoH-Download-Schedule at 14:31 17 recurring
    policy-list MoH-Download
    Using 'debug kron all' I see the following output

    Apr 17 15:05:46.639 AEST: Major 1, Minor 0
    Apr 17 15:05:46.639 AEST: Timer Event MoH-Download-Schedule
    Apr 17 15:05:46.639 AEST: Kron delay for next MoH-Download-Schedule 2592000000
    Apr 17 15:05:46.639 AEST: Call parse_cmd 'copy tftp://'
    Apr 17 15:05:48.780 AEST: Major 4, Minor 8
    Apr 17 15:05:48.780 AEST: Signaled from Runaway Process
    Apr 17 15:05:48.780 AEST: Forcing Removing Policy MoH-Download
    Apr 17 15:05:48.780 AEST: Removing Policy MoH-Download
    Apr 17 15:05:48.780 AEST:     Removing CLI 'copy tftp://'
    Apr 17 15:05:48.780 AEST: Done Removing Policy MoH-Download
    My first question is; if the occurrence is configured as recurring, then why does it remove the policy?
    What will it run when next scheduled?

    The main issue is, whilst it runs If I do a 'show flash' I see:
    3 4096 Apr 17 2008 15:05:48 +10:00

    The file should be about 4 meg not 4k.

    If I try and delete the file I get:

    Delete [confirm]
    %Error deleting (File in use in an incompatible mode)
    If I reboot the router (its in a test lab) the file in flash shows 0 in size and I can now delete it.

    I have tried with an alternate file (a 300k text file) with the same result.
    The file size is 4096k and I cannot delete it until a reboot.

    I can run the command outside of kron and it works fine.
    Any Ideas?