Announcement

Collapse
No announcement yet.

Cisco 857w dhcp server doesn't work

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco 857w dhcp server doesn't work

    router:Cisco 857W
    IOS: ver 12.4

    I am not sure why, but dhcp doesn't work on the router. I am able to bring up all interfaces, connect with DSL provider, broadcast SSID, but dhcp will not not serve any IP addresses.

    Vlan1 is set up to have 192.168.10.1/24 when I manually assign IP address on the laptop (wired or wireless) it is still not connecting. I am able to ping the DNS server from the router, or any other IP addresses on the internet.
    Laptop can't ping the router (with manually configured IP address).

    Below is the config file.... what am I missing?

    TIA

    -----CONFIG-----
    show running-config
    Building configuration...

    Current configuration : 5695 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname cisco857w
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 51200 warnings
    enable secret 5 xxxxxxxxxx
    enable password password
    !
    no aaa new-model
    !
    resource policy
    !
    no ip source-route
    ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.10.1 192.168.10.2
    !
    ip dhcp pool LAN
    import all
    network 192.168.10.0 255.255.255.0
    dns-server 4.4.4.4
    default-router 192.168.10.1
    lease 0 2

    !
    !
    ip cef
    ip inspect udp idle-time 1800
    ip inspect dns-timeout 7
    ip inspect tcp idle-time 14400
    no ip bootp server
    no ip domain lookup
    ip domain name yourdomain.com
    vpdn-group ppoe
    !
    !
    !
    crypto pki trustpoint TP-self-signed-4199505335
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-4199505335
    revocation-check none
    rsakeypair TP-self-signed-4199505335
    !
    !
    crypto pki certificate chain TP-self-signed-4199505335
    certificate self-signed 01
    3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
    DD01E0E2 6CC7FD8B 73DD37B5 C66F2C58 79
    quit
    username admin privilege 15 secret 5 xxxxxxxxx
    !
    !
    !
    bridge irb
    !
    !
    interface ATM0
    bandwidth 768
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    shutdown
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    no snmp trap link-status
    pvc 0/35
    protocol bridge
    pppoe-client dial-pool-number 1
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    shutdown
    !
    interface FastEthernet2
    shutdown
    !
    interface FastEthernet3
    shutdown
    !
    interface Dot11Radio0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    shutdown
    !
    encryption key 1 size 128bit 0 xxxxxxxxx transmit-key
    encryption mode wep mandatory
    !
    ssid cisco857w
    authentication open
    guest-mode
    !
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
    station-role root
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    !
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
    ip address 192.168.10.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1412
    bridge-group 1
    bridge-group 1 spanning-disabled
    !
    interface Dialer0
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1452
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap pap callin
    ppp chap hostname [email protected]
    ppp chap password 0 password
    ppp pap sent-username [email protected] password 0 password
    !
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    dialer pool 2
    dialer-group 2
    no cdp enable
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat inside source list 1 interface Dialer0 overload
    ip nat inside source route-map NONAT interface Dialer0 overload
    !
    access-list 1 permit 192.168.10.0 0.0.0.255
    dialer-list 1 protocol ip permit
    no cdp run
    !
    control-plane
    !
    banner login ^C
    -----------------------------------------------------------------------
    Cisco Router and Security Device Manager (SDM) is installed on this device.
    -----------------------------------------------------------------------
    ^C
    !
    line con 0
    login local
    no modem enable
    line aux 0
    line vty 0 4
    access-class 23 in
    privilege level 15
    password password
    login local
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    end
    -----CONFIG-----

  • #2
    Re: Cisco 857w dhcp server doesn't work

    I was able to fix it using post http://forums.petri.com/showthread.p...4512#post64512
    by Unclo_Bob
    857 is working just fine.

    Comment


    • #3
      Re: Cisco 857w dhcp server doesn't work

      Glad you solved it so quickly
      Marcel
      Technical Consultant
      Netherlands
      http://www.phetios.com
      http://blog.nessus.nl

      MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
      "No matter how secure, there is always the human factor."

      "Enjoy life today, tomorrow may never come."
      "If you're going through hell, keep going. ~Winston Churchill"

      Comment

      Working...
      X