Announcement

Collapse
No announcement yet.

[HELP] Problems with Cisco 1721 connecting to my DSL with an EXTERNAL modem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [HELP] Problems with Cisco 1721 connecting to my DSL with an EXTERNAL modem

    Hello Guys!

    First post and really hoping to get some help here! Been trying to get this working for a while and with no luck, here is my setup and config: I just can't seem to ping anything (eg. 4.2.2.2) from inside my router.

    ISP Provider (PPPoE) - DSL Modem - Cisco 1700

    My config:
    =================
    Current configuration : 2112 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname smith
    !
    boot-start-marker
    boot-end-marker
    !
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    no aaa new-model
    ip subnet-zero
    !
    !
    ip domain name domain.com
    ip name-server 4.2.2.2
    !
    ip cef
    ip audit po max-events 100
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pppoe
    !
    !
    !
    !
    !
    ip ssh authentication-retries 2
    ip ssh source-interface Ethernet0
    !
    !
    !
    !
    interface Ethernet0
    description ADSL WAN Interface to Velcom
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    no ip mroute-cache
    full-duplex
    pppoe enable
    pppoe-client dial-pool-number 1
    no cdp enable
    !
    interface FastEthernet0
    description ADSL LAN Interface
    ip address 192.168.1.2 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    no ip mroute-cache
    speed auto
    no cdp enable
    !
    interface Dialer1
    description ADSL WAN Dialer
    ip address 64.24.16.19 255.0.0.0
    no ip unreachables
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    no ip mroute-cache
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname [email protected]$$$$$$$$.com
    ppp chap password 7 $$$$$$$$$$$$$
    ppp pap sent-username [email protected]$$$$$$$$$$.com password 7 $$$$$$$$$$$$$$

    !
    ip nat inside source list 10 interface Dialer1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 600 life 86400 requests 10000
    !
    !
    access-list 10 permit 192.168.1.0 0.0.0.255
    dialer-list 1 protocol ip permit
    no cdp run
    !
    !
    !

    line con 0
    password
    login
    line aux 0
    password
    login
    line vty 0 4
    privilege level 15
    password
    login local
    transport input telnet ssh
    !
    end


    ================================


    I can't ping anything by connecting to my routers terminal, but when i turn on debugging here is what I get:

    00:10:27: Thread slow_thread: Emptyoff
    00:10:28: CEF: background resolution thread state:
    00:10:28: Thread fast_thread: Empty
    00:10:28: Thread todothread: Empty
    00:10:28: Thread slow_thread:
    00:10:29: CEF: background resolution thread state:
    00:10:29: Thread fast_thread: Empty
    00:10:29: Thread todothread: Empty
    00:10:29: Thread slow_thread: EmptyPQUICC_FEC(0/0): PHY 0 Read reg = 0 val = 1000
    PQUICC_FEC(0/0): PHY 0 Read reg = 11 val = 588
    PQUICC_FEC(0/0): PHY 0 Read reg = 11 val = 588
    PQUICC_FEC(0/0): PHY 0 Read reg = 11 val = 588
    PQUICC_FEC(0/0): PHY 0 Read reg = 0 val = 1000
    PQUICC_FEC(0/0): PHY 0 Read reg = 4 val = 1E1
    PQUICC_FEC(0/0): PHY 0 Wrote reg = 4 val = 1E1
    PQUICC_FEC(0/0): PHY 0 Wrote reg = 0 val = 1000
    PQUICC_FEC(0/0): PHY 0 Read reg = 12 val = 62
    PQUICC_FEC(0/0): PHY 0 Wrote reg = 12 val = 62

  • #2
    Re: [HELP] Problems with Cisco 1721 connecting to my DSL with an EXTERNAL modem

    I've never used the DSL dialer.

    I've always put my DSL modem in Bridge mode then made the "outside" interface the same subnet and made that my default Gateway.

    you basically get a (Inside PRivate IP Range) <1700> (Private Range) <DSLMDM> Outside

    A simple Example might be
    192.168.1.0/24 on the inside
    192.168.0.0/24. for Cisco to DSL network.

    Comment

    Working...
    X