Announcement

Collapse
No announcement yet.

How 2 configure VLANs on Layer 3 switch

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How 2 configure VLANs on Layer 3 switch

    i am unable to understand configure VLANs on Catalyst 4506 because [Video on How to Configure VLAN s in the Cisco IOS] was using Router based trunking.

    Actually I do not know VLAN, I never did it before I come to know about this by that video and on Cisco website and I need to do this with Catalyst 4506, 2950, 2960 on a live network.

    What I need to do is create 6 broadcast domains (ip 192.0.0.x/1.x/2.x/3.x/4.x/5.x) and Catalyst 4506 will be the Gateway for Clients machines. All clients should communicate with each other.

    I need your help in this. So I request you to please provide help, please.

  • #2
    Re: How 2 configure VLANs on Layer 3 switch

    Have a read on this
    http://www.ciscopress.com/articles/a...&seqNum=5&rl=1
    Marcel
    Technical Consultant
    Netherlands
    http://www.phetios.com
    http://blog.nessus.nl

    MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
    "No matter how secure, there is always the human factor."

    "Enjoy life today, tomorrow may never come."
    "If you're going through hell, keep going. ~Winston Churchill"

    Comment


    • #3
      Re: How 2 configure VLANs on Layer 3 switch

      Hi kris_amar,

      Having a Layer 3 switch you don't need a router to handle the inter VLAN routing, this will be done by your Catalyst 4506.

      The main steps configuring VLANs and the inter VLAN routing are:

      1.Define the VLANs
      To create a VLAN named Desktop, run the following commands in privileged mode,

      conf t
      vlan 40
      name Desktop
      exit


      2. Add the switch ports to previusly created VLANs
      Exp: Fa0/2 to Desktop VLAN

      conf t
      int fa0/2
      switchport mode access
      switchport access vlan 40
      exit


      3.Create a Layer 3 (SVI) interface for eatch VLAN

      conf t
      interface vlan 40
      ip address 192.168.0.1 255.255.255.0
      no shutdown
      exit


      3. For Internet access, add a default route to the routing table

      conf t
      ip route 0.0.0.0 0.0.0.0 192.168.12.1


      where 192.168.12.1 is the IP of your Inernet gateway.
      Regards,
      Csaba Papp
      MCSA+messaging, MCSE, CCNA
      ...............................
      Remember to give credit where credit is due and leave reputation points where appropriate
      .................................

      Comment


      • #4
        Re: How 2 configure VLANs on Layer 3 switch

        Hi Netxt

        In your example STEP 3 SVI interface VLAN 40 has ip add 192.168.0.1/24 and STEP 2: fa0/2 assigned to valn 40.

        The ip add 192.168.0.1 will be th gateway for the client who is connected to fa0/2, is it correct.

        Do I need to configure VTP, if yes, then pl show me how 2. which switch should be server or client or transprant and why. because I have Cat 2950 (5 nos), Cat 2960 (6 nos) and Cat 4506 (1 no). And all are working on default VLAN 1 and VTP server mode.


        By using this example, if I create VLAN 20, 30, and 40 with different network ids then the clients on VLAN 20 can communicate with the clients on other VLANs
        Last edited by kris_amar; 9th January 2008, 11:51. Reason: some of the text missing

        Comment


        • #5
          Re: How 2 configure VLANs on Layer 3 switch

          1. 192.168.0.1 will be the gatway for the entire VLAN 40 no just for clients conected to fa0/2.
          Exp. if you assign fa0/2, fa0/3,..... fa0/10 to Vlan 40 all computers connected to these porsts should have the gateway 192.168.0.1

          2. VTP (virtual truncking protocol) is used to reduces administration in a switched network. When you configure a new VLAN on one VTP server, the VLAN is distributed through all switches in the domain. This reduces the need to configure the same VLAN everywhere. VTP is a Cisco-proprietary protocol that is available on most of the Cisco Catalyst series products.

          Having a larg number of switches and VLANs in your LAN it is a good idea to use VTP. Configure your Catalyst 4500 as the vtp server. Do it, using the vtp commands in configuration mode (vtp domain, vtp mode, vtp password).
          Regards,
          Csaba Papp
          MCSA+messaging, MCSE, CCNA
          ...............................
          Remember to give credit where credit is due and leave reputation points where appropriate
          .................................

          Comment


          • #6
            Re: How 2 configure VLANs on Layer 3 switch

            Just to clarify: VTP = VLAN Trunk Protocol. Here's the lowdown on VTP from Cisco:

            http://www.cisco.com/warp/public/473/21.html

            Comment


            • #7
              Re: How 2 configure VLANs on Layer 3 switch

              Thanks joeqwerty

              I got the concept on VTP, thanks.

              Comment


              • #8
                Re: How 2 configure VLANs on Layer 3 switch

                Originally posted by netxt View Post
                Hi kris_amar,

                Having a Layer 3 switch you don't need a router to handle the inter VLAN routing, this will be done by your Catalyst 4506.

                The main steps configuring VLANs and the inter VLAN routing are:

                1.Define the VLANs
                To create a VLAN named Desktop, run the following commands in privileged mode,

                conf t
                vlan 40
                name Desktop
                exit


                2. Add the switch ports to previusly created VLANs
                Exp: Fa0/2 to Desktop VLAN

                conf t
                int fa0/2
                switchport mode access
                switchport access vlan 40
                exit


                3.Create a Layer 3 (SVI) interface for eatch VLAN

                conf t
                interface vlan 40
                ip address 192.168.0.1 255.255.255.0
                no shutdown
                exit


                3. For Internet access, add a default route to the routing table

                conf t
                ip route 0.0.0.0 0.0.0.0 192.168.12.1


                where 192.168.12.1 is the IP of your Inernet gateway.
                Hello And hi,

                I am new user over here and i feel that you are the right person who can solve my problem,

                Actually i m fresher to IT feild and have no experience in this feld have done only MCSE, and recently got a job in IT sector. and i got an assignment as it is very imp for my job can u please help me in this

                We recently got cisco catalyst switch 3500 XL, and i want to do VLAN on that,

                We are remotely connected to SOuthafrica,

                THere is only one switch at the moment of cisco 2950 XL and adding one more new switch of 3500 XL,

                need to create three VLAN's can u put down this a by step by step from switch log in to creating VLAN, and ip route for internet and every setting.

                Comment

                Working...
                X