Announcement

Collapse
No announcement yet.

VPN on a CIsco 1760 Router with dyndns

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • VPN on a CIsco 1760 Router with dyndns

    I have the configuration as below but somehow I can not log in with the cisco vpn client. The config has a dyndns hostname for the router with a dynamic external ip address, and the router is a fully loaded cisco 1760 with ipadvservice v12.4. What am I missing?

    Current configuration : 3088 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log uptime
    service password-encryption
    !
    hostname c1760
    !
    boot-start-marker
    boot-end-marker
    !
    enable password 7 xxxxxxx
    !
    no aaa new-model
    !
    resource policy
    !
    ip cef
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.254
    ip dhcp excluded-address 192.168.1.1 192.168.1.20
    !
    ip dhcp pool my_dhcp
    network 192.168.1.0 255.255.255.0
    dns-server 212.71.8.11 212.71.0.2
    default-router 192.168.1.254
    !
    ip domain name dyndns.org
    ip host members.dyndns.org 63.208.196.96
    ip name-server 212.71.8.11
    ip name-server 212.71.0.2
    ip ddns update method my_dyndns
    HTTP
    add http://xxx[email protected]<s>/nic/update?system=dyndns&hostname=<h>&myip=<a>
    interval maximum 28 0 0 0
    !
    username admin password 7 xxxxx
    !
    crypto isakmp policy 1
    authentication pre-share
    crypto isakmp key xxxxx address 0.0.0.0 0.0.0.0
    !
    crypto ipsec transform-set cm-transformset-1 esp-3des esp-sha-hmac
    !
    crypto map cm-cryptomap local-address Dialer0
    crypto map cm-cryptomap 1 ipsec-isakmp
    ! Incomplete
    set transform-set cm-transformset-1
    match address 100
    !
    interface ATM0/0
    no ip address
    load-interval 30
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 8/35
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet0/0
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    no ip virtual-reassembly
    speed auto
    !
    interface Dialer0
    ip ddns update hostname xxxxx.dyndns.org
    ip ddns update my_dyndns host members.dyndns.org
    ip address negotiated
    ip nat outside
    no ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname [email protected]
    ppp chap password 7 xxxx
    crypto map cm-cryptomap
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    no ip http server
    no ip http secure-server
    ip nat inside source list 1 interface Dialer0 overload
    ip nat inside source static tcp 192.168.1.221 23 interface Dialer0 23
    ip nat inside source static tcp 192.168.1.221 80 interface Dialer0 80
    ip nat inside source static tcp 192.168.1.221 11888 interface Dialer0 11888
    ip nat inside source static tcp 192.168.1.221 21 interface Dialer0 21
    ip nat inside source static tcp 192.168.1.221 25 interface Dialer0 25
    ip nat inside source static tcp 192.168.1.221 110 interface Dialer0 110
    ip nat inside source static tcp 192.168.1.221 20 interface Dialer0 20
    ip nat inside source static tcp 192.168.1.221 22 interface Dialer0 22
    ip nat inside source static udp 192.168.1.221 5060 interface Dialer0 5060
    ip nat inside source static udp 192.168.1.221 10000 interface Dialer0 10000
    ip nat inside source static udp 192.168.1.221 10001 interface Dialer0 10001
    ip nat inside source static udp 192.168.1.221 10002 interface Dialer0 10002
    !
    logging 192.168.1.221
    access-list 1 permit any
    access-list 100 permit ip any any
    dialer-list 1 protocol ip permit
    !
    control-plane
    !
    line con 0
    line aux 0
    line vty 0 4
    password 7 xxxxx
    login
    !
    end
Working...
X