Announcement

Collapse
No announcement yet.

PPTP/MPPE VPN Access on CIsco Router

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PPTP/MPPE VPN Access on CIsco Router

    I have in my LAN a windows 2003 server with MS VPN server with PPTP/MPPE. Since this server is not always switched on, I would like to put this VPDN functionality to my Cisco router, so LAN access is always possible. I have a Cisco 1760 router with IOS 12.4 advipservices - the show run is below. For some reason I can access/dialin with a windows DUN client from the LAN, but I can not access from the Internet. Is there a setting not correct - or am I missing something. The configuration is an ADSL with dynamic external IP address and the internal router interface is 192.168.1.254 and the windows server has IP address 192.168.1.222.

    Thx
    MKJ


    Building configuration...
    Current configuration : 2712 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log uptime
    no service password-encryption
    service sequence-numbers
    !
    hostname c1760
    !
    boot-start-marker
    boot-end-marker
    !
    enable password XXXX
    !
    no aaa new-model
    !
    resource policy
    !
    ip cef
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.254
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool dsl1
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.254
    dns-server 212.71.8.10 212.71.0.33
    !
    ip domain name dyndns.org
    ip host members.dyndns.org 63.208.196.96
    ip name-server 212.71.8.11
    ip name-server 212.71.0.2
    ip ddns update method mydyndns
    HTTP
    add http://XXX:[email protected];h>&myip=<a>;
    interval maximum 28 0 0 0
    !
    vpdn enable
    !
    vpdn-group myvpn
    ! Default PPTP VPDN group
    accept-dialin
    protocol pptp
    virtual-template 1
    !
    username XXXX password 0 XXXX
    !
    interface ATM0/0
    no ip address
    load-interval 30
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 8/35
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet0/0
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    speed auto
    !
    interface Virtual-Template1
    ip unnumbered FastEthernet0/0
    peer default ip address pool myvpnpool
    no keepalive
    ppp encrypt mppe auto
    ppp authentication ms-chap ms-chap-v2
    !
    interface Dialer0
    ip ddns update hostname evwaes.dyndns.org
    ip ddns update mydyndns host members.dyndns.org
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname [email protected]
    ppp chap password 0 XXXX
    !
    ip local pool myvpnpool 192.168.1.50 192.168.1.60
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    no ip http server
    no ip http secure-server
    ip nat inside source list 1 interface Dialer0 overload
    ip nat inside source static tcp 192.168.1.222 80 interface Dialer0 80
    ip nat inside source static tcp 192.168.1.222 25 interface Dialer0 25
    ip nat inside source static tcp 192.168.1.222 110 interface Dialer0 110
    ip nat inside source static tcp 192.168.1.222 21 interface Dialer0 21
    ip nat inside source static tcp 192.168.1.222 5060 interface Dialer0 5060
    ip nat inside source static tcp 192.168.1.222 22 interface Dialer0 22
    ip nat inside source static tcp 192.168.1.222 23 interface Dialer0 23
    ip nat inside source static tcp 192.168.1.222 20 interface Dialer0 20
    !
    logging 192.168.1.222
    access-list 1 permit any
    dialer-list 1 protocol ip permit
    !
    control-plane
    !
    line con 0
    line aux 0
    line vty 0 4
    password xxxx
    login
    !
    end
Working...
X