Announcement

Collapse
No announcement yet.

Problem adding Cisco Router 2621 to Home Network

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem adding Cisco Router 2621 to Home Network

    Novice adding cisco router to home network,

    I have home network setup running where host connected to switch can access the Internet. I added a cisco

    router to the network, but I can not get the router configured properly so my host can access the Internet.

    I want to be able to create VLANs, and be able to communicate between them and have access to the Internet on All the VLANS that I create.

    Need assistance to configure the cisco router, so my host could access the Internet. I'm trying to setup encapsulation dot1Q on
    the router, but I'm receiving invalid input. Do I have the correct IOS version to configure encapsulation on the router. See below:

    Router(config)#int fa0/1
    Router(config-if)# encapsulation dot1Q 1 native
    % Invalid input detected at '^' marker.

    See information below:


    cable modem ----> Linksys router (befsr41)-------> cisco router 2621 ----> switch (2912-xl)




    Switch#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) C2900XL Software (C2900XL-C3H2S-M), Version 12.0(5)XU, RELEASE SOFTWARE
    (fc1)
    Copyright (c) 1986-2000 by cisco Systems, Inc.
    Compiled Mon 03-Apr-00 16:37 by swati
    Image text-base: 0x00003000, data-base: 0x00301398

    ROM: Bootstrap program is C2900XL boot loader

    Switch uptime is 44 minutes
    System returned to ROM by power-on
    System image file is "flash:c2900XL-c3h2s-mz-120.5-XU.bin"


    cisco WS-C2912-XL (PowerPC403GA) processor (revision 0x11) with 8192K/1024K byte
    s of memory.
    Processor board ID 0x0D, with hardware revision 0x01
    Last reset from power-on

    Processor is running Enterprise Edition Software
    Cluster command switch capable
    Cluster member switch capable
    12 FastEthernet/IEEE 802.3 interface(s)
    --More--
    32K bytes of flash-simulated non-volatile configuration memory.
    Base ethernet MAC Address: 00:02:4B:BA:8B:80
    Motherboard assembly number: 73-3397-08
    Power supply part number: 34-0834-01
    Motherboard serial number: FAB0420353E
    Power supply serial number: PHI041408UL
    Model revision number: A0
    Motherboard revision number: B0
    Model number: WS-C2912-XL-EN
    System serial number: FAB0426S082
    Configuration register is 0xF


    Switch#sh vlan
    VLAN Name Status Ports
    ---- -------------------------------- --------- -------------------------------
    1 default active Fa0/3, Fa0/4, Fa0/5, Fa0/6,
    Fa0/7, Fa0/8, Fa0/9, Fa0/11,
    Fa0/12
    2 VLAN0002 active Fa0/10
    1002 fddi-default active
    1003 token-ring-default active
    1004 fddinet-default active
    1005 trnet-default active

    VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1 enet 100001 1500 - - - - - 1002 1003
    2 enet 100002 1500 - - - - - 0 0
    1002 fddi 101002 1500 - 0 - - - 1 1003
    1003 tr 101003 1500 1005 0 - - srb 1 1002
    1004 fdnet 101004 1500 - - 1 ibm - 0 0
    1005 trnet 101005 1500 - - 1 ibm - 0 0


    Switch#sh running-config
    Building configuration...

    Current configuration:
    !
    version 12.0
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Switch
    !
    enable secret 5 $1$ey79$qdt7DOEmrEIgfFxrxkhDC/
    !
    !
    !
    !
    !
    !
    ip subnet-zero
    !
    !
    !
    interface FastEthernet0/1
    description Trunk to second switch
    switchport mode trunk
    !
    interface FastEthernet0/2
    description connect to cisco router
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    description host pc connect to port
    switchport access vlan 2
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface VLAN1
    ip address 192.168.1.106 255.255.255.0
    no ip directed-broadcast
    no ip route-cache
    !
    interface VLAN2
    no ip directed-broadcast
    no ip route-cache
    shutdown
    !
    ip default-gateway 192.168.1.222
    !
    line con 0
    transport input none
    stopbits 1
    line vty 0 4
    password xxxxxxxxxxxxxxx
    login
    line vty 5 15
    password xxxxxxxxxxxxxxx
    login
    !
    end





    Router#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) C2600 Software (C2600-I-M), Version 12.0(5)T1, RELEASE SOFTWARE (fc1)
    Copyright (c) 1986-1999 by cisco Systems, Inc.
    Compiled Tue 17-Aug-99 13:57 by cmong
    Image text-base: 0x80008088, data-base: 0x8072C5D4

    ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

    Router uptime is 49 minutes
    System returned to ROM by power-on
    System image file is "flash:c2600-i-mz.120-5.T1"

    cisco 2621 (MPC860) processor (revision 0x102) with 32768K/8192K bytes of memory
    .
    Processor board ID JAD04310DBO (674299055)
    M860 processor: part number 0, mask 49
    Bridging software.
    X.25 software, Version 3.0.0.
    2 FastEthernet/IEEE 802.3 interface(s)
    32K bytes of non-volatile configuration memory.
    16384K bytes of processor board System flash (Read/Write)

    Configuration register is 0x2102



    Router#sh running-config
    Building configuration...

    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    enable secret 5 $1$1jj8$pn.ulhKNjbxBhNV2zD6x01
    !
    !
    !
    !
    !
    ip subnet-zero
    !
    !
    !
    process-max-time 200
    !
    interface FastEthernet0/0
    no ip address
    no ip directed-broadcast
    ip nat outside
    !
    interface FastEthernet0/1
    ip address 192.168.1.223 255.255.255.0
    no ip directed-broadcast
    ip nat inside
    no ip route-cache
    no ip mroute-cache
    !
    ip default-gateway 192.168.1.222
    ip classless
    ip route 0.0.0.0 0.0.0.0 1.1.1.2
    no ip http server
    !
    !
    line con 0
    password xxxxxx
    login
    transport input none
    line aux 0
    password xxxxxx
    login
    line vty 0 4
    password xxxxxx
    login
    !
    no scheduler allocate
    end

    Router#
    Last edited by tsignal32; 12th December 2007, 14:44.
Working...
X