Announcement

Collapse
No announcement yet.

Join 2 Networks

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Join 2 Networks

    The current topology is
    Network 1 I have 60 machines they get get IPs from a DHCP 192.168.0.x
    they all connect to 2 48 port cisco switch 2950XL and 1 1720 cisco
    router has two interfaces 1 to the internet the other to local LAN
    Network 2 has 4 servers with IPs 10.0.0.x a switch and cisco PIX
    firewall, the pix has 2 network interfaces 1 is GW for the servers and
    192.168.10.x for the external network.
    Incase i want to access servers on network 2 I have to change the ips
    192.168.0.x to 192.168.10.x with a GW of PIX outside interface.
    I want to join both networks. I do not want to keep on changing the
    addresses. Below is a show ver for 1720

    Cisco IOS Software, C1700 Software (C1700-Y-M), Version 12.3(14)T1,
    RELEASE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2005 by Cisco Systems, Inc.
    Compiled Thu 31-Mar-05 13:40 by yiyan
    ROM: System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)
    gw-router uptime is 4 days, 20 hours, 5 minutes
    System returned to ROM by power-on
    System image file is "flash:c1700-y-mz.123-14.T1.bin"
    Cisco 1721 (MPC860P) processor (revision 0x500) with 56468K/9068K
    bytes of memory.
    Processor board ID FOC09181RTT (4115645989), with hardware revision
    0000
    MPC860P processor: part number 5, mask 2
    1 Ethernet interface
    1 FastEthernet interface
    32K bytes of NVRAM.
    32768K bytes of processor board System flash (Read/Write)
    Configuration register is 0x2102

    Thanks

  • #2
    Re: Join 2 Networks

    are these networks PHYSICALY connected?

    if so.. a route statement in each router pointing to the other should suffice.

    Dave

    edit:
    After re-reading your post, I have more questions: are these 2 networks running on seperate VLANs? can you change the external ip of the PIX and put it on your 192.168.0.X net?
    there is a simple solution, we just need more information on your setup. Personally, I would use the 1720 to bridge the servers (if I couldn't just re-ip them) and I'd be using the PIX to firewall my internet connection.
    Last edited by [email protected]; 19th October 2007, 18:02. Reason: more info

    Comment


    • #3
      Re: Join 2 Networks

      squid4040, please clear up your run-on sentence of a post.
      ** Remember to give credit where credit is due and leave reputation points where appropriate **

      Comment


      • #4
        Re: Join 2 Networks

        Thanks Dave,
        Routing which is in place on the router
        192.168.0.0 255.255.255.0 192.168.0.1 (Network 1)
        192.168.10.0 255.255.255.0 192.168.10.1 (network 2)
        The network is physically connected
        Network 1 192.168.0.x connects -> port1 on cisco switch 2950xl
        Network 2 192.168.10.1 connects -> PIX external interface-> port2 cisco 2950xl, internal interface of pix connects -> 10.10.10.x where 2 servers are.
        Unfortunately we can not change the ip addressing scheme
        No vlans have been configured so far.
        thank you

        Comment


        • #5
          Re: Join 2 Networks

          Do you have some workstations on 192.168.0.X and some that are 192.168.10.X?

          doesn't matter... problem is this: your network does not know how to get to the 10.0.0.X network. SO. a route statement in the 1720 should suffice.
          ip route 10.0.0.0 255.255.255.0 192.168.10.1

          Dave

          Comment


          • #6
            Re: Join 2 Networks

            The route is added but still no success

            Thanks

            Comment


            • #7
              Re: Join 2 Networks

              from a pc on the 192.168.1.X network, do a tracert to one of the servers on the 10.0.0.X network and lets see where its breaking down.

              also, can you ping from a pc on the 192.168.1.X to a pc on the 192.168.10.X network?

              next, do a "sh ip route" on the PIX and post it too. it could also be an ACL on the pix not allowing anything but 192.168.10.X, there are still several things we can look at.

              another option is put that route statement I gave you earlier in the switch instead of the 1720 and try that.

              Comment


              • #8
                Re: Join 2 Networks

                Hellos
                Thanks guys I managed to sort out the problem, this is what i did using cisco 1700 I natted network1 to an interface IP on network 2.
                The router has 2 network interfaces I gave interface 1 (192.168.0.x) an ip from network 1 and interface 2 network 2 (192.168.10.x) which is able to communicate with PIX then nat network 1 to ip interface 2.


                interface Ethernet0
                description To PIX
                ip address 192.168.10.254 255.255.255.0
                ip nat outside
                ip virtual-reassembly
                full-duplex
                !
                interface FastEthernet0
                description To LAN
                ip address 192.168.0.254 255.255.255.0
                ip nat inside
                ip virtual-reassembly
                speed auto

                ip nat inside source list 50 interface Ethernet0 overload
                !
                access-list 50 permit 192.168.0.0 0.0.0.255

                Thanks
                Alex

                Comment


                • #9
                  Re: Join 2 Networks

                  looks like you found the simplest solution. simple is all most allways the best.

                  Dave

                  Comment

                  Working...
                  X