Announcement

Collapse
No announcement yet.

VLAN routing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • VLAN routing

    I'm no Cisco expert, hence my post on this forum. I have a BT HomeHub (router/firewall/ADSL) connected to the Internet and a Cisco 3560 switch on my network. I have setup 2 VLANs. VLAN1 192.168.1.0 contains the HomeHub and VLAN2 169.254.13.0. From each VLAN I can browse the other VLAN. From VLAN1 I can browse the Internet but I cannot browse the Internet from VLAN2.

    Can anyone help me set this up correctly so that I can browse the Internet from both VLANs

  • #2
    Re: VLAN routing

    weird subnet for Vlan 2.

    Ok can you post you're config?
    Marcel
    Technical Consultant
    Netherlands
    http://www.phetios.com
    http://blog.nessus.nl

    MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
    "No matter how secure, there is always the human factor."

    "Enjoy life today, tomorrow may never come."
    "If you're going through hell, keep going. ~Winston Churchill"

    Comment


    • #3
      Re: VLAN routing

      config attached
      Last edited by Dumber; 27th September 2007, 16:16. Reason: attachement removed because of password.

      Comment


      • #4
        Re: VLAN routing

        please repost without the password.
        Marcel
        Technical Consultant
        Netherlands
        http://www.phetios.com
        http://blog.nessus.nl

        MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
        "No matter how secure, there is always the human factor."

        "Enjoy life today, tomorrow may never come."
        "If you're going through hell, keep going. ~Winston Churchill"

        Comment


        • #5
          Re: VLAN routing

          ah yes, I see the following in you're config:

          Code:
          interface Vlan1
           ip address 192.168.1.1 255.255.255.0
          !
          interface Vlan2
           ip address 169.254.13.1 255.255.255.0
          !
          ip default-gateway 192.168.1.254
          ip classless
          ip route 0.0.0.0 0.0.0.0 192.168.1.254
          Can you ping the 192.168.1.254 (i guess not)
          Marcel
          Technical Consultant
          Netherlands
          http://www.phetios.com
          http://blog.nessus.nl

          MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
          "No matter how secure, there is always the human factor."

          "Enjoy life today, tomorrow may never come."
          "If you're going through hell, keep going. ~Winston Churchill"

          Comment


          • #6
            Re: VLAN routing

            No I can't ping it
            Attached Files
            Last edited by rjp55uk; 27th September 2007, 16:53.

            Comment


            • #7
              Re: VLAN routing

              In order to have a working VLAN infrastructure you need a router with subinterfaces configured for each VLAN. More exactly, the routing between VLANS is handled by router.

              So, your router configuration should contains something like

              interface fa0/1.1
              description Vlan1
              encapsulation dot1Q 1
              ip address 192.168.1.x 255.255.255.0

              !
              interface fa0/1.2
              description Vlan2
              encapsulation dot1Q 2
              ip address 169.254.13.x 255.255.255.0
              .....
              This is the config. of a Cisco router.
              Desktops from eatch vlans will use the proper IP of the router's sub interfaces for default gatway.

              I am not sure that your BT HomeHub supports subinerfaces and in this cause you will not be able to build a correct VLAN infrastructure.
              Last edited by netxt; 27th September 2007, 18:06.
              Regards,
              Csaba Papp
              MCSA+messaging, MCSE, CCNA
              ...............................
              Remember to give credit where credit is due and leave reputation points where appropriate
              .................................

              Comment


              • #8
                Re: VLAN routing

                Netxt is right.
                Marcel
                Technical Consultant
                Netherlands
                http://www.phetios.com
                http://blog.nessus.nl

                MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
                "No matter how secure, there is always the human factor."

                "Enjoy life today, tomorrow may never come."
                "If you're going through hell, keep going. ~Winston Churchill"

                Comment


                • #9
                  Re: VLAN routing

                  Thanks for your help, I had a feeling that the problem would be the BT HomeHub.

                  What would you recomend to replace the HomeHub to connect to my ADSL connection

                  Comment


                  • #10
                    Re: VLAN routing

                    Hi guys

                    My first post out here at Petri's .....

                    I am not too well-vered with the Cisco 3650 (which I belv is a Layer 3 switch) but it does seem to me that configuring a static route on the Cisco to the BT Home hub's LAN IP address should solve the problem. I might be wrong here, in which case please do let me know how.

                    Also, the rest of the solution is right up there including stating the respective Subinterface IPs as the default gateways for the PCs in the VLANs.

                    P.S: If you are going to have both VLANs browsing each other and accessing the net as well, why would you have VLANs in the first place? Kindly clarify my understanding.

                    Comment

                    Working...
                    X