Announcement

Collapse
No announcement yet.

unable to get IP from DHCP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • unable to get IP from DHCP

    Desktops unable to get the ip from DHCP located on other subnet/vlan.

    Desktp/Serve Config:

    DHCP server 2003 (located on VLAN46 192.168.201.0/24) with scopes for each subnet (other subnets don't have issuses).
    Desktop XP pro SP2/2000 SP4 (located on VLAN 32- 192.168.187.0/24)

    Network config:

    Routing is provided by dual Catalyst 3750 - stacked.
    problem subnet/vlan is using Catalyst 2924

    VTP info is propageted to 2924 without any issue. VTP counters are clean and no packet loss. Trunk running over etherchannel using two fiber ports from VTP server switch to 2924. DHCP relay is configured for vlan 32 and there is no access lists configured at this time. Also Trunk permits trafic from all vlans

    If I assign static IP to the workstation everything works but it times-out if ip should be received from DHCP server (VLAN46). With fluke I was able to get the IP address from DHCP but had to change time-out from 10 sec to 20 sec.


    Any suggestions?

    Thank you.
    Trbonja

  • #2
    Re: unable to get IP from DHCP

    did you setup an ip-helper address on the switch?
    Marcel
    Technical Consultant
    Netherlands
    http://www.phetios.com
    http://blog.nessus.nl

    MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
    "No matter how secure, there is always the human factor."

    "Enjoy life today, tomorrow may never come."
    "If you're going through hell, keep going. ~Winston Churchill"

    Comment


    • #3
      Re: unable to get IP from DHCP

      Yes. Proof that it works is that I do get an IP address from DHCP server but only if I increase DHCP client time-out value from 10 sec to 20 sec.

      Thanks for reply.

      Trbonja

      Comment


      • #4
        Re: unable to get IP from DHCP

        did you enable portfast on the switches?
        Marcel
        Technical Consultant
        Netherlands
        http://www.phetios.com
        http://blog.nessus.nl

        MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
        "No matter how secure, there is always the human factor."

        "Enjoy life today, tomorrow may never come."
        "If you're going through hell, keep going. ~Winston Churchill"

        Comment


        • #5
          Re: unable to get IP from DHCP

          portfast enabled on all access ports

          Trunk/etherchannel abviously don't have it enabled and trunk encapsulation is dot1q.

          Again, thanks for reply

          Trbonja

          Comment


          • #6
            Re: unable to get IP from DHCP

            ok that's correct.
            Did you added the following to the access ports.
            switchport mode access
            Maybe you can post the config of the switch.
            Marcel
            Technical Consultant
            Netherlands
            http://www.phetios.com
            http://blog.nessus.nl

            MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
            "No matter how secure, there is always the human factor."

            "Enjoy life today, tomorrow may never come."
            "If you're going through hell, keep going. ~Winston Churchill"

            Comment


            • #7
              Re: unable to get IP from DHCP

              switchport mode access is in the config as well. The problem unit is an old 2924 with ios 12.0.5.
              Another unit with same configuration but it's 3750 24 port unti works as intended.

              As for posting the full config I have to ask for permissions. The best I can do is to post ports config:

              START
              ============================

              nterface Port-channel1
              description xxxxx
              switchport trunk encapsulation dot1q
              switchport mode trunk

              nterface GigabitEthernet1/0/1
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/2
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/3
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/4
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/5
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/6
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/7
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/8
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/9
              description NT-Server1
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/10
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/11
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/12
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/13
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/14
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/15
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/16
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/17
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/18
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/19
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/20
              switchport access vlan 20
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/21
              switchport access vlan 10
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/22
              switchport access vlan 10
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/23
              switchport access vlan 10
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/24
              switchport access vlan 10
              switchport mode access
              spanning-tree portfast

              nterface GigabitEthernet1/0/25
              description xxxxxx
              switchport trunk encapsulation dot1q
              switchport mode trunk
              channel-group 1 mode on

              nterface GigabitEthernet1/0/26
              description xxxxxxx
              switchport trunk encapsulation dot1q
              switchport mode trunk
              channel-group 1 mode on


              ===============================
              END



              Thank you,

              Trbonja

              Comment


              • #8
                Re: unable to get IP from DHCP

                If another newer model of switch works fine, is there an IOS ugrade for te 2924 that might resolve this?

                Just a thought...
                David Davis - Petri Forums Moderator & Video Training Author
                Train Signal - The Global Leader in IT Video Training
                TrainSignalTraining.com - Free IT Training Products
                Personal Websites: HappyRouter.com & VMwareVideos.com

                Comment


                • #9
                  Re: unable to get IP from DHCP

                  Thanks for the reply. I did upgrade IOS but the problems is still there. As the 2924 has no support and has reached end of life, I've requested replacement: Cat 3560.

                  I would still like to know what's going on and why is this happenning. I'll try to sniff some trafic and post back

                  Regards,
                  Trbonja

                  Comment


                  • #10
                    Re: unable to get IP from DHCP

                    Also, I do have to apologize as the port config are from working 3750 not 2924. 2924 is pretty much the same as Iíve cut and paste config info for all switches/routers from few text file/config templates.

                    Comment


                    • #11
                      Re: unable to get IP from DHCP

                      I have a 3548 switch with the same version IOS and have not had any problems with DHCP. Have you looked at the problem from the perspective of the 3750 instead of the 2924? Have you checked the ip helper-address, ARP cache, static or dynamic routes, etc.? Have you run a trace route from the affected VLAN to the DHCP server VLAN and back again? Have you put a sniffer on both VLAN's? I know these seem like simple ideas, but maybe it will help.

                      Comment

                      Working...
                      X