Announcement

Collapse
No announcement yet.

Dedicated DS3 configuration

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dedicated DS3 configuration

    I just had a circuit set up through a 3rd party so that I have a dedicated DS3 between two of my offices. On one end I have a 3845 and on the other I have a 2651XM, both with ATM DS3 cards in them.

    They said it is on a sonnet ring and that the circuit is up and I can use any IP address I want on each end.

    I have googled and found this:

    Configure Basic ATM

    R5 and R6 are connected via the PVC 0/99. Use a subinterface on R6 and ensure the latest method of PVC configuration is used on this router. R5 will use the physical interface and legacy PVC configuration. Do not rely on inverse ARP.

    R6(config)#interface atm 1/0.99 point-to-point
    R6(config-if)#ip address 12.0.0.6 255.255.255.0
    R6(config-if)#pvc 0 99
    R6(config-if-vc)#protocol ip 12.0.0.5 broadcast
    R6(config-if-vc)#encapsulation aal5snap

    R5(config)#interface atm 3/0
    R5(config-if)#ip address 12.0.0.5 255.255.255.0
    R5(config-if)#map-group atm
    R5(config-if)#atm pvc 1 0 99 aal5snap
    R5(config)#map-list atm
    R5(config-map)#ip 12.0.0.6 atm-vc 1 broadcast

    Is this all I have to do to make them talk?

    I tried just configuring them with an IP address and nothing else and I could not even ping the interface

    I am travelling to the other site in the morning to install the card and set up that end (R5)

    I have this end configure like this:

    interface ATM2/0
    description T3 to Westbury
    ip address 192.168.9.1 255.255.255.0
    no atm ilmi-keepalive
    pvc 5/200
    protocol ip 192.168.9.2 broadcast
    encapsulation aal5snap

    when I do a show int, it shows as down/down. Is this because the other end is not set up yet? even though I am plugged into the sonnet ring?

    THANK YOU very much for your help.
    Thank you,

    Marc

  • #2
    Re: Dedicated DS3 configuration

    Ok, this is how I am set up:

    Router A:

    interface ATM2/0
    description T3 to Westbury
    ip address 192.168.9.1 255.255.255.0
    no atm ilmi-keepalive
    pvc 5/200
    protocol ip 192.168.9.2 broadcast
    encapsulation aal5snap


    Router B:

    interface ATM1/0
    description T3 to Amherst
    ip address 192.168.9.2 255.255.255.0
    map-group atm
    atm clock INTERNAL
    atm pvc 1 5 200 aal5snap
    no atm ilmi-keepalive

    but both interfaces show down/down, even when I do a no shut. I read here:
    http://www.cisco.com/en/US/products/...080859338.html

    that you have to do a "card type t3 1" because it isn't automatic. Neither my 3845 or 2651 has the "card" command. One has IOS 12.3 and the other has 12.4

    Both cards are NM-1A-T3
    Thank you,

    Marc

    Comment


    • #3
      Re: Dedicated DS3 configuration

      Hi tnshurtm,

      I was going to share my DS3 config with you but then I saw that this is an ATM DS3 and mine is not so I don't think it will help. My config doesn't use the card command. It uses the controller command.

      So, I don't have the resolution to your issue but here are a few things that I thought of while reading your config and the Cisco doc:
      - You could setup a loopback test with your provider to first determine that the line, your cables, and your modules are all good (irregardless of your configuration). If one of these hardware pieces are no good then you are wasting your energy on the confguration. The loopback commands are in the Cisco doc you referenced.
      - The configuration is very clear when it says "The ATM T3/E3 network module will not be operational until a card type is configured." If you cannot locate the card type command then something isn't right. That may be a question for the TAC.
      - Is the provider providing clocking? I see that one side is set for clocking but I wonder what the provider has set for clocking inside their network.
      - I know the provider said you could configure each end however you want but, in the middle, the provider still has an ATM switch. Where did the PVC 5/200 come from? Is that configured on the provider's ATM switch?
      - While I have configured ATM a few times, I am by no means an ATM expert. However, but don't you need to configure a PVC that does ILMI signaling. I know that ATM uses OOB signalling, just like ISDN has the D channel. Something like:
      pvc [name] 0/16 ilmi
      (from the cisco doc you referenced)

      Again, not a resultion to your issue but just some thoughts I had on the configuration. Perhaps one of them helps you out.
      David Davis - Petri Forums Moderator & Video Training Author
      Train Signal - The Global Leader in IT Video Training
      TrainSignalTraining.com - Free IT Training Products
      Personal Websites: HappyRouter.com & VMwareVideos.com

      Comment


      • #4
        Re: Dedicated DS3 configuration

        Originally posted by daviddavis View Post
        Hi tnshurtm,

        I was going to share my DS3 config with you but then I saw that this is an ATM DS3 and mine is not so I don't think it will help. My config doesn't use the card command. It uses the controller command.

        So, I don't have the resolution to your issue but here are a few things that I thought of while reading your config and the Cisco doc:
        - You could setup a loopback test with your provider to first determine that the line, your cables, and your modules are all good (irregardless of your configuration). If one of these hardware pieces are no good then you are wasting your energy on the confguration. The loopback commands are in the Cisco doc you referenced.
        - The configuration is very clear when it says "The ATM T3/E3 network module will not be operational until a card type is configured." If you cannot locate the card type command then something isn't right. That may be a question for the TAC.
        - Is the provider providing clocking? I see that one side is set for clocking but I wonder what the provider has set for clocking inside their network.
        - I know the provider said you could configure each end however you want but, in the middle, the provider still has an ATM switch. Where did the PVC 5/200 come from? Is that configured on the provider's ATM switch?
        - While I have configured ATM a few times, I am by no means an ATM expert. However, but don't you need to configure a PVC that does ILMI signaling. I know that ATM uses OOB signalling, just like ISDN has the D channel. Something like:
        pvc [name] 0/16 ilmi
        (from the cisco doc you referenced)

        Again, not a resultion to your issue but just some thoughts I had on the configuration. Perhaps one of them helps you out.

        I made up the 5/200. I will call TAC and see what they say about the card. The clocking I was just playing with. This is the first ATM circuit I have set up so I am just winging it.
        Thank you,

        Marc

        Comment


        • #5
          Re: Dedicated DS3 configuration

          So, they wouldn't turn up due to my ISP having something messed up. Now both ends are up.

          The next hurdle...

          On Router 1, I can ping the ATM subinterface, on router 2, I can't ping it even from router 2 even though it shows as up.

          Here is the config and sh int of router 2:

          Building configuration...

          Current configuration : 6571 bytes
          !
          version 12.3
          service timestamps debug datetime msec localtime
          service timestamps log datetime msec localtime
          service password-encryption
          !
          hostname westbury2651
          !
          boot-start-marker
          boot-end-marker
          !
          enable secret 5
          !
          username
          username
          memory-size iomem 10
          clock timezone EST -5
          clock summer-time EST recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
          no network-clock-participate slot 1
          no network-clock-participate wic 0
          no aaa new-model
          ip subnet-zero
          !
          !
          ip dhcp excluded-address 192.168.10.1 192.168.10.30
          ip dhcp excluded-address 192.168.4.1 192.168.4.30
          !
          ip dhcp pool ITS
          network 192.168.10.0 255.255.255.0
          option 150 ip 192.168.5.10
          default-router 192.168.10.1
          dns-server 192.168.1.186
          option 156 ascii "ftpservers=192.168.5.5"
          !
          ip dhcp pool CLAN
          network 192.168.4.0 255.255.255.0
          default-router 192.168.4.1
          netbios-name-server 192.168.1.176
          dns-server 192.168.1.186 151.202.0.85
          option 156 ascii "ftpservers=192.168.5.5, country=1, language=1, layer2taggin
          g=1, vlanid=10"
          !
          !
          ip cef
          ip domain name mbaum.com
          ip host SJCIPTCM1 192.168.5.10
          ip name-server 151.202.0.85
          ip name-server 151.203.0.85
          ip audit po max-events 100
          no ftp-server write-enable
          ccm-manager fallback-mgcp
          ccm-manager mgcp
          ccm-manager music-on-hold
          ccm-manager config server 192.168.5.10
          ccm-manager config
          !
          class-map match-any SHORETEL_VOIP
          match ip dscp ef
          match access-group 101
          match access-group 102
          class-map match-all VOICE
          match ip dscp ef
          match ip precedence 5
          match ip dscp cs5
          match ip dscp af31
          !
          !
          policy-map WAN-EDGE-1536kbps
          class VOICE
          priority 768
          policy-map VOIP_POLICY
          class SHORETEL_VOIP
          priority percent 75
          class class-default
          set dscp default
          fair-queue
          random-detect
          !
          !
          no crypto isakmp enable
          !
          interface FastEthernet0/0
          description 802.1q trunk to 2560 on F0/24
          no ip address
          speed 100
          full-duplex
          !
          interface FastEthernet0/0.4
          description CLAN
          encapsulation dot1Q 4
          ip address 192.168.4.1 255.255.255.0
          ip nat inside
          !
          interface FastEthernet0/0.10
          description TLAN
          encapsulation dot1Q 10
          ip address 192.168.10.1 255.255.255.0
          h323-gateway voip bind srcaddr 192.168.10.1
          !
          interface Serial0/0
          description Connection to Amherst, NY
          bandwidth 1536
          ip address 10.10.10.2 255.255.255.252
          service-policy output VOIP_POLICY
          service-module t1 timeslots 1-24
          service-module t1 remote-alarm-enable
          !
          interface Service-Engine0/0
          ip unnumbered FastEthernet0/0.10
          shutdown
          service-module ip address 192.168.10.10 255.255.255.0
          service-module ip default-gateway 192.168.10.1
          !
          interface FastEthernet0/1
          description Connection to Verizon DSL
          ip address 68.236.186.161 255.255.255.0
          ip nat outside
          duplex auto
          speed auto
          !
          interface ATM1/0
          description T3 to Amherst
          no ip address
          no atm ilmi-keepalive
          !
          interface ATM1/0.1 point-to-point
          ip address 192.168.9.2 255.255.255.0
          pvc 5/201
          encapsulation aal5snap
          !
          !
          ip classless
          ip route 0.0.0.0 0.0.0.0 68.236.186.1
          ip route 192.168.1.0 255.255.255.0 10.10.10.1
          ip route 192.168.5.0 255.255.255.0 10.10.10.1
          ip route 192.168.10.10 255.255.255.255 Service-Engine0/0
          ip route 192.168.50.0 255.255.255.0 10.10.10.1
          !
          ip http server
          ip http authentication local
          no ip http secure-server
          ip http path flash:
          ip nat inside source list 1 interface FastEthernet0/1 overload
          ip nat inside source static tcp 192.168.4.3 3389 interface FastEthernet0/1 3389
          !
          !
          !
          map-list atm
          ip 192.168.9.1 atm-vc 1 broadcast
          access-list 1 permit any
          access-list 101 remark : ShoreTel Voice over IP Ports
          access-list 101 permit udp any any eq 2427
          access-list 101 permit udp any any eq 2727
          access-list 101 permit udp any any range 5440 5446
          access-list 102 remark : ShoreTel Server VoIP Packets
          access-list 102 permit udp host 192.168.5.5 gt 1024 any gt 1024
          !
          !
          tftp-server flash:P00303020214.bin
          tftp-server flash:P00305000301.sbn
          tftp-server flash:P00403020214.bin
          !
          control-plane
          !
          !
          !
          mgcp
          mgcp call-agent SJCIPTCM1 2427 service-type mgcp version 0.1
          mgcp dtmf-relay voip codec all mode nte-gw
          mgcp rtp unreachable timeout 1000 action notify
          mgcp package-capability rtp-package
          no mgcp package-capability res-package
          mgcp package-capability sst-package
          no mgcp package-capability fxr-package
          no mgcp timer receive-rtcp
          mgcp sdp simple
          mgcp fax t38 inhibit
          mgcp rtp payload-type g726r16 static
          mgcp bind control source-interface FastEthernet0/0.10
          mgcp bind media source-interface FastEthernet0/0.10
          !
          mgcp profile default
          !
          !
          !
          !
          dial-peer voice 999100 pots
          application mgcpapp
          !
          dial-peer voice 999101 pots
          application mgcpapp
          !
          dial-peer voice 999102 pots
          application mgcpapp
          !
          dial-peer voice 1 pots
          preference 1
          destination-pattern 8.T
          !
          dial-peer voice 2 pots
          preference 2
          destination-pattern 8.T
          !
          dial-peer voice 3 pots
          preference 3
          destination-pattern 8.T
          !
          !
          !
          call-manager-fallback
          secondary-dialtone 8
          max-conferences 4
          limit-dn 7940 2
          ip source-address 192.168.10.1 port 2000
          max-ephones 24
          max-dn 24 dual-line
          !
          banner motd ^CCCCCCC
          !
          line con 0
          login local
          line 25
          no activation-character
          no exec
          transport preferred none
          transport input all
          transport output all
          line aux 0
          line vty 0 4
          login local
          !
          ntp authenticate
          ntp clock-period 17208492
          ntp server 66.115.130.4
          !
          !
          end

          westbury2651#sh int atm1/0
          ATM1/0 is up, line protocol is up
          Hardware is RS8234 ATM DS3
          Description: T3 to Amherst
          MTU 4470 bytes, sub MTU 4470, BW 45000 Kbit, DLY 190 usec,
          reliability 255/255, txload 1/255, rxload 1/255
          Encapsulation ATM, loopback not set
          Encapsulation(s): AAL5
          1023 maximum active VCs, 1 current VCCs
          VC Auto Creation Disabled.
          VC idle disconnect time: 300 seconds
          Last input 00:02:03, output 00:05:58, output hang never
          Last clearing of "show interface" counters never
          Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
          Queueing strategy: Per VC Queueing
          5 minute input rate 0 bits/sec, 0 packets/sec
          5 minute output rate 0 bits/sec, 0 packets/sec
          1615 packets input, 53400 bytes, 0 no buffer
          Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
          0 input errors, 1 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
          851 packets output, 30432 bytes, 0 underruns
          0 output errors, 0 collisions, 13 interface resets
          0 output buffer failures, 0 output buffers swapped out
          westbury2651#sh int atm 1/0.1
          ATM1/0.1 is up, line protocol is up
          Hardware is RS8234 ATM DS3
          Internet address is 192.168.9.2/24
          MTU 4470 bytes, BW 45000 Kbit, DLY 190 usec,
          reliability 255/255, txload 1/255, rxload 1/255
          Encapsulation ATM
          1615 packets input, 53400 bytes
          851 packets output, 30432 bytes
          0 OAM cells input, 0 OAM cells output
          AAL5 CRC errors : 1
          AAL5 SAR Timeouts : 0
          AAL5 Oversized SDUs : 0
          AAL5 length violation : 0
          AAL5 CPI Error : 0
          Last clearing of "show interface" counters never
          westbury2651#
          Thank you,

          Marc

          Comment


          • #6
            Re: Dedicated DS3 configuration

            (I'll caution this with saying again that I am no ATM expert)

            So doesn't that maplist need to be applied to the interface with a map-group command like you originally had it?

            If that doesn't work, just give me the relevant ATM config on each side of the connection.

            Thanks!
            David Davis - Petri Forums Moderator & Video Training Author
            Train Signal - The Global Leader in IT Video Training
            TrainSignalTraining.com - Free IT Training Products
            Personal Websites: HappyRouter.com & VMwareVideos.com

            Comment


            • #7
              Re: Dedicated DS3 configuration

              I know, that is the way i read it on an internet site, but then I get this with my TAC case

              Hope you're doing fine. I'm glad to hear that problem was found. Now, are you getting any connectivity at all? can you ping one way at least?

              Now, I suggested to remove some lines from the config, have you done that yet? I don't think they are used, are they?


              ***** Westbury

              interface ATM1/0
              description T3 to Amherst
              no ip address
              map-group atm
              atm clock INTERNAL ----> You might need to change to default: 'no atm clock internal'
              atm pvc 1 5 200 aal5snap
              no atm ilmi-keepalive
              !
              interface ATM1/0.1 point-to-point
              ip address 192.168.9.2 255.255.255.0
              pvc 5/201
              encapsulation aal5snap


              ***** Amherst

              interface ATM2/0
              description T3 to Westbury
              no ip address
              no atm ilmi-keepalive
              pvc 5/200
              protocol ip 192.168.9.2 broadcast
              encapsulation aal5snap
              !
              !
              interface ATM2/0.1 point-to-point
              ip address 192.168.9.1 255.255.255.0
              pvc 5/201
              encapsulation aal5snap
              Please let me know your thoughts,


              Currently, I can ping both interfaces from workstations one their respective ends. I can not ping either int from either router. Is that normal?

              Another note is that I also have a T-1 Point to point going between the sites, so it is kind of hard to troubleshoot actual connectivity unless I start routing the traffic across the DS3. And if I do that, and it is not working, I don't have a way to get the remote site back up.

              If I change the ip route on my local end to use the DS3, will traffic still flow both ways, just using the different pipes?
              Thank you,

              Marc

              Comment


              • #8
                Re: Dedicated DS3 configuration

                Okay, I can see where you could remove those statements as you have the sub interfaces and that is where your IP addresses is at.

                I looked at this guide and it is pretty helpful:
                http://www.cisco.com/en/US/products/...0800a186b.html

                It says that this is a good working ATM config. You could compare it to yours:

                Router A
                interface atm 4/0
                ip address 131.108.168.1 255.255.255.0
                pvc 0/32
                protocol ip 131.108.168.2 broadcast

                Router B
                interface atm 2/0
                ip address 131.108.168.2 255.255.255.0
                pvc test-b-1 0/32
                protocol ip 131.108.168.1 broadcast

                You should be able to ping interface to interface from each side of the connection. I wouldn't even test bringing down the serial until you can ping from router to router across the ATM link. Now, you would not be able to ping from a workstation on one side to the ATM interface of the remote router until you enabled routing across the link.
                David Davis - Petri Forums Moderator & Video Training Author
                Train Signal - The Global Leader in IT Video Training
                TrainSignalTraining.com - Free IT Training Products
                Personal Websites: HappyRouter.com & VMwareVideos.com

                Comment


                • #9
                  Re: Dedicated DS3 configuration

                  Results of 4 hours of testing with a Cisco tech (If you are interested...)

                  As we discussed via telephone today, it would seem that you have a circuit issue between your two sites based on the following.

                  1. On the Amherst site we can see traffic in the OUT direction only whereas on the Westbury traffic is being see in both directions.
                  2. On the Amherst site, doing a "sh controller atm2/0" can see the following errors incrementing. This may indicate a physical line issue.

                  DS3: F/M-bit errors 1858527 <<<<incrementing
                  DS3: parity errors 16584531 <<<<incrementing
                  DS3: path parity errors 16317810 <<<<incrementing
                  DS3/E3: G.832 FEBE errors 222258 <<<<incrementing
                  uncorrectable HEC errors 14230125 <<<<incrementing

                  3. On the Amherst site, doing a "loopback line" should allow packets on the Westbury atm1/0 side to be looped back to itself. This is NOT happening. Again I can see ping packets going in/out but

                  4. On the Westbury site I enabled "debug atm packets" and did a "ping 192.168.9.1" and in the debug I can see OUTPUT ATM packets and NO incoming.

                  5. On the Amherst site, I did a "ping 192.168.9.2" and in the debug on the Westbury side I could see both IN and OUTPUT ATM packets. So the issue looks like it may be that the return packets to Amherst are being dropped by your service provider.

                  6. Hardware on both sides appears to be working fine based on local loopbacks when I configured "loopback diagnostic" and set the "atm clock internal" on the ATM interface. I then performed a ping to the local ATM interface and the results were 100% successful.

                  Based on the above, can you please review the next lot of troubleshooting steps listed in the Customer Action Plan below.


                  Problem Description
                  ====================
                  C3845/NM-1A-T3 / c3845-spservicesk9-mz.124-2.T1.bin
                  C2651/NM-1A-T3 / c2600-advipservicesk9-mz.123-7.T4.bin

                  Migrating from a T1 circuit to a new point to point DS3 ATM circuit.
                  Need assistance troubleshooting link down.

                  Customer Action Plan
                  ====================
                  You will need to organise a troubleshooting session with your service provider to complete End to End testing as follows.

                  1. Have your service provider perform a loopback towards the Westbury site at the closest possible point.
                  - On the Westbury site, ping the local atm interface "ping 192.168.9.2".
                  - It should be successful otherwise have your service provider investigate.
                  - Doing a "show int atm1/0" should show input packets equal to output packets (you may wish to "clear counters" first.

                  2. Have your service provider perform a loopback towards the Amherst site at the closest possible point.
                  - On the Amherst site, ping the local atm interface "ping 192.168.9.1".
                  - It should be successful otherwise have your service provider investigate.
                  - Doing a "show int atm2/0" should show input packets equal to output packets (you may wish to "clear counters" first.

                  3. If steps 1 and 2 are successful, have your service provider perform a loopback towards the Amherst site with the loopback as close to Westbury site.
                  - On the Amherst site, ping the local atm interface "ping 192.168.9.1".
                  - It should be successful otherwise have your service provider investigate.
                  - Doing a "show int atm2/0" should show input packets equal to output packets (you may wish to "clear counters" first.
                  Thank you,

                  Marc

                  Comment


                  • #10
                    Re: Dedicated DS3 configuration

                    So... I sent this to the ISP and after working through two useless techs, got to the one who knew what he was talking about.

                    After doing loop tests with him, (mind you, they had NO ALARMS OR ERRORS) which made them reluctant to even troubleshoot, I did ping tests with him on the phone and he saw that the circuit was going up and down. He then called one of the sub ISPs that they are using and found that they were having issues with some cards.

                    It seems that my configs are working, but I need a clean line to test them. I will post back with any other changes. and the final config for others to reference.
                    Thank you,

                    Marc

                    Comment


                    • #11
                      Re: Dedicated DS3 configuration

                      We are up.

                      After 5 hours on a bridge call with 4 service providers (that make up the end to end DS3), lots of loopback tests, and tons of pings, we are up. The issue was a distance problem between two of the SPs. They added some DS3 repeaters and we are working.

                      The issue that made this so hard to troubleshoot was that the distance wasn't long enough to effect the layer 1 tests which all came back good. But, it was too long for my layer 2 traffic. They spent almost a week telling me that the circuit was up and I should check my config.

                      Bottom line: Loop tests are your friend. If you are pretty sure that your config is correct, request a loop test from your provider. If it is good one way and not the other move toward the problem until you find it.


                      Here is the final config:

                      Amherst:

                      interface ATM2/0
                      description T3 to Westbury
                      no ip address
                      load-interval 30
                      atm clock INTERNAL
                      no atm ilmi-keepalive
                      !
                      interface ATM2/0.1 point-to-point
                      ip address 192.168.9.1 255.255.255.0
                      pvc 5/201
                      vbr-nrt 44209 44209
                      encapsulation aal5snap

                      Westbury:

                      interface ATM1/0
                      description T3 to Amherst
                      no ip address
                      load-interval 30
                      no atm ilmi-keepalive
                      !
                      interface ATM1/0.1 point-to-point
                      ip address 192.168.9.2 255.255.255.0
                      pvc 5/201
                      vbr-nrt 44209 44209
                      oam-pvc 0
                      encapsulation aal5snap
                      Thank you,

                      Marc

                      Comment


                      • #12
                        Re: Dedicated DS3 configuration

                        Hi Marc,

                        That is excellent news! Thanks for updating us!

                        And thanks for posting the working config!

                        A very interesting issue, indeed.....

                        All the Best to you,
                        David Davis - Petri Forums Moderator & Video Training Author
                        Train Signal - The Global Leader in IT Video Training
                        TrainSignalTraining.com - Free IT Training Products
                        Personal Websites: HappyRouter.com & VMwareVideos.com

                        Comment


                        • #13
                          Re: Dedicated DS3 configuration

                          Sounds about right given I get the feeling you aren't a customer who drives enough dollars to your ISP to make any difference in their balance sheet. If you were this would have gotten fixed faster and easier most likely.

                          That said if you don't sound like you're confident in what you're doing which given the trouble you had getting the configlets going I tend to suspect you will sound this way, you will probably get jerked around some because customer config issues are a waste of the ISP's labor dollars chasing a wild goose in their network. Get on the phone knowing exactly what you want, all your symptoms, etc and don't budge at all and you'll get taken seriously and someone will help.
                          Thanks,
                          Brian Desmond
                          Microsoft MVP - Directory Services
                          www.briandesmond.com

                          Comment

                          Working...
                          X