Announcement

Collapse
No announcement yet.

PIX 501 port forwaring fot smtp not working.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PIX 501 port forwaring fot smtp not working.

    I can't get port forwarding to work for smtp. I read I similar thread, and tried that solution with no luck.

    Thank you for your help.

    static (inside,outside) tcp interface smtp 10.1.1.4 smtp netmask 255.255.255.255 0 0 "
    access-list EMAIL_ACL permit tcp any interface outside eq smtp
    access-group EMAIL_ACL in interface outside
    clear xlate


    PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password
    passwd
    hostname
    domain-name
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list nonat permit ip 10.1.0.0 255.255.0.0 10.2.0.0 255.255.0.0
    access-list vpnclient permit ip 10.1.0.0 255.255.0.0 10.2.0.0 255.255.0.0
    access-list acl_out permit icmp any any
    access-list acl_out permit tcp any host xxx.xxx.xxx.xxx eq www
    access-list EMAIL_ACL permit tcp any interface outside eq smtp
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside xxx.xxx.xxx.xxx 255.255.255.192
    ip address inside 10.1.1.1 255.255.0.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool vpnpool 10.2.1.250-10.2.1.254
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp interface www 10.1.1.2 www netmask 255.255.255.255 0 0
    static (inside,outside) tcp interface smtp 10.1.1.4 smtp netmask 255.255.255.255 0 0
    access-group EMAIL_ACL in interface outside
    route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    sysopt ipsec pl-compatible
    crypto ipsec transform-set remote esp-aes esp-md5-hmac
    crypto dynamic-map dynmap 10 set transform-set remote
    crypto map remote 40 ipsec-isakmp dynamic dynmap
    crypto map remote interface outside
    isakmp enable outside
    isakmp nat-traversal 15
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 1000
    vpngroup vpnremotes address-pool vpnpool
    vpngroup vpnremotes split-tunnel vpnclient
    vpngroup vpnremotes idle-time 1800
    vpngroup vpnremotes password ********
    vpngroup group idle-time 1800
    telnet 10.1.0.0 255.255.0.0 inside
    telnet timeout 5
    ssh xxx.xxx.xxx.xxx 255.255.255.0 outside
    ssh timeout 5
    console timeout 0
    terminal width 80
    Cryptochecksum:5624471df769303631a37ca506cd3512
    : end
Working...
X