Announcement

Collapse
No announcement yet.

IP classless

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • IP classless

    hello,
    I learn for my ccna exam. I am the lucky guy having a lot of cisco spare routers and switches and I can do a lot of practice.
    My Cisco 2600 router's interfaces are configured in the following way:
    l
    !
    interface FastEthernet0/0
    ip address 10.18.0.91 255.255.254.0
    duplex auto
    speed auto
    end
    !
    interface FastEthernet0/1
    ip address 192.168.15.1 255.255.255.0
    duplex auto
    speed auto
    end
    !
    There is also the default route command
    ip route 0.0.0.0 0.0.0.0 10.18.0.1

    the ping is working fine from the 10.18.0.0 /23 network and from any other local sub net also (Exp. from 10.18.230.0 /23).
    BUT, the telnet or ssh are available only from the 10.18.0.0/23.
    I checked the access lists, no one exists.
    I spent a lot of time with this issue before i tried
    ip classless
    It solved the problem.
    WHY the ping worked but the telnet or ssh not?

    Thanks.
    PS. Also many thanks for all of you useful Cisco related articles on www.petri.com and other sites where you are posting.
    Regards,
    Csaba Papp
    MCSA+messaging, MCSE, CCNA
    ...............................
    Remember to give credit where credit is due and leave reputation points where appropriate
    .................................

  • #2
    Re: IP classless

    Hi

    Upto my knowledge any default route add should have ip classless enabled..

    It means the ipaddress in the packet is checked to all the route entries till the default route in the routing table..

    Other wise,, the router will drop the packet as it doesnt find any matcsh in its table.

    so when ever u add a default route,, make sure you have ipcalssless command enabled.

    Thanks and regards

    Prabu
    prabu

    Comment


    • #3
      Re: IP classless

      Fellow member Prabu makes a good point!

      Just to chime in on this topic, IP classless should always be enabled.

      It was set to enabled, by default, in IOS 11.3 and greater.

      Here is a link with more description from Cisco-
      http://www.cisco.com/en/US/products/...html#wp1018033

      Thanks for the great question!
      David Davis - Petri Forums Moderator & Video Training Author
      Train Signal - The Global Leader in IT Video Training
      TrainSignalTraining.com - Free IT Training Products
      Personal Websites: HappyRouter.com & VMwareVideos.com

      Comment

      Working...
      X