No announcement yet.

what is hsrp

  • Filter
  • Time
  • Show
Clear All
new posts

  • what is hsrp

    please tell me about hot standy routing protocol how its work
    switch , details and configuration steps


  • #2
    Re: what is hsrp

    Not when you posted in the hall of fame we wont!!

    reported to admins

    Michael Armstrong
    MCITP: EA, MCTS, MCSE 2003, MCSA 2003: Messaging, CCA, VCP 3.5, 4, 5, VCAP5-DCD, VCAP5-DCA, ITIL, MCP, PGP Certified Technician

    ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **


    • #3
      Re: what is hsrp

      You earned youreself a warning. Next time a 2 week ban.
      Thread moved

      PS, also use

      second hit.
      Technical Consultant

      MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
      "No matter how secure, there is always the human factor."

      "Enjoy life today, tomorrow may never come."
      "If you're going through hell, keep going. ~Winston Churchill"


      • #4
        Re: what is hsrp

        Hot Standby Router Protocol - it's Cisco's proprietary protocol for having redundant gateways on a given subnet. VRRP is the standardized equivelant.

        Basically, you have two routers, call then and, and then they share - one active and one or more passive nodes where the active one responds to You point your clients at

        The routers send heartbeats out frequently to make sure the active member is still up or else another router takes over.

        To configure it you'd have configlets something like this:

        interface fastethernet0/0
        ip address
        no shutdown
        standyby 1 ip

        interface fastethernet0/0
        ip address
        no shutdown
        standyby 1 ip
        Brian Desmond
        Microsoft MVP - Directory Services


        • #5
          Re: what is hsrp


          to have a correct HSRP config follow this below

          interface Ethernet0
          ip address

          !--- Assigns an IP address to the interface.

          no ip redirects
          standby 1 ip

          !--- Assigns a standby group and standby IP address

          standby 1 priority 105

          !--- Assign a priority (105 in this case) to the router interface (e0)
          !--- for a particular group number (1). The default is 100.

          standby 1 preempt

          !--- Allows the router to become the active router when the priority
          !--- is higher than all other HSRP-configured routers in the hot standby group.
          !--- If you do not use the standby preempt command in the configuration
          !--- for a router, that router does not become the active router, even if
          !--- the priority is higher than all other routers.

          standby 1 track Serial0

          !--- Indicates that HSRP tracks Serial0 interface.
          !--- The interface priority can also be configured, which indicates the
          !--- amount by which the router priority decreases when
          !--- the interface goes down. The default is 10.

          interface Serial0
          ip address