Announcement

Collapse
No announcement yet.

CISCO 2611 not able to internet access why

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • CISCO 2611 not able to internet access why



    That is my small network what I want to do that is make CMPUTER A to be able going to internet.
    I could ping from Comp A to Comp B.
    Comp B could ping Comp A.
    Comp B have access to internet
    Comp A whatever I try do not have access to internet

    Router CISCO 2611 (but have only 2 FastEthernet port nothing else) is cisco router where I want routing two different network LAN A with comp A and LAN B = rest devices.

    D-LINK is normal adsl router with switch inside – is connected to internet, to comp B and port 2 of router cisco.

    That config from my router J

    ROUTER CISCO
    show running-config
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname RouterA
    !
    !
    ip subnet-zero I don`t know that line is important
    !
    !
    interface FastEthernet0/0
    description LAN-1

    ip address 192.168.1.65 255.255.255.224
    no ip directed-broadcast
    !
    interface FastEthernet1/0
    description GOING-TO-D-LINK-ADSLROUTER
    ip address 172.16.0.2 255.255.255.0
    no ip directed-broadcast
    !
    !
    router rip
    network 172.16.0.0 wrong address network maybe here is problem ??
    network 192.168.1.64
    !
    ip classless
    !
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    !
    no scheduler allocate
    end




    And most important think how to write configuration file in router, because when I type
    write memory
    copy start run
    and switch off from power router lost config, how to make when it lost power and go back to live, is using my config file, must be same way to do this. Because every time when I lost power then I have to set up it again and again.


    Thanks for help
    Last edited by ryszon; 17th April 2007, 13:42.

  • #2
    Re: CISCO 2611 not able to internet access why

    I can't find the internet connection on you're drawing.
    Also, can you post the Sh ip route from the cisco device.
    My guess is that he's missing a default route.

    The "copy running-config startup-config" (copy run start) should work.
    However, can you post the sh ver there i guess that the config register isn't set correctly. (should be 0x2102 instead of for example 0x2142)
    Marcel
    Technical Consultant
    Netherlands
    http://www.phetios.com
    http://blog.nessus.nl

    MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
    "No matter how secure, there is always the human factor."

    "Enjoy life today, tomorrow may never come."
    "If you're going through hell, keep going. ~Winston Churchill"

    Comment


    • #3
      Re: CISCO 2611 not able to internet access why



      CISCO#show ver
      Cisco Internetwork Operating System Software
      IOS (tm) C2600 Software (C2600-I-M), Version 12.0(10), RELEASE SOFTWARE (fc1)
      Copyright (c) 1986-2000 by cisco Systems, Inc.
      Compiled Mon 20-Mar-00 23:30 by phanguye
      Image text-base: 0x80008088, data-base: 0x80600628

      ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

      CISCO uptime is 7 minutes
      System restarted by power-on
      System image file is "flash:c2600-i-mz.120-10"

      cisco 2611 (MPC860) processor (revision 0x203) with 26624K/6144K bytes of memory
      .
      Processor board ID JAD0536116P (1563811731)
      M860 processor: part number 0, mask 49
      Bridging software.
      X.25 software, Version 3.0.0.
      2 Ethernet/IEEE 802.3 interface(s)
      32K bytes of non-volatile configuration memory.
      8192K bytes of processor board System flash (Read/Write)

      Configuration register is 0x2142


      1. when i switch power off and again on then show run
      2. and show start
      3. My configure is stored in startup-configure not in running-configso if use "copy running-config startup-config" then I lost config file.
      4. But if I make "copy startup-config running-config" then is copping but still when lost power everything is going to point 1



      CISCO#sh ip route
      Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
      i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
      U - per-user static route, o - ODR

      Gateway of last resort is not set

      CISCO#

      Gateway is not set - it is default-gateway, but which ip in this case should I use, ip address of ethernet port in router, or ip address of adsl router?

      Comment


      • #4
        Re: CISCO 2611 not able to internet access why

        Configuration register is 0x2142
        This is why you config is not saved in the startup config.
        The 0x2142 is ment for password recovery so you van bypass the nvram (the startup config)
        Type the following:

        Code:
        Conf t
        config-register 0x2102
        reload
        If you enter the sh version command before the reload you'll see at the bottem:
        Configuration register is 0x2142 (will be 0x2102 at next reload)
        Maybe nice to check

        CISCO#sh ip route
        Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
        U - per-user static route, o - ODR

        Gateway of last resort is not set

        CISCO#
        Here you see that you don't have a default route.
        Do the following:
        Code:
        conf t
        Ip route 0.0.0.0 0.0.0.0 172.16.0.1
        the 172.16.0.1 should be the ipaddress of the Dlink interface which is connected to the 2611.


        Further i've a few other remarks on you're config.
        ip subnet-zero
        This is needed to allow the complete range of subnets. for example, if you subnet 172.16.0.0 /16 to a 24 subnet mask you may not use 172.16.0.0 /24 cause this is called subnet zero. The subnetted mask is eq as the default subnet. Just leave it as it is


        router rip
        network 172.16.0.0
        network 192.168.1.64
        Do you use RIP on you're network to distribute network addresses?
        Last edited by Dumber; 17th April 2007, 15:46. Reason: added some more info.
        Marcel
        Technical Consultant
        Netherlands
        http://www.phetios.com
        http://blog.nessus.nl

        MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
        "No matter how secure, there is always the human factor."

        "Enjoy life today, tomorrow may never come."
        "If you're going through hell, keep going. ~Winston Churchill"

        Comment


        • #5
          Re: CISCO 2611 not able to internet access why

          Hello

          I set it up using your clue (guide lines - sorry i`m not good in english)

          CISCO#show configuration
          Using 604 out of 29688 bytes
          !
          version 12.0
          service timestamps debug uptime
          service timestamps log uptime
          no service password-encryption
          !
          hostname CISCO
          !
          !
          ip subnet-zero
          !
          !
          !
          interface Ethernet0/0
          description going to D-Link
          ip address 172.16.0.2 255.255.255.0
          no ip directed-broadcast
          !
          interface Ethernet0/1
          description LAN
          ip address 192.168.1.65 255.255.255.224
          no ip directed-broadcast
          !
          router rip
          network 172.16.0.0
          network 192.168.1.0
          !
          ip default-gateway 172.16.0.1
          ip classless
          ip route 0.0.0.0 0.0.0.0 172.16.0.1
          !
          !
          line con 0
          transport input none
          line aux 0
          line vty 0 4
          login
          !
          no scheduler allocate
          end

          CISCO#
          Now everything working fine, I have acces to internet with out any problem.
          Hehe now I fill beteer, soon I have exam ccna2.

          Thank you for you time and help.

          Comment


          • #6
            Re: CISCO 2611 not able to internet access why

            well done
            I've just passed my CCNA exam (intro and ICND at once).
            see here
            http://forums.petri.com/showthread.php?t=15072
            Marcel
            Technical Consultant
            Netherlands
            http://www.phetios.com
            http://blog.nessus.nl

            MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
            "No matter how secure, there is always the human factor."

            "Enjoy life today, tomorrow may never come."
            "If you're going through hell, keep going. ~Winston Churchill"

            Comment


            • #7
              Re: CISCO 2611 not able to internet access why

              One question

              If I use
              Conf t
              configure-register 0x2102
              reload
              then I set up everything what I need and write config to memory

              how to set up in next step password, I want set up password after setting of port in router.

              should then I use

              conf t
              configure-register 0x2142
              reload
              and then
              Router#enable secret bleble_my_password
              or it is different to do this

              Comment


              • #8
                Re: CISCO 2611 not able to internet access why

                nope. the configure-register 0x2142 is used to make it possible to break the routers password.
                Just leave it at 0x0212. Only in emergency use 0x2142.
                ox2142 is ment to be to bypass the startup-config. So it wouldn't loaded when you boot up a router.

                Just use:
                Conf T
                enable secret bleble_my_password
                Copy run start
                Marcel
                Technical Consultant
                Netherlands
                http://www.phetios.com
                http://blog.nessus.nl

                MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
                "No matter how secure, there is always the human factor."

                "Enjoy life today, tomorrow may never come."
                "If you're going through hell, keep going. ~Winston Churchill"

                Comment


                • #9
                  Re: CISCO 2611 not able to internet access why

                  Now I understand what is differen between this two memory addresses thx, for guide.

                  Comment


                  • #10
                    Re: CISCO 2611 not able to internet access why

                    you're welcome
                    Marcel
                    Technical Consultant
                    Netherlands
                    http://www.phetios.com
                    http://blog.nessus.nl

                    MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
                    "No matter how secure, there is always the human factor."

                    "Enjoy life today, tomorrow may never come."
                    "If you're going through hell, keep going. ~Winston Churchill"

                    Comment

                    Working...
                    X