Announcement

Collapse
No announcement yet.

cisco 2154 router connecting to adsl

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • cisco 2154 router connecting to adsl

    gday,

    im very new to the cisco routing world and just after a bit of help. i have just bought a 2154 and a 1900 to practise on for my CCNA course. i wanted to connect the router ethernet0 to my adsl modem and the ethernet1 to the switch. from what i understand i need to auto assign the ip address on ethernet0 with dhcp. and then set up a ip route table from ethernet1 to ethernet0. this is my running-config so far.

    interface Ethernet0
    ip address dhcp
    ip nat outside
    shutdown
    !
    interface Ethernet1
    ip address 192.168.1.1 255.255.255.0

    ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 Ethernet0
    ip route 192.168.1.0 255.255.255.0 Ethernet1

    im sure i have made a silly mistake but i cant see it.

  • #2
    Re: cisco 2154 router connecting to adsl

    Hello,
    Did you notice that your Ethernet0 interface is still shutdown? It will never be able to pull an IP address via DHCP unless you enable the interface with

    config t
    interface ethernet0
    no shutdown
    David Davis - Petri Forums Moderator & Video Training Author
    Train Signal - The Global Leader in IT Video Training
    TrainSignalTraining.com - Free IT Training Products
    Personal Websites: HappyRouter.com & VMwareVideos.com

    Comment


    • #3
      Re: cisco 2154 router connecting to adsl

      that helped thanks i knew it was something silly. alright next problem the router can access the internet but the host can not.
      this is the ip route section in sh runn


      interface Ethernet1
      ip address 192.168.1.1 255.255.255.0

      ip http server
      ip classless
      ip route 0.0.0.0 0.0.0.0 Ethernet0
      ip route 0.0.0.0 0.0.0.0 10.1.1.1
      ip route 192.168.1.0 255.255.255.0 Ethernet1

      host> ipconfig /all

      ip address 192.168.1.2
      subnet mask 255.255.255.0
      default gateway 192.168.1.1
      dns 10.1.1.1
      Last edited by jono; 13th February 2007, 09:05.

      Comment


      • #4
        Re: cisco 2154 router connecting to adsl

        So the 10.x.x.x network - that is the inside network of your adsl modem, right? Assuming yes, I would remove the NAT statement on e0.

        Yes, using NAT is one option. The other option is just to do real routing. I recommend real routing and that is why I suggested you remove the NAT statement.

        Next, you will have to tell your ADSL router about the 192.168.1.0 network. This can be done with either a dynamic routing protocol between the ADSL modem and the Cisco router (like RIP) or a static route. I am pretty sure that your ADSL modem doesn't support RIP (but I could be wrong) and would suggest the static route.

        I would also remove DHCP from E0 and use a static IP.

        Attached is an example of my router with how to enter a static route.

        You want to add a route so that the ADSL modem knows about the internal 192.168.1.0 network.

        Hope that helps!
        Attached Files
        Last edited by daviddavis; 17th February 2007, 12:58.
        David Davis - Petri Forums Moderator & Video Training Author
        Train Signal - The Global Leader in IT Video Training
        TrainSignalTraining.com - Free IT Training Products
        Personal Websites: HappyRouter.com & VMwareVideos.com

        Comment


        • #5
          Re: cisco 2154 router connecting to adsl

          ok i think we are getting somewhere with the static routing. i can now ping my modem from host and when i try ping google.com the dns gives me the ip address and the packets send and never come back. the same happens with the router when i ping google.com

          my modem does support rip v1/v2 and i tried routing that way but to no avail. i tried setting the neighbour to 10.1.1.1 (modem) and still nothing.

          i have removed NAT and DHCP and set up static route on the modem to destination 192.168.1.0 subnet 255.255.255.0 gateway 10.1.1.2 which is E0 of router

          thanks alot for your help so far!

          Comment


          • #6
            Re: cisco 2154 router connecting to adsl

            HI,

            Can you post a fresh config?

            Also, it would help to draw a little diagram in mspaint and post it as well. Just something showing Internet, to modem, to router with current IP addresses.

            Thanks
            David
            David Davis - Petri Forums Moderator & Video Training Author
            Train Signal - The Global Leader in IT Video Training
            TrainSignalTraining.com - Free IT Training Products
            Personal Websites: HappyRouter.com & VMwareVideos.com

            Comment

            Working...
            X