Announcement

Collapse
No announcement yet.

How to get ADSL dsl thru Cisco 2501 serial ports.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to get ADSL dsl thru Cisco 2501 serial ports.

    Hi

    I have (2) Cisco 2501's and I need some help routing my ADSL dsl connection thru Router-A to Router-B. I have a 1900 switch too. My dsl router connects to Ethernet0 on the 2501-A and I am able to receive an internal ip address. I was able to find the configuration to make this happen.

    Ethernet0 172.16.1.10 YES DHCP up up

    Serial0 unassigned YES manual down down

    Serial1 unassigned YES NVRAM administratively down dow

    Here is the configuration I found, however it was for a 2514 instead.

    Current configuration : 1074 bytes
    !
    version 12.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool insideDHCP
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 207.69.188.186 207.69.188.185
    !
    !
    !
    !
    interface Null0
    no ip unreachables
    !
    interface Ethernet0
    description Facing the ISP
    ip address dhcp
    ip nat outside
    no ip route-cache
    no ip mroute-cache

    interface Ethernet1
    description Facing my LAN
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    no ip route-cache
    no ip mroute-cache

    interface Serial0
    no ip address
    no ip route-cache
    no fair-queue
    !
    interface Serial1
    no ip address
    no ip route-cache
    shutdown
    !
    ip nat inside source list 1 interface Ethernet0 overload
    ip http server
    ip classless
    !
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    !
    !
    line con 0
    line aux 0
    transport input all
    line vty 0 4
    login
    !
    end

    I tried to jeryrig this config to where the configurations ethernet1 would be my serial0, but no luck there. Does anyone have a dummy configuration or some advice on how to router an internet connection through serially? Thanks

  • #2
    Re: How to get ADSL dsl thru Cisco 2501 serial ports.

    Hi,

    if I understand you correctly, you want to:

    -have the dsl connection connected your ethernet interface on your 25xx router #1
    -be able to route the packets in from dsl to ethernet and back out via Serial on router #1
    -route these packets from Serial on Router #1 to Serial on Router #2

    Am I correct? If so, you need to:

    -connect the routers up back to back (serial port to serial port) via the correct serial cable
    -set the serial interface on the router which is on the DCE end of the cable (which should be marked on the cable) to be the 'clock'

    -set ip addresses on all interfaces

    -set static routes pointing from one router to the other.

    Its difficult to tell from your post whether you can do all of this- you seem to have some knowledge of all this stuff. If what I'm saying doesn't make sense then please let me know.

    regards

    theterranaut

    Comment


    • #3
      Re: How to get ADSL dsl thru Cisco 2501 serial ports.

      Yes.

      Please forgive my example,


      ethenet serial ethernet
      DSL ROUTER--------(e0)[2514A](s0)-----------(s0)[2514B](e0)--------[1924 switch]


      I hope this makes better sense

      Thanks

      Comment


      • #4
        Re: How to get ADSL dsl thru Cisco 2501 serial ports.

        I have the interfaces set and the DCE/DTE set correctly. I just need help routing the internet from one router to another serially. I have set the encapsulation for both serial interfaces to PPP and lowered the clockrate too. Don't know if that helps, yet still not able to connect.

        Being able to ping is one thing, but being able to route the internet is something completely different as im learning. Thanks for your help I really need it.

        Comment


        • #5
          Re: How to get ADSL dsl thru Cisco 2501 serial ports.

          Thats alright, I think you are just about there..just make sure that the clients connecting to your 1924 are using the ethernet interface of your 'local' router as their default gateway.

          OK. I'm going to call the router that has the 1924 connected your 'local' router and the one connected to the dsl box your 'remote router, okay?


          If you issue a 'sh ip route' command on each router, at present you will see
          the 'connected' routes. These are the routes that the router knows about because it has an interface addressed with the relevant ip addresses.



          Step 1: Set up a default route on the 'local' router
          (the one your 1924 connects to)
          [The object of this is to get this router to forward any traffic that it hasn't an explicit route for, out of its serial interface and onto the 'next hop': which will be the serial interface of the remote router. As this inside router is just hosting a 'stub' network- a network with one exit point- all thats needed is a command saying 'if I dont specifically know how to get to a network, just send it this way.']

          command needed:

          enable
          configure terminal
          ip route 0.0.0.0 0.0.0.0 (next hop IP address- the address of the serial int on the remote router)

          When you enter this command, test its effectiveness by pinging the ethernet interface of the remote router from a client on the inside. If you get a response, all should be well. If not, check your gateway and let me know.

          Step 2: Set up a route to the 'inside' routers ethernet lan on the 'remote' router.
          [At present, the remote router knows about its own ethernet network and the serial network. It needs an explicit route to tell it how to forward traffic destined for your 'inside' router's ethernet lan network]

          command needed:

          enable
          configure terminal
          ip route (inside lan network) (inside lan subnet mask) (next hop ip address)

          So, if your inside lan was 192.168.2.0 255.255.255.0, and your next hop from your 'remote' router was the 'inside' router's serial interface, on 10.10.10.1:

          ip route 192.168.2.0 255.255.255.0 10.10.10.1

          Step 3: Finally, your 'remote' router needs to know what to do about traffic it has no explicit route for, ie, 'internet' traffic.

          [At present, the remote router knows about its own ethernet network, the serial network, and your 'inside' network: the whole of your LAN environment. It needs a default route for your internet (unknown) traffic, which will go via the dsl box.]

          command needed:

          enable
          configure terminal
          ip route 0.0.0.0 0.0.0.0 (next hop ip address- dsl box inside interface)

          So, if your dsl box's 'inside' interface was on 10.10.20.1:

          ip route 0.0.0.0 0.0.0.0 10.10.20.1



          I think that should be all you need. Try it and see. If it works okay, do me a favour- come back and let us know, eh?

          regards

          theterranaut

          Comment


          • #6
            Re: How to get ADSL dsl thru Cisco 2501 serial ports.

            Thank you for a well written reply, I do appreciate it. Howeve, I am still unable to connect unfortunately. I have contated other to obtain opinions on how to get this to work and have been given different insructions on how to get this to work as well.

            One guy told me that PPPoE wont work with those serial interfaces - even when encapsulation is set to PPP. Another guy gave me a reply similar to yours with similar instructions, another person told me that encapsulation of the serial ports has no no bearing and doesn't matter with PPPoE and another guy told me that my serial cables were bad ?? Well I know the serial cables aren't bad and thats about as far as Ive gotten. LOL.

            I do appologize as I am a total newby to Cisco, getting things configured and I have a stupid question. If the packets comming from E0 on Router-A and going to S0 on the same router, is this still considered PPPoE at the time it reaches the S0 interface? Anyway, with your help and a guy who was helpfull as well, I am able to ping all the way from a remote host to E0's DHCP'd ip address on Router-A, and able to ping from Router-A all the way to the remote host attached to Router-B. Now since I am able to do this, shouldn't I be able to connect? I have my default gateway and dns set up properly on my XP box - this I am sure of 100 percent. Do you have any recommendations as to my next step? Thanks again for all of your help.

            Comment


            • #7
              Re: How to get ADSL dsl thru Cisco 2501 serial ports.

              No problem.

              PPP and PPPoE are related but different things, btw. I'm not sure why you need PPP- I would remove it and just set up the interfaces using IP addresses and clock rates to get them up and running. You would only really need PPP over Serial is you were trying to get some authentication up and running, or one of the other things PPP is useful for. The basic encapsulation on Serial on Cisco is called HDLC, is on by default, and should suit you fine.

              (Check the front page for David Davis' excellent guide to WAN protocols for more info)

              Please post your configs so I can take a look.

              regards

              theterranaut

              Comment


              • #8
                Re: How to get ADSL dsl thru Cisco 2501 serial ports.

                Hello

                With this configuration I am able to ping anything I want from the remote computer. I have removed the 1900 swithch from the equation and ran a crossover cable from E0 on the receiving router (Router-B) just to rid of any suspiciouns that it may be causing a problem..


                Router-A (This is the router attached to the dsl modem)

                Current configuration : 1096 bytes
                !
                version 12.3
                service timestamps debug uptime
                service timestamps log uptime
                no service password-encryption
                service udp-small-servers
                service tcp-small-servers
                !
                hostname RouterA
                !
                boot-start-marker
                boot-end-marker
                !
                !
                no aaa new-model
                ip subnet-zero
                ip dhcp excluded-address 192.168.1.1
                !
                ip dhcp pool insideDHCP
                network 192.168.1.0 255.255.255.0
                default-router 192.168.1.1
                dns-server 207.69.188.186
                !
                !
                !
                !
                interface Null0
                no ip unreachables
                !
                interface Ethernet0
                description Facing the ISP
                ip address dhcp
                ip nat outside
                no ip route-cache
                no ip mroute-cache
                !
                !
                !
                interface Serial0
                description Facing my LAN
                ip address 192.168.1.1 255.255.255.0
                no ip route-cache
                no ip mroute-cache
                clock rate 500000
                no fair-queue
                !
                interface Serial1
                no ip address
                no ip route-cache
                !
                ip nat inside source list 1 interface Ethernet0 overload
                ip http server
                ip classless
                ip route 0.0.0.0 0.0.0.0 Serial0
                ip route 0.0.0.0 0.0.0.0 10.0.0.1
                !
                !
                !
                !
                line con 0
                exec-timeout 0 0
                line aux 0
                transport input all
                line vty 0 4
                login





                Here is Router-B (This is the router that is being routed to from A)


                Current configuration : 763 bytes
                !
                version 12.3
                service timestamps debug uptime
                service timestamps log uptime
                no service password-encryption
                service udp-small-servers
                service tcp-small-servers
                !
                hostname RouterB
                !
                boot-start-marker
                boot-end-marker
                !
                !
                no aaa new-model
                ip subnet-zero
                !
                !
                !
                !
                !
                !
                interface Ethernet0
                ip address 10.0.0.1 255.255.255.0
                no ip route-cache
                !
                interface Serial0
                ip address 192.168.1.2 255.255.255.0
                no ip route-cache
                no ip mroute-cache
                no fair-queue
                !
                interface Serial1
                no ip address
                no ip route-cache
                shutdown
                !
                ip http server
                ip classless
                ip route 0.0.0.0 0.0.0.0 192.168.1.1
                ip route 0.0.0.0 0.0.0.0 Serial0
                !
                !
                !
                !
                line con 0
                line aux 0
                transport input all
                line vty 0 4
                login
                !
                end



                Now the Lan Ip address on my DSL router is 172.16.0.254 and it give out ip addresses like 172.16.1.10, 172.16.1.11,172.16.1.12 etc..

                When I tried to put a static route to this ip address 172.16.0.254, I was not able to ping to it, so I took it out. Thanks.

                Comment


                • #9
                  Re: How to get ADSL dsl thru Cisco 2501 serial ports.

                  Thanks.

                  I may be misunderstanding your post, but do you mean that all is working now?

                  regards

                  theterranaut

                  Comment


                  • #10
                    Re: How to get ADSL dsl thru Cisco 2501 serial ports.

                    Hello

                    It wasn't working at the time I wrote that last posting. However, now its working. I received some help from a guy in Seattle Washington who pointed me in the right direction. He told me to have only one static route per router

                    Router A ip route 10.0.0.0 255.0.0.0 Serial0

                    RouterB ip route 0.0.0.0 0.0.0.0 Serial0


                    Router A's access-lists

                    access-list 1 remark RFC1918 non-routable address space
                    access-list 1 permit 192.168.0.0 0.0.255.255
                    access-list 1 permit 172.16.0.0 0.15.255.255
                    access-list 1 permit 10.0.0.0 0.255.255.255


                    None on Router B


                    This was the fix....



                    Now what I meant by:

                    Now the Lan Ip address on my DSL router is 172.16.0.254 and it give out ip addresses like 172.16.1.10, 172.16.1.11,172.16.1.12 etc..

                    When I tried to put a static route to this ip address 172.16.0.254, I was not able to ping to it, so I took it out. Thanks.


                    I meant that I couldn't route to that IP address in the first place. It was useless to have that route included. So I took it out...


                    If you would like to see the sh run for both routers, just let me know..I will gladly send them. I wont this time because they are space consuming. Thanks again for your help. Have a great day..

                    Comment


                    • #11
                      Re: How to get ADSL dsl thru Cisco 2501 serial ports.

                      No problem, good that you got there in the end!

                      regards

                      theterranaut

                      Comment

                      Working...
                      X