Announcement

Collapse
No announcement yet.

Class A IP address with a Class C Mask

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Class A IP address with a Class C Mask

    I have a 2514 router with 2 CAT-5 transceivers for the AUI ports that I have been tasked with configuring for a client. On Ethernet 0 (AUI 0), the client is using a class A WAN address with a class A subnetted mask. On Ethernet 1 (AUI 1), they are using a class A LAN private address with a class C subnet mask, 255.255.255.0. When I try to add that IP address/Subnet mask combination, I get an error stating "bad mask /24".

    How do I add that IP/Mask combination? My command is standard:

    ip address 10.0.0.100 255.255.255.0

    Any help is greatly appreciated.

  • #2
    Re: Class A IP address with a Class C Mask

    isn't it: ip address 10.0.0.100 0.255.255.255

    Comment


    • #3
      Re: Class A IP address with a Class C Mask

      Hiya,

      Danny, thats an acl ip/mask combination: ip address 10.0.0.100 0.255.255.255.

      Tons of fun, you are correct in your syntax for this command, so thats not the problem here. It could be your version of IOS. Can you do two things please:

      -type 'show version' at the console and post the output
      -in configure mode, type 'ip classless'

      It sounds like either the router has an elderly IOS that can only do classful addressing or it has a later IOS thats set to only do classful.

      Let us know-

      theterranaut

      Comment


      • #4
        Re: Class A IP address with a Class C Mask

        Thank you very much for the reply. I had already typed in ip classless. Here is my sho version. As you can see, I also ran sho run so you can see my config. If my version of IOS is too old, I do have two other Cisco routers with newer IOS's. Is it possible to extract an IOS from one 2500 router to another? Anyway here it is:

        Firewall#sho ver
        Cisco Internetwork Operating System Software
        IOS (tm) 2500 Software (C2500-D-L), Version 11.2(26e), RELEASE SOFTWARE (fc1)
        Copyright (c) 1986-2003 by cisco Systems, Inc.
        Compiled Fri 04-Jul-03 04:04 by cmong
        Image text-base: 0x0302BC1C, data-base: 0x00001000

        ROM: System Bootstrap, Version 11.0(10c), SOFTWARE
        BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFT
        WARE (fc1)

        Firewall uptime is 3 days, 23 hours, 10 minutes
        System restarted by power-on
        System image file is "flash:c2500-d-l.112-26e.bin", booted via flash

        cisco 2500 (68030) processor (revision L) with 2048K/2048K bytes of memory.
        Processor board ID 09264394, with hardware revision 00000000
        Bridging software.
        X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.
        2 Ethernet/IEEE 802.3 interface(s)
        2 Serial network interface(s)
        32K bytes of non-volatile configuration memory.
        8192K bytes of processor board System flash (Read ONLY)

        Configuration register is 0x2142

        Firewall#sho run
        Building conf

        Current configuration:
        !
        version 11.2
        no service password-encryption
        no service udp-small-servers
        no service tcp-small-servers
        !
        hostname Firewall
        !
        enable secret 5 $1$Zxwd$k0.tp7LWwmu2k.ikdISC.0
        !
        no ip domain-lookup
        ip domain-name corporateofc.com
        ip name-server 10.0.0.10
        ip name-server 205.152.144.23
        ip name-server 205.152.37.23
        !
        interface Ethernet0
        description WAN Port
        ip address 70.147.97.107 255.255.255.248
        !
        interface Ethernet1
        description LAN Port
        ip address 10.0.0.100 255.0.0.0
        !
        interface Serial0
        no ip a
        shutdown
        !
        interface Serial1
        no ip address
        shutdown
        !
        router rip
        network 10.0.0.0
        network 70.0.0.0
        !
        ip classless
        ip route 0.0.0.0 0.0.0.0 70.147.97.105
        banner motd ^C ...power...prestigue...a jedi need not these things ^C
        !
        line con 0
        login
        line aux 0
        login
        line vty 0 4
        login
        !
        end


        Thanks again for taking a look at this.

        Tons of Fun

        Comment


        • #5
          Re: Class A IP address with a Class C Mask

          Tons- sorry, I led you down the garden path with this one! It was early in the morning and I hadn't had any coffee! I've just noticed my mistake-


          This is, in fact, (at least in the general case anyway) the wrong mask for the IP you are using.

          The IP is given as: 10.0.0.100.

          Because the middle two octets are zero, this can only be a 'classful' address; ie, an 8 bit mask, so 255.0.0.0- UNLESS, of course, the router has been issued the command

          ip subnet zero

          in configure mode.

          This allows the use of the specialised 0 address, normally denoting a network, to act as an ordinary address.

          Try that, should work, I think your IOS is modern enough.

          regards,

          theterranaut
          Last edited by theterranaut; 13th October 2006, 16:26.

          Comment


          • #6
            Re: Class A IP address with a Class C Mask

            That was it! Thank you very much, now I can continue on. I do have one more question if you don't mind. The config register was not correct, so when I brought it home to complete, it erased everything. I changed the register to 0x2102, but now I have (boot) in my hostname. It is:

            Firewall (boot)#

            It was not there before. What does the boot signify? I thought when I changed the register back to 0x2102, that would go away?

            Thanks again for the help getting the class issue corrected, that was causing me a lot of problems.

            Tons of Fun!

            Comment


            • #7
              Re: Class A IP address with a Class C Mask

              Hiya,

              I'm not too sure- normally, seeing 'boot' anywhere means you are in rommon mode- but as you've set a hostname for the device you must be booting into an IOS of some shape.

              I would check a couple of things:

              -have you issued a 'boot system flashyour IOS name here)" command in config mode? This makes sure the router is getting to the right file to boot, rather than into the ROM.

              -your config-register is definitely still at 0x2102? (use sh ver to check)

              -when you write any kind of config and reload, is your config staying put? ie, not going back into setup mode?

              theterranaut

              Comment


              • #8
                Re: Class A IP address with a Class C Mask

                Hi Tons of Fun,

                The "router(boot)# indicates that this router is in ROMMON mode. This means that the router could not successfully boot the IOS from its source. 99% of the time, the source for the IOS is the FLASH on the router.

                In rommon mode, (the router(boot)# prompt), I would verify the config register with o/r 0x2142 and reboot the router. Watch the boot up process carefully to see if there are errors (like "failed to boot from flash").

                In your previous config, the router was booting from flash but was bypassing the NVRAM. Still, the change you made shouldn't have made any difference on whether the router would boot from flash or not.

                If you can copy and paste the boot up process on the console of the router onto this forum, I can tell you why the router won't boot.

                Many times, the flash can go bad and you have to reload the IOS on the flash.

                Let us know.

                Thanks
                David
                David Davis - Petri Forums Moderator & Video Training Author
                Train Signal - The Global Leader in IT Video Training
                TrainSignalTraining.com - Free IT Training Products
                Personal Websites: HappyRouter.com & VMwareVideos.com

                Comment


                • #9
                  Re: Class A IP address with a Class C Mask

                  EDIT
                  Hi David,

                  Of course, you are right-


                  Just labbed this up.

                  I changed the config-register from a 'normal' one to 0x2100. This put the device into rommon mode. Sure enough, typing 'boot' from this
                  took me into an IOS with a prompt of "testname#(boot)"

                  Sh ver shows:

                  sh ver
                  Cisco Internetwork Operating System Software
                  IOS (tm) 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(8a), RELEASE SOFTWARE (fc1)
                  Copyright (c) 1986-1995 by cisco Systems, Inc.
                  Compiled Tue 24-Oct-95 15:46 by mkamson
                  Image text-base: 0x01020000, data-base: 0x00001000

                  ROM: System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE

                  testname uptime is 11 minutes
                  System restarted by reload
                  Running default software

                  cisco 2500 (68030) processor (revision N) with 2044K/2048K bytes of memory.
                  Processor board serial number 06097177 with hardware revision 00000000
                  X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.
                  1 Ethernet/IEEE 802.3 interface.
                  2 Serial network interfaces.
                  32K bytes of non-volatile configuration memory.
                  8192K bytes of processor board System flash partition 1 (Read/Write)
                  8192K bytes of processor board System flash partition 2 (Read/Write)

                  Configuration register is 0x2100

                  This section:

                  IOS (tm) 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(8a), RELEASE SOFTWARE (fc1)
                  Copyright (c) 1986-1995 by cisco Systems, Inc.
                  Compiled Tue 24-Oct-95 15:46 by mkamson
                  Image text-base: 0x01020000, data-base: 0x00001000

                  shows I'm in the limited IOS stored in ROM.

                  Issuing:
                  conf t
                  config-register 0x2102
                  reload

                  and I'm back into a normal IOS: sh ver shows

                  testname#sh ver
                  Cisco Internetwork Operating System Software
                  IOS (tm) 2500 Software (C2500-I-L), Version 12.1(22), RELEASE SOFTWARE (fc4)
                  Copyright (c) 1986-2003 by cisco Systems, Inc.

                  I'd forgotten that the rom IOS contains enough functionality to be able to read configs, if not make sense of all the commands.


                  Thanks!

                  theterranaut
                  Last edited by theterranaut; 17th October 2006, 11:57.

                  Comment


                  • #10
                    Re: Class A IP address with a Class C Mask

                    Good Job!

                    Thanks for the posts!

                    David
                    David Davis - Petri Forums Moderator & Video Training Author
                    Train Signal - The Global Leader in IT Video Training
                    TrainSignalTraining.com - Free IT Training Products
                    Personal Websites: HappyRouter.com & VMwareVideos.com

                    Comment


                    • #11
                      Re: Class A IP address with a Class C Mask

                      Hi guys, sorry about the delay, I have been traveling constantly lately. You are absolutely right, I found out that it was booting into Rommon. I also found out that after verifying that my register was 0x2102, if it continues to boot into Rommon, it's an indicator of potentially bad flash. We swapped out thwe flash, and sure enough, that was the problem. Thanks a lot for the help, this forum is a great forum, and I plan to hang out here quite a bit.
                      Now that you helped me get past my "class" issue, I believe my ACLs are causing problems. I am going to start a new thread because it is a new issue.

                      Thanks again

                      Comment

                      Working...
                      X