No announcement yet.

cannot logon with remote desktop

  • Filter
  • Time
  • Show
Clear All
new posts

  • cannot logon with remote desktop

    Hello all,
    Ive got a weird situation going on...
    i`am unable to logon on to my sbs server 2003 with remote desktop from inside the network and from the outside.
    the connection to the server is made i`ve got a normal logon screen when i fill in the credentials it try`s to logon it looks like the connection is made and then it goes back to the log on screen.

    i`m working with sbs 2003 what i`ve done so far is that i checked all event logs
    checked the firewall settings port 3389 is open.
    checking that users involved have the correct rights to logon to the server
    i use 2 nic`s so i`ve checked ras settings as well.
    i think for myself that it is a policy setting but i`m unsure


  • #2
    Re: cannot logon with remote desktop

    1. Try to use telnet from the local LAN to port TCP 3389 on the SBS - This will
    help us to understand if there connection to the server RDP.

    2. Firewall - I guess that you use firewall to connect the LAN to the internet and
    the SBS is used as firewall/dial point to the internet.
    I recommanded to use the SBS with a single network adapter and use
    Netscreen 5GT etc. to connect to the internet intead - so the firewall
    wouldnt be the SBS it self.
    Also, verity that there no firewall that blocks connection to the SBS.

    3. Open "Terminal Services Configuration" on the SBS and verity correct settings
    as other SBS 2003 servers that you use.
    You can try to force the RDP to listen only to the LAN NIC, if the SBS
    used as access point to the internet.

    4. Try to disable and enable RDP on the SBS.

    5. Verity that you use hardware that in Microsoft HCL. This issue can
    occur if install SBS on PC etc (For example - bad driver of the display adapter).


    Best Regards,

    Yuval Sinay

    LinkedIn:, Blog:


    • #3
      Re: cannot logon with remote desktop

      Hi thanks for a quick answer

      1 i can telnet the port from the lan and it will open a session

      2i`ve disabled the sbs firewall and use an external one and checked the settings they are 100% correct .

      it is not working from a client or from outside my network as you can read in the question i can connect to the sbs server but when i try to logon it logs en inmidiatly logs off .

      3 when i try to change a setting in terminal services configuration i`ve got an error message "To change permission compatibility settings you must switch to application server mode in terminal services" so that is not an option i think

      4 i`ve disabled rdp and enabled it . it doesn`t change anything .

      5 al my hardware is on the hcl except an onboard raid controller but it is disabled anyway.

      maybe you have another suggestion or anyone for that fact ..

      regards Marco


      • #4
        Re: cannot logon with remote desktop

        With what account are you trying to log in?
        Have you tried logging in with a local account?


        • #5
          Re: cannot logon with remote desktop

          thanks for the response.
          we are talking about small business server it is a DC it is not possible to log on local ....


          • #6
            Re: cannot logon with remote desktop

            Ah, you didn't mention it was a DC
            Have you tried logging in with more than one account?
            Do you see anything in the event log?


            • #7
              Re: cannot logon with remote desktop

              according to the event log i`ve succesfully logged on but inmiditelatly logged off
              so i am a little in the dark here.
              if there is a way to upload a little piece of the log so anybody can review it please let me know