Announcement

Collapse
No announcement yet.

Two Terminal Services servers that behave differently

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Two Terminal Services servers that behave differently

    I have two Windows Server 2003 terminal services servers. One is on Enterprise and is about 2 months old. The other I just put up and it is on Standard Edition. Both are on a common NT 4.0 domain, LAN and subnet. I have compared the settings of each, many times, and believe they are set the same in the Terminal Service Configuration utility.

    On the older one, the logon script is run before displaying the desktop or running a program specified to launch at connection time. On the newer one, the desktop or program to launch is processed in parallel with the logon script. When the program depends on maps done in the logon script - well, you can imagine, this causes unpredictable behavior.

    Any one else seen this behavior and/or know what controls it?

    Thank you,
    Clay

  • #2
    Re: Two Terminal Services servers that behave differently

    There few known issues for this problem:

    1. Maybe the first server was setup to allow "Run login script asynchronously"
    via the local group policy.

    2. One server was setup to run in Application mode and the other use
    Remote Desktop mode.

    3. The script content or/and paths or/and the implment of the script arent the
    same in both servers.


    http://www.microsoft.com/technet/pro...ep/gpfeat.mspx

    Please update us if this information was useful.
    Best Regards,

    Yuval Sinay

    LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

    Comment


    • #3
      Re: Two Terminal Services servers that behave differently

      yuval14,

      I found a registry hack to add a key to have the login scripts run synchronous:

      HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

      REG_DWORD: RunLogonScriptSync

      Range: 0 | 1

      0 = Async; 1 = Sync

      Now, off to make it hidden!

      Thanks!

      Comment

      Working...
      X