Announcement

Collapse
No announcement yet.

Problem setting up terminal server session broker

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem setting up terminal server session broker

    I have a system with two terminal servers and a dedicated terminal server broker.

    I have set everything up as per this guide:

    http://technet.microsoft.com/en-us/l...(v=ws.10).aspx

    I have not set up DNS round robin yet, but as I understand the guide, that is not a requirement, it just balances the initial logon requests bwtween servers.

    As I understand the guide, I have configured the ts broker with the session broker role, I have added the two TS servers to the local farm members group on the session broker.

    I have configured each terminal server to be a member on the same farm.

    I beleive that now when I log on to either of the terminal servers, it should automatically query the session broker, and decide which server should handle that particular session.

    But its not working - whatever terminal server I log on to, it always just logs me in to that physical server.

    Am I missing something??
    David Silvester
    Systems Administrator

  • #2
    Re: Problem setting up terminal server session broker

    Hello

    you must create 2 record A with same name and different IP Address
    you need in the server broker add 2 Server to group :Session Broker Computers"
    "

    dont forget applied policy on terminal server computer .

    good luckl

    Comment


    • #3
      Re: Problem setting up terminal server session broker

      Originally posted by Meirp View Post
      Hello

      you must create 2 record A with same name and different IP Address
      you need in the server broker add 2 Server to group :Session Broker Computers"
      "

      dont forget applied policy on terminal server computer .

      good luckl
      On the session Broker server I have added both terminal servers to the session broker computers local group.

      then on each terminal server, in remote desktop session host configuration, I have set up farm membership, typed in DNS name for the session broker, and then used the same farm name on both.

      still every time I connect, log off and connect again, I automatically connect to the server whose IP I typed into remote desktop computer field.

      I understand that I am supposed to set up two A records of same name but different IP addresses - so when a client queries that FQDN, they will get several IP addresses returned, and pick the top 1 - as I understand it, this helps to balance the initial connection requests between terminal servers, but I don't think its a necessity is it?

      Whichever server gets the initial login request, it should still query the session broker and then pass the request on accordingly shouldn't it??

      Maybe I am missing something else?

      I did try connecting with administrator account, maybe that is exempt from being brokered?
      David Silvester
      Systems Administrator

      Comment


      • #4
        Re: Problem setting up terminal server session broker

        Originally posted by davids355 View Post
        On the session Broker server I have added both terminal servers to the session broker computers local group.

        then on each terminal server, in remote desktop session host configuration, I have set up farm membership, typed in DNS name for the session broker, and then used the same farm name on both.

        still every time I connect, log off and connect again, I automatically connect to the server whose IP I typed into remote desktop computer field.

        I understand that I am supposed to set up two A records of same name but different IP addresses - so when a client queries that FQDN, they will get several IP addresses returned, and pick the top 1 - as I understand it, this helps to balance the initial connection requests between terminal servers, but I don't think its a necessity is it?

        Whichever server gets the initial login request, it should still query the session broker and then pass the request on accordingly shouldn't it??

        Maybe I am missing something else?

        I did try connecting with administrator account, maybe that is exempt from being brokered?
        Hello Again .
        you must enable round robin in dns server from what i remember round robin is allowed by default .
        yes my friend create 2 A record with same name is necessary and must
        we are missing a little something .
        i think you problem is in group policy settings
        you configured right policy ?
        please cancel local Firewall in terminal server and Broker server ?

        i wait for you answer
        thank u

        Comment


        • #5
          Re: Problem setting up terminal server session broker

          Originally posted by Meirp View Post
          Hello Again .
          you must enable round robin in dns server from what i remember round robin is allowed by default .
          yes my friend create 2 A record with same name is necessary and must
          we are missing a little something .
          i think you problem is in group policy settings
          you configured right policy ?
          please cancel local Firewall in terminal server and Broker server ?

          i wait for you answer
          thank u
          Should the round robin be set up at the host for the domain/FQDN, or on the local domain server?

          I havent added anything in group policy, I thought changes could be made in group policy OR just by configuring each terminal server individually to be part of the farm.?

          OK, Firewalls I can turn off and see if that helps.

          Ah, now you have made me think - we do actually have some NAT going on so not sure if that would effect it - we have a public IP for each of the servers, and also private IPs, and then pfsense firewall handles the NAT between them... maybe thats why its not working?
          David Silvester
          Systems Administrator

          Comment


          • #6
            Re: Problem setting up terminal server session broker

            Originally posted by davids355 View Post
            Should the round robin be set up at the host for the domain/FQDN, or on the local domain server?

            I havent added anything in group policy, I thought changes could be made in group policy OR just by configuring each terminal server individually to be part of the farm.?

            OK, Firewalls I can turn off and see if that helps.

            Ah, now you have made me think - we do actually have some NAT going on so not sure if that would effect it - we have a public IP for each of the servers, and also private IPs, and then pfsense firewall handles the NAT between them... maybe thats why its not working?
            listen is uncomplicated - in DNS server you have to do 2 things .

            1. Enable round robin see below:


            2. open 2 record with same name but different IP ( terminal server | no Broker IP )


            note:
            1) you need to applied GPO ( its very important to do its Correctly)
            2)in terminals server have group call "Remote Desktop Users" please add there the users that allow access terminal

            3)open terminal and follow these steps :



            click "change settings"


            and add termianl server as farm member :


            please do it also second server.

            a week ago i a published a guide about Termianl Server :
            http://netsystem.org.il/index.php/to...minal-server/#

            but the guide is hebrew language (sorry ) maybe the Illustrations can help u ..

            i wait for answer you thank

            Comment


            • #7
              Re: Problem setting up terminal server session broker

              ^^ Ah that makes sense now. I completely misunderstood what was meant by round robin!

              OK, I will try this after hours this evening and report back.
              thanks.
              David Silvester
              Systems Administrator

              Comment


              • #8
                Re: Problem setting up terminal server session broker

                Its still not working, but there is another thing I am not sure about.

                I have the following configuration:

                Both servers are accessed over the WAN.

                both servers have their own public IP addresses which we use when connecting to them via RDP.

                They also have their own local IP addresses - which are assigned on their NICs.

                We have a firewall that NATs between remote and local IP.

                so when I set up the servers as farm members, it says that the local IP addresses are used for reconnection - will this work?

                And also, in the round robin config, I have two A records with the same host (the farm name) but do I use the local IPs or the remote IPs?
                David Silvester
                Systems Administrator

                Comment

                Working...
                X